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INSTALLATION 

When installing BIOMA, you have to distinguish between client and server installation: 

• Server installation refers to installing on a computer that serves as a database server. 
• Client installation refers to installing on a computer that only hosts the BIOMA software alone. 

If you install for a single user, both installations will be carried out on the same computer. 

SYSTEM REQUIREMENTS 

SUPPORTED OPERATING SYSTEMS 

• Windows 7  
• Windows 8 
• Windows Server 2003  
• Windows Server 2008  
• Windows 8.1 to Windows 11 (32/64 Bit) 
• Windows Server 2012 bis Windows Server 2019 

ADDITIONAL SOFTWARE 

• Microsoft Excel (to process exported data)   

COMPONENTS 

Usually, the components needed to run BIOMA are already included in the above-mentioned operating systems. If 
not, click the following links to download the required part: 

• .NET Framework 3.5 Service Pack 1 (EOL 9. Jan 2029) 

If you are using Windows 10, Windows Server 2016, or Windows Server 2019, we recommend installing .NET 
Framework 3.5 through the control panel. 

DEMO MODE 

For running BIOMA in demo mode, no database installation is required. Thus, it is necessary to follow the 
installation guidelines under Client Installation only! 

SERVER INSTALLATION 

Microsoft SQL Server 2019 is the recommended database server. If this database server is not available on your 
system, you can use the free Microsoft SQL Server 2019 Express Edition. 

BIOMA 2.6.401 also works with every other Microsoft SQL Server version that supports compatibility level 100 
(Microsoft SQL Server 2008 to 2019). 

It is recommended (but not necessary) to backup the BIOMA database on your old SQL server before installing 
Microsoft SQL Server 2019. 

https://dotnet.microsoft.com/en-us/download/dotnet-framework/net35-sp1
https://docs.microsoft.com/dotnet/framework/install/dotnet-35-windows-10?WT.mc_id=dotnet-35129-website
https://docs.microsoft.com/dotnet/framework/install/dotnet-35-windows-10?WT.mc_id=dotnet-35129-website
https://docs.microsoft.com/en-us/sql/t-sql/statements/alter-database-transact-sql-compatibility-level?view=sql-server-ver15
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STEP 1 – INSTALLATION OF DATABASE SERVER 

• Download the SQL Server 2019 Express installer (SQLServer2019-SSEI-Expr) from Microsoft SQL Server 
2019 Express Edition that, when executed, will present options to perform an installation or download 
media only. 

 

• Execute the downloaded file SQL2019-SSEI-Expr.exe. 
• Select Download Media. 

 
 

  

https://www.microsoft.com/en-US/download/details.aspx?id=101064
https://www.microsoft.com/en-US/download/details.aspx?id=101064


 

 Installation  •  3 

• To download the needed setup file (SQLEXPR_x64_ENU.exe), select language English, package Express 
Core, the desired Download Location, and click Download. 

 

• Click Close. 

 

• Execute the downloaded setup file SQLEXPR_x64_ENU.exe. 
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• Choose the directory to extract the file to and click OK. 

 

• Select New SQL Server stand-alone installation or add feature to an existing installation. 
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• Accept the license terms and click Next. 

 

• The firewall warning can be ignored. Click Next. 
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• Click Next. 

 

• Click Next. 
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• Click Next. 

 

• Select Mixed mode, type an administrator password (for admin sa) and press Next. 
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• When the installation is completed, click Close. 

 

STEP 2 – BIOMA INSTALLATION (ON SERVER) 

It is necessary to install BIOMA directly on the server because, together with the BIOMA software, an additional 
tool called BIOMA Database Setup Utility is installed, which can be used to create the database (cf. Step 3 – 
Creation of Database). 

WARNINGS: 

1. Running the setup program of BIOMA 2.6.401 will delete all older versions of BIOMA on this computer!  
So, if you want to test BIOMA 2.6.401 before deleting any older version, you can, alternatively, 

a. install and run BIOMA for testing reasons in a virtual machine, or 
b. install BIOMA on a different computer (where no BIOMA has been installed before), and copy the 

content of the folder C:\Program Files (x86)\inka software\BIOMA 2.6.401 to the computer with 
the old BIOMA version. Note that with the latter procedure, no icons will be added to the 
desktop of the start menu, the file extensions of BIOMA are not automatically assigned to the 
new version, the BIOMA Job Server is not installed automatically, and you have to start BIOMA 
manually by clicking WteClient.exe in the folder BIOMA 2.6.401. 

2. To migrate the data of a plant document, it is recommended to start the old version of BIOMA and export 
a report package (cf. Export / Edit Report Package (a)) with a reporting period set that includes all 
available data in the database (cf. Edit Operation Data (e)). For this reason, it is not necessary to set any 
manual inputs. This exported report package can be imported later in the new version of BIOMA. 
 

• Execute setup.exe in the BIOMA folder. 
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• Click Next. 

 

• Click Install. 
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• When the installation is completed, click Finish to exit the installation  

 

STEP 3 – CREATION OF DATABASE 

To create a database, the BIOMA Database Setup Utility can be used. It is, of course, also possible for a database 
admin to create the database manually. 

• Select START > All Programs > BIOMA 2.6.401 > Database Setup Utility. 
• On tab Database server, click Test connection. If you choose a different mode than Windows 

Authentication, the login (sa) and password data from Step 1 – Installation of Database Server have to be 
used. 

 

• On tab Installation, click Create database and confirm the warning with Yes. If the user name and 
password for the BIOMA client are changed here, these changes must be considered during the 
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configuration of the database connection on the client computer (cf. Step 2 – Configure Client Database 
Connection). 

 

• Check if the database has been created successfully (last line of text above). 

STEP 4 – SERVER CONFIGURATION (ONLY IN MULTI-USER OPERATION) 

If the BIOMA software should run on the computer that is hosting the database server only, you can skip Step 4. 

But if the database server has to be accessed from a different computer (client), the server must be reachable from 
within the network. The necessary configurations can be carried out with SQL Server Configuration Manager, 
which is also part of Microsoft SQL Server 2019 Express Edition. 

• Select START > All Programs > Microsoft SQL Server 2019 > SQL Server Configuration Manager. 
• Select SQL Server Network Configuration > Protocols for SQLEXPRESS. Right-click TCP/IP and select 

Properties. 

 

  



 

 Installation  •  12 

 

• On tab Protocol, set Enabled to Yes. 

  

• On tab IP Addresses, under IP All, set TCP Port to 1433. Click OK. 

 

• Close the SQL Server Configuration Manager. 
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Additionally, configure an exception for TCP port 1433 in your firewall. The following description is for Windows 10: 

• Click START. Enter windows firewall in the Search field. Select Windows Defender Firewall with 
Advanced Security from the search results. 

 

• Select Inbound Rules and click New Rule. 
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• Click Rule Type and select Port. Click Next. 

 

• Click Protocol and Ports, select TCP and enter 1433 under Special local ports. Click Next. 
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• Select Allow the connection and click Next. 

 

• Click Next. 
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• Enter a Name for the exception rule and click Finish. 

 

 

CLIENT INSTALLATION 

• If the BIOMA software should run on the computer that is hosting the database server, you can skip Step 1 
– BIOMA Installation (on Client) because the software should be already installed there. In this case, 
continue with Step 2 – Configure Client Database Connection. 

STEP 1 – BIOMA INSTALLATION (ON CLIENT) 

WARNINGS: 

1. Running the setup program of BIOMA 2.6.401 will delete all older versions of BIOMA on this computer!  
So, if you want to test BIOMA 2.6.401 before deleting any older version, you can, alternatively, 

a. install and run BIOMA for testing reasons in a virtual machine, or 
b. install BIOMA on a different computer (where no BIOMA has been installed before), and copy the 

content of the folder C:\Program Files (x86)\inka software\BIOMA 2.6.401 to the computer with 
the old BIOMA version. Note that with the latter procedure, no icons will be added to the 
desktop of the start menu, the file extensions of BIOMA are not automatically assigned to the 
new version, the BIOMA Job Server is not installed automatically, and you have to start BIOMA 
manually by clicking WteClient.exe in the folder BIOMA 2.6.401. 

2. To migrate the data of a plant document, it is recommended to start the old version of BIOMA, and export 
a report package (cf. Export / Edit Report Package (a)) with a reporting period set that includes all 
available data in the database (cf. Edit Operation Data (e)). For this reason, it is not necessary to set any 
manual inputs. This exported report package can be imported later in the new version of BIOMA 



 

 Installation  •  17 

 
• Execute setup.exe in the BIOMA folder. 
• Click Next. 

 

• Click Install. 
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• When the installation is completed, click Finish to exit the installation  

 

STEP 2 – CONFIGURE CLIENT DATABASE CONNECTION  

If the standard installation of the database server has been performed, nothing has to be changed. If a different 
database server is accessed or e.g., windows authentication is used, the settings have to be adjusted. 

• Start BIOMA. 
• Login with user name expert and default password demo. 
• Select Extras > Options. 

 

• On tab Database, state the Server name that should be used. 
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• Click Test connection. 

 

• Click OK. 

If the warning Error establishing database connection! is displayed, the server is not configured for SQL Server 
Authentication, and Windows Authentication should be used. 

TROUBLE SHOOTING 

CHANGING OF SERVER AUTHENTICATION MODE (EXISTING SQL-SERVER INSTALLATIONS) 

By default, BIOMA uses “SQL Server Authentication” when connecting to the database server. If "Windows 
Authentication" was selected during the installation of the SQL-Server, you can change this later with the free tool 
“Microsoft SQL Server Management Studio (SSMS)”. 

• Download and install “SSMS-Setup.ENU.exe” 

  
 

https://aka.ms/ssmsfullsetup
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• Start “SQL Server Management Studio 1”

 

• Click “Connect”. 

 

• Right click the database server and choose “properties”. 
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• Select “Security”, choose “SQL Server and Windows Authentication mode” and click “OK”. 

 

• Close the “SQL Server Management Studio Express” window.
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QUICK START WITH BIOMA 

Here, you find quick-start instructions on how to work with BIOMA. For more detailed information, see Menu 
Description. 

The letter in the brackets directly after a headings refers to necessary minimum access rights (user < administrator 
< expert < developer). 

• A user has the rights to import operational data and display the results of the calculation for several 
parameters. 

• An administrator has the additional rights to perform plant and program configurations and create report 
packages. 

• An expert has the additional rights to edit operational data, import report packages, and create reports. 
• A developer has the additional rights to display and edit the calculation algorithm, change permission 

group settings, and issue licenses. 

DEMO MODE 

When BIOMA is run in demo mode (that means that no valid license file has been installed), it is NOT possible to 
create new plant documents, import data, or crate report packages. All changes applied to the sample data will be 
deleted when the software is closed. 

If you want to access the demo data also later when you have installed a valid license, rename a copy of demo.dat 
(under C:\Program Files (x86)\inka software\BIOMA 2.6.401\Testdata\) to demo.brpz, and import the report 
package into BIOMA. Note that the file Demodata2021.csv, which can be found in the same folder, contains all the 
operational data from the demo plant and has been originally used to import the data to the empty demo plant 
document. 

LOGIN (U) 

Log in to the BIOMA software. 

• Select File > Login. 
• Log in with user name expert and password demo (if you are in demo mode or you have installed an 

expert license). 
• You are now logged in with expert privileges. 

 

INSTALL LICENSE (A) 

Install a license file. If you do not, BIOMA will run in demo mode where all changes applied to the example data set 
will not be saved. 

• Select Help > About. 
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• Click Install License. 

 

• Choose the license file (e.g., company_name.license) you got when buying BIOMA. 

 

• Click Update if the expiration date and the licensee shall be updated. All existing credentials will be kept. 
• Click Install if a new license shall be installed. The existing license will be overwritten, and all existing 

credentials (users and passwords) will be lost. 
• Confirm the appearing message by clicking Yes. 
• Restart BIOMA. 
• Log in again (use admin/demo with client licenses and expert/demo with developer licenses). 

OPEN PLANT DOCUMENT (U) 

Open a plant document of your choice. 

• Select File > Open Plant Document. 
o When BIOMA is run in demo mode, the only plant document available is Sample Plant (2021). 
o When BIOMA is run with a valid license for the first time, a new plant document with the name 

New plant created at [date time] is available. Select this entry if you want to design a plant 
document from scratch. 

o Alternatively, import a report package (cf. Import Report Package (a)). 
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o If plant documents have already been created with a previous version of BIOMA and the SQL 
database has been left untouched, all plant documents available in this database should be 
displayed. 

• Select a plant document, tick Open on program start and click OK. 

 

EDIT PLANT CONFIGURATION (A) 

Edit general plant information and specific parameters information. 

• Select Edit > Edit Plant Configuration. 
• On tab Plant, you can enter Plant name, the type of Energy production (Steam/Hot water), Address, and 

optionally Remarks.  

 

• On tab Contact Person, you can enter a contact person's name, email, telephone, and fax. 

 



 

 Quick Start with BIOMA  •  26 

• On tab Parameters, edit plant-specific parameters (if necessary). The default settings are taken from 
C:\Program Files\inka software\BIOMA 2.6.401\Template\Parameter.xls. The following settings can be 
changed. 

Data Source: 

o Default values will be the same during online calculation and in the report package. 
o Manual and Manual total values have to be updated manually when creating a report package. 

Manual values represent relations [e.g., kg/kg], while Manual total values represent mass and 
volume flows over the total reporting period. 

o Control System values are directly produced from the control system and will be imported via 
CSV file. 

o None should be chosen if a parameter is not necessary for calculation (e.g., if no sludge is burned, 
select none for mslu). 

Use defaults: 

o If the tick use defaults is set, it indicates that during online calculation the default settings (mean 
value and standard deviation) should be used (if given) when no data is available from the control 
system. 

o During online calculation, the default values of Default and Manual values are always used. 

 Min and Max: 

o Here, the parameters' allowed minimum and maximum values can be stated, which are used for 
plausibility checks. 

Value and Uncertainty: 

o Enter the mean value and the standard uncertainty of a parameter. 

+/- Manual [%]: 

o This standard uncertainty in % will be used during calculation. If it is not given, it will be 
computed from the given mean value and absolute uncertainty. Note that this is the relative 
standard uncertainty of the parameters on a daily basis! Because this is a random uncertainty, it 
will get smaller the larger the considered period is (by the factor 1/sqrt(n), where n is the number 
of days in the period considered). 
 
𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑛𝑛2 = 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑2 /𝑛𝑛 

+/- Systematic [%] (E): 

o If the reduction mentioned above is too fast, a “systematic” part can be introduced, that will not 
reduce when n is rising: 
 
𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑛𝑛2 = 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑠𝑠𝑠𝑠𝑠𝑠2 + (𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑2 − 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑠𝑠𝑠𝑠𝑠𝑠2 )/𝑛𝑛 
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Factor for Uncertainty Calculation (E): 

o Additionally, from the remaining random part 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑2 − 𝑢𝑢𝑠𝑠𝑠𝑠𝑠𝑠2  a certain fraction 𝐹𝐹 can be 
declared to be also “systematic”, and thus not being reduced if n is rising: 
 
𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑛𝑛2 = 𝑢𝑢𝑠𝑠𝑠𝑠𝑠𝑠2 + (𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑2 − 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑠𝑠𝑠𝑠𝑠𝑠2 ) 𝐹𝐹2 +  ((𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑2 − 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑠𝑠𝑠𝑠𝑠𝑠2 ) − (𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑2 − 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑠𝑠𝑠𝑠𝑠𝑠2 ) 𝐹𝐹2)/𝑛𝑛 
𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑛𝑛2 = 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑠𝑠𝑠𝑠𝑠𝑠2 + (𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑2 − 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑠𝑠𝑠𝑠𝑠𝑠2 ) (𝐹𝐹2 + (1 − 𝐹𝐹2)/𝑛𝑛 

  

• On tab Oven Lines, click + to add an oven line. 
• Select an existing oven line and click … at the end of the row to edit oven line properties. 
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• On tab Common, edit the name and the display color of the oven line. 

 

• On tab Parameters, edit oven line-specific parameters (if necessary). 

  

IMPORT CONFIGURATION 1 (A) 

Define the structure of the data in the CSV file to be imported. 

• Select Edit > Import Operation Data. 
• On tab Import, select Import of control system data from CSV file. 
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• Click Settings to change the CSV import definition settings. 

 

• On tab Common, choose the language, column separator, position of date column, and first data row of 
the CSV file. 

• Select an offset for Mwaste. This is the time from when the waste is taken from the bunker until 
combustion takes place. The best practice is 2 hours. 

 

• On tab Column mapping, you can edit already existing import settings or create new entries. An example 
setting is displayed in the graph below. 

• In the row marked by a *, you can add a new import parameter by selecting a component (oven line), a 
parameter key, and a column reference. Note: you have to click the empty field below component or 
parameter key to display the respective drop-down list. 

• Alternatively, you can edit any existing parameter by changing the entries in the respective row. 
• Click OK. 
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• If you want to import control system data automatically, click Close (!). 
• If you want to import a CSV file manually, select a source file and click Start. 

IMPORT CONFIGURATION 2 (A) 

Define the (import, backup, error) directories of the CSV files, set the import interval and enable the import timer. 

• Select Extras > Options > tab Import. 
• Choose Import Directory. This is the folder where the CSV data file has to be placed to be automatically 

imported. 
• Choose Backup Directory. If the data import was successful, the CSV file will be moved from Import 

Directory to Backup Directory). 
• Choose Backup Directory. If the data import was unsuccessful, the CSV file will be moved from Import 

Directory to Error Directory). 
• Set Import interval (seconds) and tick Enable import timer to activate automatically importing of data. 

The Import Directory will be checked according to the time stated if new data is available. 
• Set the number of backup files that should be kept before starting to delete the oldest. 
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The flow of the .csv file is depicted below. 

CMS/Reporting 
System

BIOMA

Successful import
Unsuccessful import 

(Problem with .csv file)

BIOMA PC/SERVER

1) Your CMS/Reporting System 
generates .csv file containing 
operation data. The .csv file is 
placed in a specified folder 
(‘import directory’)

2) BIOMA imports data from all 
CSV files from the ‘import 
directory’ into its internal 
database

3) If the data import is 
successful, BIOMA moves the 
.csv file to the ‘Backup 
directory’. If the data import is 
unsuccessful, the .csv will be 
moved to the ‘Error directory’

4) If you would like to reimport 
data, simply move files from 
the ‘Backup directory’ to the 
‘Import directory’

Import directory

Backup directory Error directory

Move .csv files to 
reimport into BIOMA

 

IMPORT DATA (U) 

Import data to your plant document. 

• Enable your control system to automatically produce CSV files with aggregated data for one hour (every 
full hour!). The time e.g., 01:00 stands for the time interval >0:00 to 1:00. 

• Copy these files automatically to the chosen Import Directory. 
• These files must obey the settings from Import Configuration 1 (a): E.g., 

,Mwaste,Vgas,Moil,mslu,Msteam,Tsteam,Psteam,TempH2,Vpgas,cO2pgas,Vfg,cO2fg,cCO2fg 
10.06.2022 16:00,20,,0,,100,400,40,125,,,125000,8.5,10.5 

• As soon as the first 4 hours of plausible data are available, a calculation will be performed, and the results 
will be displayed in the Graphical User Interface (GUI). 

USE GRAPHICAL USER INTERFACE (U) 

In the graphical user interface of BIOMA, the calculation results of selected parameters can be displayed 
graphically and by value. 
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• In the Status Panel, on tab Oven lines, select the oven lines you want to display in the graph. 

 

• In the Status Panel, on tab Parameters, administrators and experts can select the parameters they want 
to be visible to regular users. These parameters can be selected to be displayed in the graph, and their 
calculation results can be seen on tab Calculated data. (R … reconciled values, I … input values). 

o Select Show all settings. 
o Select Visible for those parameters that shall be available/visible for regular users. 
o Select Selected for those parameters that shall be displayed in the graph. This setting has an 

effect only if the respective parameters are also visible. 
o You can assign as many parameters as you want to two different y-axes (left and right). The first 

parameter selected to be displayed determines the unit of the assigned y-axis (left/right). From 
then on, parameters assigned to the same y-axis can be selected only if they have the same unit 
as the one of the respective y-axis. The same applies to the second y-axis. 

o You can select the desired marker type and the y-axis to be used, and edit the 
minimum/maximum values of the respective y-axis. 

o To get a parameter to the top of the list, change its order number in the first column. 
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• To show all calculation results of the chosen calculation interval, select tab Calculated data in the Status 
Panel. Here, you can select for which line and calculation step you want to display data. Additionally, it is 
possible to export this information into an XML file by clicking Export. 

 

• If you want to show the results for a different period 
o Click the button … next to Calculation interval (or the date/time button) 
o Select the calculation interval: 

 Past 8 hours (hour steps moving) = default setting, no date selection possible 
 8 hours (hour steps moving) 
 1 day (hours step moving) 
 1 week (days steps) 
 1 month (days steps) 
 1 year (month steps) 
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o Select the starting point of the calculation interval. 

 

o Click OK. 
o Alternatively, you can also use the arrows next to the date/time button to switch to the previous 

or calculation interval in steps. 

Notes: 

• Each data point displayed in a graph with hourly resolution represents the calculation results of the 4-
hour-moving-average. 

• If any troubles occur during calculation, the related messages will be displayed inside the Messages 
window. To clear this window, right-click on it and choose Clear output. 

• ATTENTION: No calculation uncertainties will be displayed. This feature is only available for experts (cf. 
Export Online Calculation Results (e)). 

EXPORT REPORT PACKAGE (A) 

Administrators can export report packages. A report package includes the complete data set for the selected 
reporting period (including the updated plant parameters, called manual inputs) but no computed results. 

• Select Reporting > Export/Edit Report Package. 
• Select the reporting period (e.g., 01.01.2021 – 31.12.2021). 
• Update plant parameters (tabs Common and Oven lines). This update is needed to correct the met 

assumptions necessary to perform online calculations. 
• If you don’t have the total values for Moiltot, Mslutot, Mwastetot and Vgastot, you can click Apply 

Defaults to compute the sum of the data from the database independent of the fact if the respective 
datasets are plausible or not. Note that Mashtot, Mscaptot and Mslagtot are set to zero because they are 
not needed for the computation. 

• Click Export, select a destination folder and click Save. 
• Click Save to store the changes. 
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IMPORT REPORT PACKAGE (A) 

If you get support in the form of an edited report package, you have to import it. 

• Select Reporting > Import Report Package. 
• Select a report package (extension *.brpz). 
• Click Open. 

The plant document is afterwards available under File > Open Plant Document.
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MENU DESCRIPTION 

Here, you find a detailed description of the menu entries. 

The letter in the brackets directly after the name of the menu entries refers to necessary minimum access rights 
(user < administrator < expert < developer). 

• A user has only the rights to import operational data and display the results of the calculation for several 
parameters. 

• An administrator has the additional rights to perform plant and program configurations and create report 
packages. 

• An expert has the additional rights to edit operational data, import report packages, and create reports. 
• A developer (hardware dongle needed) has the additional rights to display/edit an alternative calculation 

algorithm, issue licenses, and add/delete/edit user groups. 

MENU OVERVIEW (LINKED) 

 
File 

 
Edit Reporting 

 

∟ Login (u) ∟ Edit Plant Configuration (a) ∟ Export / Edit Report Package (a)  
∟ 

Logout (u) 
∟ 

Import Operation Data (u) 
∟  

Import Report Package (a) 
 

∟ Open Plant Document (u) ∟ Edit Operation Data (e) ∟ Building Reports (e)  
∟ New Plant Document (e) ∟ Calculate (u) ∟ Export Calculation Results (a/e)  
∟ Exit (u) ∟ Show Generated Source (d) ∟ Export Online Calculation Results (e)  

  ∟ Edit Calculation Source (d) ∟ Reference Systems (e)  
 
Extras Help 

 

∟ Options (a) ∟ About (a)  
∟ Change Log (e)      
∟ Administration (a/e)      

  ∟ Export Definition (E)    

  ∟ Plant Document Admin (a)  

 ∟ Users (a) and Permissions (d)  

           

FILE 

Here, you can find information on how to log in/log out and how to open/create new plant documents. 

LOGIN (U) 

You have to log in in order to be able to operate the BIOMA software. 

• In the menu, click File > Login. 
• Enter User Name and Password. 
• Directly after installation, the users “wte” (short for waste to energy; = regular user), “admin” or “expert” 

can be used. The default password for all of the is “demo”. 
• It is recommended to change these passwords (cf. Users (a) and Permissions (d)). 
• Select Auto Login if you want to log in automatically with the entered credentials when BIOMA is started. 
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LOGOUT (U) 

If you are logged in and you want to switch users, you have to log out before being able to log in with different 
credentials. 

• In the menu, click File > Logout to log off the currently logged-in user. 

OPEN PLANT DOCUMENT (U) 

Here, you can select the plant document you want to work with. 

• In the menu, click File > Open Plant Document. 
• Tick Open on program start if you want to open the selected plant document automatically when BIOMA 

is started. 
• Click OK. 

 

NEW PLANT DOCUMENT (E) 

Here, experts have to opportunity to create new plant documents. 

• In the menu, click File > Open Plant Document to create a new empty plant document, which can be 
edited afterwards under Edit > Edit Plant Configuration. 

EXIT (U) 

Here you can close the BIOMA software. 

• In the menu, click File > Exit to close the software BIOMA. 
• Alternatively, you can also click the x in the upper-right corner of the BIOMA user interface. 
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EDIT 

Here, you get information on how to edit plant/oven line configurations, import/edit operation data, perform 
online calculations, and implement own calculation source code. 

EDIT PLANT CONFIGURATION (A) 

Here, administrators can edit the plant configurations. 

• In the menu, click Edit > Edit Plant Configuration. 

BUTTON ADD NEW PARAMETERS (D) 

If changes to the parameter.xls have been applied, developers can add these changes to the plant document. 

• Click Add new parameters to update the database with parameters that have been added to the file 
C:\Program Files\inka software\BIOMA 2.6.401\Template\Parameter.xls. 

TAB PLANT 

This tab contains general information about the plant. 

• On tab Plant, enter the plant data (plant name, the type of energy produced (steam/hot water) address, 
and remarks). 

 

TAB CONTACT PERSON 

This tab contains general information about the contact person. 

• On tab Contact Person, enter the contact person's data (name, e-mail, telephone, fax). 
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TAB PARAMETERS 

This tab allows to apply changes to the parameters of the plant document. 

• On tab Parameters, the settings of the plant-specific parameters (concerning fuels and materials) can be 
edited. The default settings are taken from 
C:\Program Files\inka software\BIOMA 2.6.401\Template\Parameter.xls. The following settings can be 
changed: 

Data Source: 

o Default values will be the same during online calculation and in the report package. 
o Manual and Manual total values have to be updated manually when creating a report package. 

Manual values represent relations [e.g., kg/kg], while Manual total values represent mass and 
volume flows over the total reporting period. 

o Control System values are directly produced from the control system and will be imported via 
CSV file. 

o None should be chosen if a parameter is not necessary for calculation (e.g., if no sludge is burned, 
select none for mslu). 

Use defaults: 

o If the tick use defaults is set, it indicates that during online calculation the default settings (mean 
value and standard deviation) should be used (if given) when no data is available from the control 
system. 

o During online calculation, the default values of Default and Manual values are always used. 

 Min and Max 

o Here, the parameters' allowed minimum and maximum values can be stated, which are used for 
plausibility checks. 

Value and Uncertainty: 

o Enter the mean value and the standard uncertainty of a parameter. 
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+/- Manual [%]: 

o This standard uncertainty in % will be used during calculation. If it is not given, it will be 
computed from the given mean value and absolute uncertainty. Note that this is the relative 
standard uncertainty of the parameters on a daily basis! Because this is a random uncertainty, it 
will get smaller the larger the considered period is (by the factor 1/sqrt(n), where n is the number 
of days in the period considered). 
 
𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑛𝑛2 = 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑2 /𝑛𝑛 

+/- Systematic [%] (E): 

o If the reduction mentioned above is too fast, a “systematic” part can be introduced, that will not 
reduce when n is rising: 
 
𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑛𝑛2 = 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑠𝑠𝑠𝑠𝑠𝑠2 + (𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑2 − 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑠𝑠𝑠𝑠𝑠𝑠2 )/𝑛𝑛 

 

Factor for Uncertainty Calculation (E): 

o Additionally, from the remaining random part 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑2 − 𝑢𝑢𝑠𝑠𝑠𝑠𝑠𝑠2  a certain fraction 𝐹𝐹 can be 
declared to be also “systematic”, and thus not being reduced if n is rising: 
 
𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑛𝑛2 = 𝑢𝑢𝑠𝑠𝑠𝑠𝑠𝑠2 + (𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑2 − 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑠𝑠𝑠𝑠𝑠𝑠2 ) 𝐹𝐹2 +  ((𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑2 − 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑠𝑠𝑠𝑠𝑠𝑠2 ) − (𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑2 − 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑠𝑠𝑠𝑠𝑠𝑠2 ) 𝐹𝐹2)/𝑛𝑛 
𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑛𝑛2 = 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑠𝑠𝑠𝑠𝑠𝑠2 + (𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑑𝑑𝑎𝑎𝑎𝑎𝑎𝑎𝑎𝑎2 − 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑠𝑠𝑠𝑠𝑠𝑠2 ) (𝐹𝐹2 + (1 − 𝐹𝐹2)/𝑛𝑛 

 

If the mouse pointer hovers over the short term of a parameter, a detailed description is displayed as a tooltip.  

TAB HISTORY (E) 

On this tab (visible for experts only), experts can enter information about the history of the plant document. 
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TAB OVEN LINES 

This tab allows to apply changes to the parameters of the specific oven lines. 

• On tab Oven Lines 
o click + to add an oven line. 
o select an existing oven line and click – to delete it. 

 

EDIT OVEN LINE PROPERTIES (A) 

This is a subsection of Edit Plant Configuration. 

• In the menu, select Edit > Edit Plant Configuration. 
• On tab Oven lines, select an existing oven line and click … at the end of the row to edit the oven line 

properties. 

TAB COMMON 

This tab contains general information about a selected oven line. 

• On tab Common, enter oven line data (name, color, and remarks). 

 

TAB PARAMETERS 

This tab allows to apply changes to the parameters of the oven lines of a plant. 
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• On tab Parameters, the settings for oven line-specific parameters (concerning combustion air, fuels, 
incineration ash, steam loop, and total values for the reporting period) can be edited. The default settings 
are taken from C:\Program Files\inka software\BIOMA 2.6.401\Template\Parameter.xls. The following 
settings can be changed: 

Data Source: 

o Default values will be the same during online calculation and in the report package. 
o Manual and Manual total values have to be updated manually when creating a report package. 

Manual values represent relations [e.g., kg/kg], while Manual total values represent mass and 
volume flows over the total reporting period. 

o Control System values are directly produced from the control system and will be imported via 
CSV file. 

o None should be chosen if a parameter is not necessary for calculation (e.g., if no sludge is burned, 
select none for mslu). 

Use defaults: 

o If the tick use defaults is set, it indicates that during online calculation the default settings (mean 
value and standard deviation) should be used (if given) when no data is available from the control 
system. 

o During online calculation, the default values of Default and Manual values are always used. 

 Min and Max 

o Here, the parameters' allowed minimum and maximum values can be stated, which are used for 
plausibility checks. 

Value and Uncertainty: 

o Enter the mean value and the standard uncertainty of a parameter. 

+/- Manual [%]: 

o This standard uncertainty in % will be used during calculation. If it is not given, it will be 
computed from the given mean value and absolute uncertainty. Note that this is the relative 
standard uncertainty of the parameters on a daily basis! Because this is a random uncertainty, it 
will get smaller the larger the considered period is (by the factor 1/sqrt(n), where n is the number 
of days in the period considered). 
 
𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑛𝑛2 = 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑2 /𝑛𝑛 

+/- Systematic [%] (E): 

o If the reduction mentioned above is too fast, a “systematic” part can be introduced, that will not 
reduce when n is rising: 
 
𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑛𝑛2 = 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑠𝑠𝑠𝑠𝑠𝑠2 + (𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑2 − 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑠𝑠𝑠𝑠𝑠𝑠2 )/𝑛𝑛 
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Factor for Uncertainty Calculation (E): 

o Additionally, from the remaining random part 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑2 − 𝑢𝑢𝑠𝑠𝑠𝑠𝑠𝑠2  a certain fraction 𝐹𝐹 can be 
declared to be also “systematic”, and thus not being reduced if n is rising: 
 
𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑛𝑛2 = 𝑢𝑢𝑠𝑠𝑠𝑠𝑠𝑠2 + (𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑2 − 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑠𝑠𝑠𝑠𝑠𝑠2 ) 𝐹𝐹2 +  ((𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑2 − 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑠𝑠𝑠𝑠𝑠𝑠2 ) − (𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑2 − 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑠𝑠𝑠𝑠𝑠𝑠2 ) 𝐹𝐹2)/𝑛𝑛 
𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑛𝑛2 = 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑠𝑠𝑠𝑠𝑠𝑠2 + (𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑𝑑2 − 𝑢𝑢𝑟𝑟𝑟𝑟𝑟𝑟,𝑠𝑠𝑠𝑠𝑠𝑠2 ) (𝐹𝐹2 + (1 − 𝐹𝐹2)/𝑛𝑛 

If the mouse pointer hovers over a short term of a parameter, a detailed description is displayed as a tooltip.  

  

IMPORT OPERATION DATA (U) 

Here, users can import operation data. 

• In the menu, select Edit > Import Operation Data. 

TAB IMPORT 

On this tab, the import definition and the source of the data to be imported can be selected. 

• Select tab Import to manually import operational data. 
• Select an import definition. At the moment, Import of control system data from CSV file is available only. 
• Click Settings to change the CSV import definition settings (admins only) 
• Click … to select a Source file. 
• Click Start. 
• See Import protocol if the selected data has been imported successfully. 
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TAB PROTOCOLS 

On this tab, you see the log file of all import and export operations. 

• Select tab Protocols to display detail about the data import. 

 

CSV IMPORT CONFIGURATION (A) 

This is a subsection of Import Operation Data. 

• In the menu, select Edit > Import Operation Data. 
• On tab Import, click Settings to change the CSV import definition settings. 

TAB COMMON 

On this tab, you can find common information about the structure of the CSV file. 

• On tab Common, the general settings for importing the data from the CSV file can be edited. 
• Select language, column separator, date column, and first data row. 
• Select an Offset for Mwaste. This is the time from when the waste is taken from the bunker until 

combustion occurs. The best practice is two hours. That means that the measured waste mass for a point 
in time will be assigned to the remaining data set measured two hours later. 
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TAB COLUMN MAPPING 

On this tab, you define which column of the CSV file represents which parameter. 

• On tab Column Mapping, the columns of the CSV file are mapped to the respective parameters. 
• Add a parameter by selecting an oven line, a parameter key, and inserting a column reference in the row 

marked by a *. 
• Delete a parameter by selecting the grey box in front of a parameter row and pressing delete. 

 

Notes: 

• Columns are addressed with a capital C followed by the column number. 
• It is also possible to state equations using these column numbers (see e.g., parameter cCO2fg). 

EDIT OPERATION DATA (E) 

Here, the imported operation data can be displayed, edited, and exported. 

• In the menu, select Edit > Edit Operation Data. 
• Select the desired Component (oven line or plant). 
• Select the desired Period. 
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• Click Query. 
• Edit the displayed data. 
• If wanted, click Export to export the operation data to MS Excel. 
• Click Apply or OK. 

  

CALCULATE (U) 

Here, a calculation can be started manually. 

• In the menu, select Edit > Calculate. 
• Select the Calculation interval. 
• Select the date and time of the Start of the interval. 
• Click OK. 

 

• Alternatively, the calculation can also be started directly in the Status Panel. 

SHOW GENERATED SOURCE (D) 

This menu entry displays the automatically generated source code necessary to access the parameters via names 
within the calculation source code and the source code entered under Edit Calculation Source (d). 

• In the menu, select Edit > Show Generated Source. 
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EDIT CALCULATION SOURCE (D) 

This menu entry allows to enter/edit an alternative calculation source code directly within BIOMA. 

• In the menu, select Edit > Edit Calculation Source. 

 

REPORTING 

Here, you get information on how to export/edit/import report packages, build reports and export calculation 
results. Additionally, it is possible to recalculate a selected reference system with the selected computation 
algorithm of the active plant document to compare the results. 

EXPORT / EDIT REPORT PACKAGE (A) 

To transmit the recorded plant data to authorities for evaluation, administrators can create report packages. A 
report package includes the complete data set for the selected reporting period (including the updated plant 
parameters, called manual inputs) but no computed results. 

• In the menu, select Reporting > Export / Edit Report Package. 
• Select the reporting period (e.g., 01.01.2021 – 31.12.2021). 
• Update the plant and oven line parameters (as described below). 
• If you don’t have the total values for Moiltot, Mslutot, Mwastetot and Vgastot, you can click Apply 

Defaults to compute the sum of the data from the database independent of the fact if the respective 
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datasets are plausible or not. Note that Mashtot, Mscaptot and Mslagtot are set to zero because they are 
not needed for the computation. 

• Click Export, select a destination folder and click Save. 
• Alternatively, click Save to store the changes of updated plant parameters in the internal database only 

without creating a report package. 

TAB COMMON 

On this tab, generic settings for the plant parameters used during the online calculation can be updated for the 
final computation. 

• Select the reporting period. 
• Update Plant parameters. 

   

TAB LINE X 

On this tab, generic settings for the individual oven lines used during the online calculation can be updated for the 
final computation. 

• On the bottom tab Values for Reporting period, update oven line parameters. 
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• On the bottom tab Adjustments (O2, CO2), adjustments for O2 and CO2 measurements can be entered. 
This might be necessary because O2 and CO2 calibration of measuring devices are usually performed with 
calibration gases that have a higher concentration than optimal for the balance method. Because of that, 
it is recommended to repeat the measurements with calibration gases that contain concentrations in the 
height of the expected values and enter this information into BIOMA. 
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IMPORT REPORT PACKAGE (A) 

Here, you can import report packages.  

• In the menu, select Reporting > Import Report Package. 
• Select a saved report package (extension *.brp) or a compressed report package (extension *.brpz) 
• Click Open. 

BUILDING REPORTS (E) 

Here, you can build a report from the imported data or report package.  

• In the menu, select Reporting > Building Reports. 
• Select the reporting period. The beginning and the end of the reporting period can only be chosen within 

the time frame of the created or imported report package.  
• Select an alternative report template (BIOMA.xrpt). These templates written in XML are editable. 
• Select reporting steps (Days, Weeks, Months, Years). This selection should fit the chosen report template. 

The default setting is Months. 
• Click Calculate report data. 

Afterwards 

• Click Chart Editor to edit existing charts for the report (data binding is written in XML). 
• Click Text Modules to write a user-defined text that can be implemented in the report template via XML 

code. 

  

• Click Publish to create a pdf report based on the report template. 
• Click Export to export the results of plausibility checks and the results of the calculation steps to several 

Excel files (one for each oven line and one for the whole plant). 
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• Click Save as a reference system to save the computational results as a reference system (extension 
*.brefsys) to be recalculated later with an alternative calculation algorithm (cf. Reference Systems (e)). A 
reference system is a report package that, additionally, includes the computed results. 

• Click Close to close the window. You will be asked if you want to store the results of your calculations. If 
you click Yes, you do not have to repeat the calculation when opening the Report Building Form again. 
This is especially useful if you are working on the layout of your report template and only want to view the 
results of the pdf creation process when clicking Publish. 

EXPORT CALCULATION RESULTS (A/E) 

Here, you can export calculation results according to a selected export definition.  

• In the menu, select Reporting > Export Calculations Results. 

TAB EXPORT 

On this tab, you can select an export definition, adjust its setting (experts only), state the destination and the file 
name of the CSV file to be saved, select the period to be computed, and finally start the export. 

• On tab Export, select an existing export definition (which has to be created before by an expert under 
Export Definition (E)). Per default, administrators have the right to select “Simple CSV export” only. 
Experts can also select “Detailed CSV export”. 

• The Settings (also predefined under Export Definition (E)) can be changed by experts only. 
• If necessary, restate the destination of the CSV file to be saved. The following placeholders can be used in 

the export file name: 
o ${name} - The name of the export definition 
o ${line} - The oven line key 
o ${sheet - The name of the sheet (detailed export) 
o ${date} - The current date (yyMMdd) 
o ${time} - The current time (HHmmsss) 
o ${yy} - current year (2 digits)  
o ${yyyy} - current year (4 digits) 
o ${MM} - current month (2 digits)  
o ${dd} - current day (2 digits) 
o ${HH}  - current hour (2 digits) 
o ${mm}  - current minute (2 digits) 
o ${ss}  - current second (2 digits) 
o ${fff}  - current fraction of second (3 digits) 
o Invalid characters in file name and path will be replaced with underscores ‘_’. 

• State the period to be considered while exporting the calculation results. 
• Click Start. 
• Check the export protocol if the export was successful. 
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The Simple CSV export will result in one output file: 

 

The Detailed CSV export will result in seven output files: 

 

Notes: 

• The Detailed CSV Export, which also includes the uncertainties of all parameters, can be performed by 
experts only. 

• The Simple CSV Export includes selected parameters only and contains no uncertainties. 

Remark: During the computation, no manual input as set under Export / Edit Report Package (a) will be 
considered, Instead the plausible data within the selected period will be aggregated to get a rough estimate. 

TAB PROTOCOL 

On this tab, you see the log file of all import and export operations. 

EXPORT ONLINE CALCULATION RESULTS (E) 

Here, experts can export the complete information about online computation (all parameters together with their 
uncertainties) as an xml file, which can be opened with MS Excel. 

• In the menu, select Reporting > Export Online Calculation Results. 
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• Select the desired directory and click OK. 

This point is available only if a computation has already been performed via Control Panel. 

REFERENCE SYSTEMS (E) 

Here, experts can recalculate a chosen reference system with an alternative calculation algorithm (cf. Edit 
Calculation Source (d)) and compare the computational results. The reference system (with extension *.brefsys) 
must have been created in advance under Building Reports (e). 

• On tab Load reference system, click … to select the desired reference system. 

 

• On tab Recalculate, click Recalculate to calculate the loaded reference file with the currently set 
calculator version. 
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• On tab Summary, check the columns AVG Delta [%] and SD Delta [%] for significant differences. 

 

• Optional: On tab Export, click Export calculation results to export xml files with the results of both 
computations. 

 

• Click Close. 

EXTRAS 

OPTIONS (A) 

• In the menu, select Extras > Options. 

TAB DATABASE 

• On tab Database, the database connection is established and tested. 
•  If the standard installation of the database server has been performed, nothing has to be changed. If a 

different database server should be accessed or e.g., windows authentication shall be used, the setting 
must be edited here. 

• Click Apply default connection settings to reset the settings to default. 
• Click Test connection to check if everything is working correctly. 
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• Click OK. 

 

TAB CALCULATION 

• On tab Calculation, the basic settings for the computation can be found. 
• If you want to regularly check the operation data for changes (e.g., if new data has been imported) and 

perform a computation if some are detected, select the Calculation interval in seconds and enable 
calculation timer. 

• Set Message level (none < error < warnings < information < detail). 
• Set Calculation method (Default method, Source code (necessary for developers only)). 

 

TAB IMPORT 

• On tab Import, the basic directory settings for importing data can be found. 
• Choose Import Directory. This is the folder where the CSV data file has to be placed to be automatically 

imported. 
• Choose Backup Directory. If the data import was successful, the CSV file will be moved from Import 

Directory to Backup Directory). 
• Choose Backup Director”. If the data import was unsuccessful, the CSV file will be moved from Import 

Directory to Error Directory). 
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• Set Import interval (seconds) and tick Enable import timer to activate automatically importing of data. 
The Import Directory will be checked according to the time stated if new data is available. 

• Set Backup file count (= the number of backup files that should be kept before starting to delete the 
oldest). 

 

CHANGE LOG (E) 

Here, changes applied to the plant document are logged. 

• In the menu, select Extras > Change Log. 

 

• Select the period to be queried and click Query. 
• Click Export to export the information to MS Excel. 

ADMINISTRATION (A/E) 

• In the menu, select Extras > Administration. 

EXPORT DEFINITION (E) 

• In the menu, select Extras > Administration > Export Definition. 
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• Click the empty field below Export processor and select the desired export processor from the drop-down 
list (Simple CSV export [=> parameters to be exported can be selected] or Detailed CSV export [=> 
everything will be exported]). 

 

• Click Apply. 

 

• State a fitting name. 
• Click … next to the Remarks text field to add remarks 
• Click … next to the Configuration text field to define the export configuration (can be done by experts 

only). 
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TAB COMMON (E) 

On this tab, the common settings of the CSV export can be defined. 

• Oven line: Select the oven line to be calculated and exported. 
• Steps: Select the calculation steps 
• Output path: Enter the default output file name. This name will be used if no name is supplied when 

executing the export. The file name may contain placeholders that will be replaced when executing the 
export. 

• Culture: The culture determines the date and number formats (e.g., thousands separator, AM, PM) 
• Date format: The date format string. 

o Standard DateTime Format Strings: 
http://msdn.microsoft.com/en-us/library/az4se3k1(v=vs.80).aspx 

o Custom DateTime Format Strings: 
http://msdn.microsoft.com/en-us/library/8kb3ddd4(v=vs.80).aspx 

• Number format: The number format string 
o Standard Numeric Format Strings: 

http://msdn.microsoft.com/en-US/library/dwhawy9k(v=vs.80).aspx 

http://msdn.microsoft.com/en-us/library/az4se3k1(v=vs.80).aspx
http://msdn.microsoft.com/en-us/library/8kb3ddd4(v=vs.80).aspx
http://msdn.microsoft.com/en-US/library/dwhawy9k(v=vs.80).aspx


 

 Menu Description  •  59 

o Custom Numeric Format Strings: 
http://msdn.microsoft.com/en-US/library/0c899ak8(v=vs.80).aspx 

• Column separator: The column separator character.   

 

TAB PARAMETER (E) 

On this tab, the parameters to be considered during the Simple CSV export can be selected. 

• Select the desired parameters and enter the order of the parameters 

 

PLANT DOCUMENT ADMIN (A) 

• In the menu, select Extras > Administration > Plant Document Admin. 
• To delete a plant document, tick the document and click Remove Document. Note that the active 

document cannot be deleted. 
• To delete only operational data, tick the desired document and click Delete Operation Data. 

http://msdn.microsoft.com/en-US/library/0c899ak8(v=vs.80).aspx
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USERS (A) AND PERMISSIONS (D) 

Here, administrators can create/delete users and add them to predefined user groups (with certain connected 
rights). Additionally, developers can create/edit/delete user groups, assign the respective rights and issue new user 
licenses. 

• In the menu, select Extras > Administration > Users and Permissions. 
• Apply the desired changes and click OK. 

ISSUE A LICENSE (D) 

For developers, the easiest way to issue a license is this: 

• Install a client (contains the users wte and admin) or an expert license (contains additionally the users 
expert and BIOMAUtil [= command line user]). 

• Apply the desired changes to the license (users, passwords, user group, rights) 
• Click License (this button is visible for developers only!). 
• Enter the name of the Version (Client, Expert), the name of the Licensee, the Registration date (the day 

from when the license should be valid), and the Expiration date (the day from when the license is not 
valid anymore). 

• Additionally, you can state that the license should not expire by activating no expiration and that you 
want the license to be a demo version by activating demo. 

• Click OK. 
• Copy the file C:\ProgramData\inka software\BIOMA\WipClient.sec and rename it to e.g., 

ExpirationDate_NameLicense.license 
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TAB USERS (A) 

• On tab Users, select one of the available users from the dropdown list to see/edit the group (access rights) 
it belongs to. 

 

• To edit or create a user, 
• Click the Edit user or Add new user button. 
• Edit or enter login name, password, and name (will be displayed on top of GUI). 
• Click OK. 

 

• Select a group membership (experts > administrators > WIP employees [short for Waste Incineration 
Plant]) 
 

• To delete a user, 
• Select the User from the dropdown menu and click the Remove user button. 
• Click OK. 

TAB PERMISSIONS (D) 

• On tab Permission, select the group you want to edit from the drop-down list Group. 
• Select the desired rights by setting the respective tick. 
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• To create a user group, 
• Click the Add new group button (+). 
• Enter the name of the new group and, optionally, some remarks. 

 

• To delete a user group, 
• Select the group from the dropdown list Group. 
• Click the Delete group button (-) 
• Click OK. 
• Attention: No warning will be issued before deletion! 

HELP 

ABOUT (A) 

• In the menu, select Help > About. 
• Click Install License to install an acquired license (e.g., XYZ.license). 
• Licenses can only be created with developer rights. To get a license, please contact TU Vienna. 
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APPENDIX 

COMPARISON OF EXPORT FEATURES 

In BIOMA, there are multiple features to export data to be processed in other locations. Here is an overview: 

Feature 1: Status Panel > tab Calculated data > button Export (cf. Use Graphical User Interface (u)) 
Access rights: Users 
Output: All “visible” parameters (could be input and/or reconciled values) 
Uncertainties: No 
Period:  As selected for computing in the Status Panel 
Interval: As selected for computing in the Status Panel 
Files: One XML file for each line with tabs results (= reconciled values), inputs (original values) 
 
Feature 2: Menu > Reporting > Export Online Calculation Results (cf. Export Online Calculation Results (e)) 
Access rights: Experts 
Output: Inputs, results, and plausibility checks for all parameters 
Uncertainties: Yes 
Period:  As selected for computing in the Status Panel 
Interval: As selected for computing in the Status Panel 
Files:  One XML file for each line with tabs Manual Input (empty), PlausibilityCheck, CheckedRecords, 

CalcResult, Common, CalcResultNldr, CommonNldr 
 
Feature 3: Menu > Reporting > Building Reports > Export (cf. Building Reports (e)) 
Access rights: Experts 
Output: Inputs, results, and plausibility checks for all parameters 
Uncertainties: Yes 
Period:  Selected reporting period 
Interval: Selected reporting steps 
Files:  One XML file for each line with tabs Manual Input, PlausibilityCheck, CheckedRecords, 

CalcResult, Common, CalcResultNldr, CommonNldr 
One XML file for the total plant with tabs Common, Period 

 
Feature 4: Menu > Reporting > Export Calculation Results (cf. Export Calculation Results (a/e)) 
Access rights: “Simple CSV Export”: Users 

“Detailed CSV Export”: Experts 
Output: For the oven line as defined in the export definitions => 

“Simple CSV Export”: input and/or reconciled value for selected parameters. E.g., 

 
“Detailed CSV Export”: inputs, results, and plausibility checks for all parameters 

Uncertainties: “Simple CSV Export”: No 
“Detailed CSV Export”: Yes 

Period:  Selected period 
Interval: As defined in the export definitions 
Files:  For the oven line as defined in the export definitions => 

“Simple CSV Export”: one CSV file with name “CalculationExport.csv”  
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“Detailed CSV Export”: seven CSV files with names ManualInput (empty), PlausibilityCheck, 
CheckedRecords, CalcResult, Common, CalcResultNldr, CommonNldr 

 

PERMISSION GROUPS 

Here is an overview about the permission groups that are included in BIOMA per default: 

Flag Description 
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adminUsers Manage user accounts     X X 

adminGroupPerms Manage user groups         

adminClientUsers Manage WTE-clients accounts     X X 

editClientOptions Edit WTE-Clients options     X X 

adminPlantDocs Create and delete plant documents     X X 

editPlantDocs Edit plant documents     X X 

loadPlantDocs Load plant documents X X X X 

createPlantDocs Create plant documents     X X 

editSystemParams Edit system parameter       X 

loadTemplate Load document from template       X 

saveTemplate Save document from template       X 

importRecValues Import operation data X X X X 

importEditConfig Edit import configuration     X X 

createReports Perform calculations and create reports       X 

createReportPacks Create report packages     X X 

deleteChangeLog Delete report packages         

viewChangeLog View change log entries       X 

viewHistoryText View plant document history       X 

editHistoryText Edit plant document history       X 

exportSimple Simple export of calculated values   X   X 

exportDetailed Detailed export of calculated values      X 

exportEditConfig Edit export configuration       X 
 

COMMAND LINE TOOL 

Some basic operations of BIOMA can also be performed without having to start the user interface. Here is a brief 
description of the command line syntax biomautil (mainly for IT experts). 

Start the command line (press WIN+R > type cmd >hit ENTER) and navigate to the BIOMA installation folder (this 
is normally C:\Program Files (x86)\inka software\BIOMA 2.5.xxx). If you don’t know how to do the latter, see e.g. 
https://riptutorial.com/cmd/example/8646/navigating-in-cmd) 

https://riptutorial.com/cmd/example/8646/navigating-in-cmd
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The general structure of all commands is 
biomautil /CMD:{Command} [/PlantGuid:{PlantGuid}] [/?|Help] 

/? or /Help (it can be used without “/CMD:{command} 
For getting help for biomautil, type biomautil /?, and then press ENTER. 
 
Example: 
C:\Program Files (x86)\inka software\BIOMA 2.5.xxx > biomautil /? 
 
The option [/PlantGuid:{PlantGuid}] can be used with all following commands (however, with “/CMD:ListPlants” it 
doesn’t make sense). {PlantGuid} is the plant GUID (Global Unique Identification) of the plant document. If the 
PlantGuid is not known, it can be retrieved with the command “/CMD:ListPlants”. If not supplied, the default plant 
GUID as for the BIOMA client will be used. 
 
Example: 
/PlantGuid:5bd7c003-adbe-4b33-a837-1ac2f5feaeaf (without SPACE!) 
 
/CMD:ListPlants 
Queries a list of all plant documents (Plant GUID + Plant name) 
 
/CMD:ListImportDefs 
Queries a list of all import definitions. 
 
/CMD:ListExportDefs 
Queries a list of all export definitions. 
 
/CMD:CalcExport 
Executes an export of calculated values using the specified export definition. 

• /ExportDefId:{ID} 
The export definition ID. The command 'ListExportDefs' can be used to query the IDs. 

• [/FileName:{ExportFileName}] 
The export file name. If the default destination not specified, of the export definition will be used. 

• [/PeriodCount:{n}] 
Count of periods used to calculate the total export period. The default is 1. 

• [/Period:{Hours|Days|Weeks|Months}] 
The period used to calculate the total export period. The default is hours. 

• [/AddProtocol:{Yes|No}] 
Indicates whether the import protocol will be added to the database. The default is 'No'. 

Example: 
Export calculation results of the last 14 Days. The export definition specifies the format and the calculation steps. 
Use double quotes (") to encapsulate file name with blanks. 
biomautil /CMD:CalcExport /ExportDefId:1 /FileName:"C:\Temp\my_output_file_name.csv" /PeriodCount:14 
/Period:Days 

/CMD:Import 
Executes the import of operation data from a single file using the specified import definition. 

• /FileName:{ImportFileName} 
The import file name. 

• [/ImportDefId:{ID}] 
The import definition ID. The command 'ListImportDefs' can be used to query the IDs. If not specified, the 
default import definition ID will be used. 

• [/AutoCommit:{Yes|No}] 
Indicates if the data will be written to the database without confirmation by the user. The default is 'No' 

• [/AddProtocol:{Yes|No}] 
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Indicates whether the import protocol will be added to the database. The default is 'No'. 

Example: 
Import operation data. Use double quotes (") to encapsulate file name if it contains blanks. 
biomautil /CMD:Import /FileName:"C:\Temp\Import file from SPS.csv" 
 
/CMD:BatchImport 
Executes a batch import of operation data using the specified import definition. The batch import all files of the 
import directory and moves them to the backup or error directory after import. 

• [/ImportDefId:{ID}] 
The import definition ID. The command 'ListImportDefs' can be used to query the ID. If not specified, the 
default import definition ID will be used. 

• [/ImportDir:{the import directory}] 
The source directory containing the import files. If not specified, the same directory as configured in the 
BIOMA client will be used. 

• [/BackupDir:{the backup directory}] 
Successfully imported files are moved to the backup directory. If not specified, the same directory as 
configured in the BIOMA client will be used. 

• [/ErrorDir:{the error directory}] 
If errors occurring during import the according files will be moved to the error directory. If not specified, 
the same directory as configured in the BIOMA client will be used. 

• [/AddProtocol:{Yes|No}] 
Indicates whether the import protocol will be added to the database. The default is 'No'. 

Example: 
Batch import without user confirmation using the same settings as the BIOMA client. 
biomautil /CMD:BatchImport 

BIOMA JOB SERVER 

AUTOMATIC IMPORT AND EXPORT WITH THE “BIOMA JOB SERVER“ 

Beginning with BIOMA Version 2.3.1001.0, the „BIOMA Job Server“ service will be installed with the setup 
program. After installation the service is disabled. 

 

This service allows to schedule BIOMA export and imports tasks. The „BIOMA Job Server“ is a slightly modified 
version of the „Quartz.Net“ project.  

Quartz.NET is an open source project aimed at creating a free-for-commercial use Job Scheduler, with 'enterprise' 
features. It is licensed under the Apache License, Version 2.0 (the "License"). You may obtain a copy of the License 
at: http://www.apache.org/licenses/LICENSE-2.0  

CONFIGURATION OF SCHEDULED IMPORT 

1. Use the BIOMA client application to configure the import/backup/error directories. 

http://www.quartz-scheduler.net/
http://www.apache.org/licenses/LICENSE-2.0
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2. Call the import at least once from the BIOMA client and check results. 

 

3. The command line utility „biomautil.exe“ is used to perform the import task. This program is located in 
installation folder of BIOMA. Usually, this is “%ProgramFiles%\inka software\BIOMA X.X.XXXX\”. Execute 
“biomautil /?” at the command prompt to get more help. 

  
 

4. Edit the file „Jobs.xml“ in the folder „JobServer“ to modify the default configuration. You need to have 
administrator privileges to edit the “Jobs.xml” file. Use the “run as administrator” context menu to start 
the editor (e.g. notepad). 
 
The default configuration triggers the import every 10 minutes. 
       <cron-expression>0 0/10 * * * ?</cron-expression> --> 
 
A tutorial on how to set the crone-expression of  the trigger can be found under 
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http://www.quartz-scheduler.org/documentation/quartz-2.3.0/tutorials/crontrigger.html 
 

5. Enable and start the „BIOMA Job Server“ service 

  
 

6. View the log file 
The log file is located at „%ProgramData%\ inka software\BIOMA\LogFiles\obServerLog.txt“. 
A maximum number of 10 log each with max 100 KB will be maintained. 
 
For test purposes you may change the import interval to in „Jobs.xml“ to 1 minute.  
       <cron-expression>0 * * * * ?</cron-expression> --> 
 
Please note, the “BIOMA Job Service” needs to be restarted after changing the configuration. 
 

CONFIGURATION OF SCHEDULED EXPORT OF CALCULATED VALUES 

1. Use the BIOMA client to configure and test the export. 

http://www.quartz-scheduler.org/documentation/quartz-2.3.0/tutorials/crontrigger.html
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2. Test export with the command line utility “biomautil.exe” 
 
Execute “biomautil /CMD:ListExportDefs” to query the export definition ID  (ExportDefId). 
Execute “biomautil /CMD:CalcExport /ExportDefId:1” to export the data. 
biomautil /CMD:CalcExport /ExportDefId:1 /PeriodCount:1 /Period:Hours 
 

3. Edit “Jobs.xml” to schedule the export command. 
The default configuration triggers the export every day at 2 AM but only in the year 1970. It will not trigger 
until you remove the year.  
 
You need to administrator privileges to edit the “Jobs.xml” file. Use the “run as administrator” context 
menu to start the editor (e.g., notepad). 
 
<value>/CMD:CalcExport /ExportDefId:1 /PriodCount:1 /Period:Hours</value> 
 
Run every day at 2 AM  
<cron-expression>0 0 2 * * ?</cron-expression> 
 
Please note that the “BIOMA Job Service” needs to be restarted after changing the configuration. 
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