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Welcome to the AWR Design Environment!

The AWR Design Environment comprises two powerful tools that can be used 
together to create an integrated system and RF design environment: Visual 
System Simulator� (VSS) and Microwave Office (MWO). These powerful tools 
are fully integrated in the AWR Design Environment and allow you to 
incorporate circuit designs into system designs without leaving the AWR Design 
Environment.

Microwave Office enables you to design circuits composed of schematics and 
electromagnetic (EM) structures from an extensive electrical model database, 
and then generate layout representations of these designs. You can perform 
simulations using one of Microwave Office�s simulation engines -- a linear 
simulator, an advanced harmonic balance simulator, a 3D-planar EM simulator 
(EMSight�), or an optional HSPICE simulator -- and display the output in a 
wide variety of graphical forms based on your analysis needs. You can then tune 
or optimize the designs and your changes are automatically and immediately 
reflected in the layout. 

VSS enables you to design and analyze end-to-end communication systems. You 
can design systems composed of modulated signals, encoding schemes, channel 
blocks and system level performance measurements. You can perform 
simulations using VSS�s predefined transmitters and receivers, or you can build 
customized transmitters and receivers from basic blocks. Based on your analysis 
needs, you can display BER curves, ACPR measurements, constellations, and 
power spectrums, to name a few. VSS provides a real-time tuner that allows you 
to tune the designs and then see your changes immediately in the data display.

OBJECT ORIENTED TECHNOLOGY

At the core of MWO and VSS capability is advanced object-oriented 
technology. This technology results in software that is compact, fast, reliable, 
and easily enhanced with new technology as it becomes available.
G e t t i n g  S t a r t e d  G u i d e  1 -1
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ABOUT THIS GUIDE

This Getting Started Guide is designed to get you up and running quickly in the 
AWR Design Environment and to show you Microwave Office and VSS 
capabilities through working examples. 

PREREQUISITES

You should be familiar with Microsoft® Windows® and have a working 
knowledge of basic circuit and/or system design and analysis.

This document is available as a PDF file on your Program Disk (Getting 
Started.pdf), or you can download it from the AWR website at www.mwoffice.com.

If you are viewing this guide as online Help and intend to work through the 
examples, you should obtain and print out the PDF version for ease of use.

CONTENTS OF THIS GUIDE

Chapter 2 provides the basic installation procedures. 

Chapter 3 provides an overview of the AWR Design Environment including the 
basic menus, windows, components and commands.

Chapters 4, 5, 6, and 7 take you through hands-on examples that show you how 
to use Microwave Office to create circuit designs. 

Chapters 8, 9, 10, 11, and 12 take you through hands-on examples that show 
you how to use VSS to create system simulations and to incorporate Microwave 
Office circuit designs. 

CONVENTIONS USED IN THIS GUIDE

This guide uses the following typographical conventions:

Item Convention

Anything that you select 
(or click) in the AWR 
Design Environment, like 
menu items, button 
names, and dialog box 
option names

Shown in a bold type. Nested menu selections are shown 
with a �>� to indicate that you select the first menu item 
and then select the second menu item:

Choose File > New Project

Any text that you enter 
using the keyboard

Shown in a bold type within quotation marks:
Enter �my_project� in Project Name.
1-2 MWO/VSS 2003
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Getting Additional Information
GETTING ADDITIONAL INFORMATION

There are multiple resources available for additional information and technical 
support on MWO and VSS.

DOCUMENTATION

Documentation for MWO includes:

� What�s New in MWO 2003? presents the new or enhanced features, 
elements, and measurements for this release. This document is 
available via the Start button Programs > AWR Suite 2003 menu, or by 
choosing Help > What�s New while in the program.

� Microwave Office User Guide describes how to use the Microwave Office 
windows, menu choices, and dialog boxes to perform linear, nonlinear, 
and EM design, layout, and simulation, and discusses related concepts.

� Microwave Office Element Catalog (Volumes 1 and 2) provides complete 
reference information on all of the electrical elements that you use to 
build schematics.

� Microwave Office Measurement Reference provides complete reference 
information on the �measurements� (i.e., computed data such as gain, 
noise, power, or voltage) that you can choose as output for your 
simulations.

� MWO/VSS/AO Installation Guide describes how to install the AWR 
Design Environment and configure it for locked or floating licensing 
options. It also provides licensing configuration troubleshooting tips. 
This document is available on your Program Disk as install.pdf, or 
downloadable from the Applied Wave Research website at 
www.mwoffice.com under Support. 

� Known Issues lists the known issues for this release. This document is 
available on your program disk as KnownIssues.htm. 

Keys or key combinations 
that you press

Shown in a bold type with initial capitals. Key 
combinations are shown with a �+� to indicate that you 
press and hold the first key while pressing the second 
key:

Press Alt+F1.

Item Convention
G e t t i n g  S t a r t e d  G u i d e  1-3
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Getting Additional Information
1

Documentation for VSS includes: 

� What�s New in VSS 2003? presents the new or enhanced features, 
system blocks, and measurements for this release. This document is 
available via the Start button Programs > AWR Suite 2003 menu, or by 
choosing Help > What�s New while in the program.

� Visual System Simulator System Block Catalog provides complete reference 
information on all of the system blocks that you use to build systems.

� Visual System Simulator Measurement Reference provides complete 
reference information on the measurements you can choose as output 
for your simulations.

ON-LINE HELP

All AWR documentation is available as on-line Help. 

To access online Help choose Help from the main menu or press F1 anytime 
you are working within the AWR Design Environment. Context sensitive help is 
available for elements and system blocks in the Element Browser and within 
schematics or system diagrams. Context sensitive Help is available for 
measurements from the Add/Modify Measurements dialog box. 

WEBSITE SUPPORT

Support is also available from the Applied Wave Research website at 
www.mwoffice.com. You can go directly to this site from the AWR Design 
Environment Help menu. The Support page provides links to the following: 

� the current software version

� the KnowledgeBase, which contains Frequently Asked Questions 
(FAQs) from MWO and VSS users, Application Notes, Tutorials, and 
project examples

� VSS and MWO documentation

TECHNICAL SUPPORT

Technical Support is available Monday - Friday, 7 a.m. - 5 p.m., PST.

Phone: 310.726.3028 / Fax: 310.726.3005 / E-mail: support@mwoffice.

For users with current maintenance contracts, Technical Support is also 
available via an interactive Web-based chat session. To contact Support in this 
manner, choose Help > Chat with AWR Support.
1-4 MWO/VSS 2003
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INSTALLING MWO/VSS 2
This chapter describes how to install Microwave Office (MWO) and Visual 
System Simulator (VSS). You can install them as standalone applications or 
install them together as integrated partners within the AWR Design 
Environment. A procedure for obtaining a FLEXlm® license with a software-
based key is also included.

The installation procedures are intended for evaluators and licensed users who 
want to install MWO and VSS with a FLEXlm license dedicated to their 
particular machine. For alternative licensing configurations, see the MWO/
VSS/AO Installation Guide on your Program Disk (install.pdf). You can also 
download this guide from the AWR website at www.mwoffice.com. The file is 
located under Support.

INSTALLATION OVERVIEW

The AWR Design Environment software is shipped on a program CD-ROM for 
installation. The installation program installs Microwave Office, Visual System 
Simulator and Analog Office. 

Licensing and Available Features
You may have purchased a complete MWO/VSS license with full functionality 
(i.e., linear simulator, nonlinear simulator, EM simulator, optional HSPICE 
simulator, and layout tool), or you may have purchased a license for one or more 
features. In either case, the complete application is installed and your license 
determines the specific MWO and/or VSS functions that are available to you. 
The program is installed by default in C:\Program Files\AWR\AWR2003.

Installing Downloaded Versions
You can also download and install the program from the Applied Wave 
Research website (www.mwoffice.com). You can access XML libraries from within 
the AWR Design Environment via the Element Browser, and on the AWR 
website.
G e t t i n g  S t a r t e d  G u i d e   2-1

http://www.mwoffice.com
http://www.mwoffice.com


I N S T A L L I N G  M WO / V S S

Preparing for Installation
2

In Case of Installation Errors
If installation aborts due to an error, ensure the machine�s TEMP environment 
variable points to an existing directory. To set environment variables, see the 
MWO/VSS/AO Installation Guide (install.pdf on your Program Disk, or under 
Support at www.mwoffice.com.)

PREPARING FOR INSTALLATION

Before you start the installation:

1 Make sure the machine on which you wish to install the software meets the 
following hardware and software requirements:

� Pentium® PC, 800MHz, 256MB RAM, 200MB available disk space.

� Microsoft® Windows® 2000, NT4®, or XP.

� Microsoft Internet Explorer Version 5.0 or later, including Web 
Browser1, Help, and Visual Basic scripting support. To install Explorer, 
go to the Microsoft website at http://www.microsoft.com/windows/IE, or 
insert the Program Disk into the CD-ROM drive and run 
D:\Tools\ie6sp1\i386\ie6setup.exe, where D: is the CD-ROM drive 
designation.

2 When installing an update, back up any custom libraries you have stored in 
the \Library subdirectory of the program directory, and any .dll files you 
have stored in the \cells or \models directories.

3 When installing an upgrade, retain your existing version until you verify that 
your projects work successfully in the new version. (To uninstall Microwave 
Office, choose Add/Remove Programs from the Windows Control Panel, 
select the AWR Design Environment and follow the instructions.)

1. If you do not want Microsoft Internet Explorer to be your default internet browser, you must choose to
NOT associate file types via the Advanced setup options when you install Internet Explorer. Note that
you must still have the Web Browser installed, as the AWR Help and XML libraries use it.
2-2 MWO/VSS 2003
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INSTALLING THE SOFTWARE

You can begin your installation from the installation Welcome screen. 

To install the AWR Design Environment:

1 If you have the program CD-ROM, place it into the CD-ROM drive. When 
the AWR splash screen displays, follow the prompts and instructions. If the 
Welcome dialog does not display, explore the program CD-ROM and run 
the setup.exe program.

If you have downloaded MWO and VSS from www.mwoffice.com, browse to 
the folder in which you downloaded the software and run the setup program 
to display the installation Welcome dialog.

2 As you proceed with the installation you are prompted to specify the 
following:

3 When prompted to create one or more Start menu shortcuts, choose from 
the following list of AWR product numbers based on the product feature 
set you have purchased.

Option Description

Backup Replaced Files Backups are necessary only if you have modified files in 
your previous MWO/VSS version or stored any design files 
in the installation directory tree.

Select Default Process Choose the default units to use in schematics and layouts 
(as well as affect the default sizes for components such as 
transmission lines). The default is Microns. You can 
alternatively set this default within the program; see the 
Microwave Office User Guide for details. 

Register File Extensions Select this check box to specify that files with a .emp, .em, 
.sch, or .net extension are opened in the AWR Design 
Environment. If you use another schematic tool or program 
that uses these extensions, you may want to disable this 
option. This check box is selected by default.

Select Start Menu Group Enter the name of the Start menu program group to which 
you want to add the AWR 2003 icons. �AWR Suite 2003� is 
the default. If you accept the default, you start the program 
by clicking the Start button on your desktop and then 
choosing Programs > AWR Suite 2003 > AWR 
Design Environment. In addition, you can specify that 
these icons display only when you are logged onto the 
computer, or when anyone logs onto the computer.
G e t t i n g  S t a r t e d  G u i d e   2-3
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If you have an evaluation license, leave all of the boxes unchecked to create 
the appropriate default shortcut.

4 When installation is complete click Exit to close the screen. 

OBTAINING YOUR FLEXLM LICENSE

The AWR Design Environment supports FLEXlm floating1 and locked 
licensing as well as hardware-based2 keys. If you want to configure your site for 
FLEXlm floating licensing, and/or if you want to use hardware-based keys, see 
the MWO/VSS/ANO Installation Guide under Support at www.mwoffice.com, or on 
your Program Disk (install.pdf).

Option Description

VSS-100 Standalone version of Visual System Simulator

MWO-328 All MWO-228 functionality plus HSPICE functionality

MWO-228 Linear, nonlinear, and EM simulators, and layout; design rule 
checking, ability to work with layout components having more 
than two layers, and access to foundry libraries

MWO-225 linear, nonlinear, and EM simulators, and layout

MWO-205 linear and nonlinear simulators, and layout

MWO-200 linear and nonlinear simulators

MWO-125 linear and EM simulators, and layout

MWO-120 linear and EM simulators

MWO-105 linear simulator and layout

MWO-100 linear simulator

1. Floating licensing allows multiple users to share a license over a network via a client-server architecture,
whereas locked licensing dedicates a license to a particular machine. 

2. Hardware-based keys are calculated from an AWR-supplied hardware dongle serial number. Such a
license can be transferred between machines simply by moving the dongle.
2-4 MWO/VSS 2003
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To obtain a FLEXlm locked license using a software-based key:

1 Click the Start button on your desktop, and choose Programs > AWR Suite 
2003 > AWR Design Environment. 
If the AWR Design Environment was not configured during installation to 
display from your Start menu, start it by double-clicking My Computer on 
your desktop, opening the folder where you installed the program and 
double-clicking on MWOffice.exe.

2 The following AWR License Configuration dialog box displays.

3 To obtain a valid license file from Applied Wave Research, click the 
appropriate button under Registration and follow the instructions. 

4 You will receive your license within two business days. When you receive it, 
rename it awr.lic and place it into the program directory.
G e t t i n g  S t a r t e d  G u i d e   2-5
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AWR DESIGN ENVIRONMENT 3
This chapter describes the windows, menus and basic operations for performing 
the following tasks in the AWR Design Environment:

� Creating projects to organize and save your designs

� Creating system diagrams, circuit schematics, and EM structures

� Placing circuit elements into schematics

� Placing system blocks into system diagrams

� Incorporating subcircuits into system diagrams and schematics

� Creating layouts

� Creating and displaying output graphs

� Running simulations for schematics and system diagrams

� Tuning simulations

STARTING AWR PROGRAMS

To start the AWR Design Environment:

1 Click Start on your desktop.

2 Choose Programs > AWR Suite 2003 > AWR Design Environment. The 
following AWR Design Suite main window displays.

If the AWR Design Environment was not configured during installation to 
display in your Start menu, start the application by double-clicking the My 
Computer icon on your desktop, opening the drive and folder where you 
installed the program, and double-clicking on MWOffice.exe, the Microwave 
Office application.
G e t t i n g  S t a r t e d  G u i d e   3-1
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AWR DESIGN ENVIRONMENT COMPONENTS

The AWR Design Environment contains the windows, components, menu 
selections and tools you need to create linear and nonlinear schematics, set up 
EM structures, generate circuit layouts, create system diagrams, perform 
simulations, and display graphs. Most of the basic procedures apply to both 
Microwave Office (MWO) and Visual System Simulator (VSS). The major 
components of the AWR Design Environment are:

Component Description

menu A set of menus located along the top of the window for 
performing a variety of MWO and VSS tasks.

toolbar A row of buttons located just below the menu that 
provides shortcuts to frequently used commands such 
as creating new schematics, performing simulations, or 
tuning parameter values or variables.
The buttons available depend on the functions in use 
and the active window within the design environment 
(as well as any customization of toolbar button groups). 
Position the cursor over a button to view a short 
description of the button.

System Diagrams

Circuit Schematics

Tabs

Workspace

Project
Browser

Toolbar

Menus
Title bar
3-2 MWO/VSS 2003
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Many of the functions and commands can be invoked from the menus and on 
the toolbar, and in some cases by right-clicking on a node in the Project 
Browser. This guide may not describe all of the ways to invoke a specific task.

Project Browser Located in the left column of the window, this is the 
complete collection of data and components that define 
the currently active project. Items are organized into a 
tree-like structure of nodes and include schematics, 
system diagrams and EM structures, simulation 
frequency settings, output graphs, and more. 
The Project Browser is active when the AWR 
Environment first opens. Right-click a node in the 
Project Browser to access menus of relevant 
commands.

Element Browser Contains a comprehensive inventory of circuit 
elements for building your schematics, and system 
blocks for building system diagrams for simulations. 
The Element Browser displays in the left column in 
place of the Project Browser when you click the Elem 
tab at the lower left of the window.

workspace The area in which you design schematics and 
diagrams, draw EM structures, view and edit layouts, 
and view graphs. You can use the scrollbars to move 
around the workspace. You can also use the zoom in 
and zoom out options from the View menu. 

tabs A set of tabs located at the lower left of the window that 
allow you to switch the contents of the left column of 
the window from Project Browser (i.e., Proj) to 
Element Browser or Layout Manager. 
Click the Elem tab to display the Element Browser and 
to access a comprehensive inventory of circuit 
elements and system blocks for simulation. 
Click the Layout tab to specify options for viewing and 
drawing layout representations and to create new 
layout cells. 

Component Description
G e t t i n g  S t a r t e d  G u i d e   3-3
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BASIC OPERATIONS

This section highlights the windows, menu choices, and commands available for 
creating simulation designs and projects in the AWR Design Environment. 

Working With Projects
The first step in building and simulating a design is to create a project. You use a 
project to organize and manage your designs and everything associated with 
them in a tree-like structure.

PROJECT CONTENTS

Because MWO and VSS are fully integrated in the AWR Environment, you can 
start a project based on a system design using VSS, or on a circuit design using 
MWO. The project may ultimately combine both VSS and MWO elements. You 
can view all of the components and elements in the project in the Project 
Browser. Modifications are automatically reflected in the relevant elements. 

A project can include any set of designs and one or more linear schematics, 
nonlinear schematics, EM structures, or system level blocks. A project can 
include anything associated with the designs, such as global parameter values, 
imported files, layout views, and output graphs. 

CREATING, OPENING, AND SAVING PROJECTS

When you first start the AWR Design Environment, a default empty project 
titled �Untitled Project� is loaded. Only one project can be active at a time. The 
name of the active project displays in the main window title bar.

After you create (name) a project, you can create your designs. You can perform 
simulations to analyze the designs and see the results on a variety of graphical 
forms. Then, you can tune or optimize parameter values and variables as needed 
to achieve the desired response. You can generate layout representations of the 
designs, and output the layout to a DXF, GDSII, or Gerber file. 

To create a project choose File > New Project. Name the new project and the 
directory you want to write it to by choosing File > Save Project As. The project 
name displays in the title bar.

To open an existing project, choose File > Open Project. To save the current 
project, choose File > Save Project. When you save a project, everything 
associated with it is automatically saved. AWR projects are saved as *.emp files.
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Working With Schematics and Netlists in MWO
A schematic is a graphical representation of a circuit while a netlist is a text-
based description. A Microwave Office project can include multiple linear and 
nonlinear schematics and netlists.

To create a schematic or netlist, right-click Circuit Schematics in the Project 
Browser and choose New Schematic or New Netlist.

After you specify a schematic or netlist name, a schematic or netlist window 
opens in the workspace and the Project Browser displays the new item as a 
subnode of Circuit Schematics. Subgroups of the new schematic or netlist 
which contain all of the parameters and options (for example, frequencies or 
harmonic balance options) that define and describe the schematic or netlist can 
be displayed in the Project Browser by selecting Options > Environment 
Options > Show options as sub-nodes. In addition, the menu and toolbar 
display new choices particular to building and simulating schematics or netlists.

Create new project
Open existing project

Save current project
Name new project
Email the project
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Working with System Diagrams in VSS
A VSS project can include multiple system diagrams. To create a system 
diagram, right-click System Diagrams in the Project Browser and choose New 
System Diagram. 

You are prompted to name the new system diagram.

After you name the system diagram, a window opens in the workspace and the 
Project Browser displays the new system diagram. Subnodes of the system 
diagram which contain all of the parameters and options that define and 
describe the system diagram can also be displayed in the Project Browser by 
selecting Options > Environment Options > Show options as sub-nodes. After 

Schematic 
window (or 
netlist 
window) 
opens in the 
workspace

Create new netlist

Right-click then 
choose New 
Schematic

Right-click to create 
new system diagram

A system diagram opens 
in the workspace
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you name the system diagram, the menus and toolbar display new selections and 
buttons for building and simulating systems.

Using the Element Browser
The Element Browser gives you access to a comprehensive database of 
hierarchical groups of circuit elements for schematics and system blocks for 
system diagrams. The Library and Data folders in the Element Browser provide 
a wide range of electrical models and S-parameter files from manufacturers.

Circuit elements include models, sources, ports, probes, measurement devices, 
data libraries, and model libraries that can be placed in a circuit schematic for 
linear and non-linear simulations.

System blocks include channels, math tools, meters, subcircuits, and other 
models for system simulations.

� To view elements or system blocks, click the Elem tab in the lower left 
window. The Element Browser replaces the Project Browser window. 

� To expand and contract the model categories, click the + and - symbols 
to view the desired subcategory, such as Microstrips or Ports. The 
available models display in the lower window pane. 

� To place a model into a schematic or system diagram, simply click and 
drag it into the window, release the mouse button, right-click to rotate 
it if needed, position it, and click to place it.

� To edit model parameters, simply double-click the element graphic in 
the schematic or system diagram window. An Element Options dialog 
box displays for you to specify new parameter values. You can also edit 
individual parameter values by double-clicking on the value in the 
schematic or system diagram and entering a new value in the text box 
that displays.
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ADDING SUBCIRCUITS TO SCHEMATICS

Subcircuits allow you to construct hierarchical circuits by including a circuit 
block in a schematic. The circuit block can be a schematic, a netlist, an EM 
structure, or a data file.

� To add a subcircuit to a schematic, click Subcircuits in the Element 
Browser. The available subcircuits display in the lower window pane. 
These include all of the schematics, netlists, and EM structures 
associated with the project, as well as any imported data files defined 
for the project.

� To add a data file as a subcircuit, you must first import it and add it to 
the project as a node. To do so, choose Project > Add Data File. Any 
imported data files are automatically shown in the list of available 
subcircuits in the Element Browser.

� To place the desired subcircuit, simply click it and drag it into the 
schematic window, release the mouse button, position it, and click to 
place it.

Buttons for 
adding ports 
and ground

Expand then 
click desired 
subcategory

Drag desired 
model
into schematic or 
system diagram 
window

Click Elem tab to 
display Element 
Browser
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� To edit subcircuit parameters, select the subcircuit in the schematic 
window, right-click, and choose Edit Subcircuit. Either a schematic, 
netlist, EM structure, or data file opens in the workspace. You can edit 
it in the same way that you would edit the individual circuit block types.

ADDING SUBCIRCUITS TO SYSTEM DIAGRAMS

Subcircuits allow you to construct hierarchical systems and to import results of 
circuit simulation directly into the system block diagram.

� To create a subcircuit to a system diagram, choose Project > Add 
System Diagram > New System Diagram or Import System Diagram 
and then click Subcircuits under System Blocks in the Element 
Browser. The available subcircuits display in the lower window pane.

� To place the desired subcircuit, simply click and drag it into the system 
diagram window, release the mouse button, position it, and click to 
place it.

� To edit subcircuit parameters, select the subcircuit in the system 
diagram window, right-click, and choose Edit Subcircuit.

� To add a system diagram as a subcircuit to another system diagram, you 
must first add ports to the system that is designated as a subcircuit.

ADDING PORTS AND WIRES TO SCHEMATICS AND DIAGRAMS

To add ports to a schematic or system diagram, expand the Ports category in 
the Element Browser. Under Circuit Elements or System Blocks, click Ports or 
one of its subgroups, for example, Harmonic Balance. The available models 
display in the lower window pane. Drag the port into the schematic or system 
diagram window, right-click to rotate it if needed, position it, and click to place 
it.

For a shortcut when placing ports and ground, click the Port or Ground buttons 
on the toolbar, position the port or ground, and click to place it.

CONNECTING ELEMENT AND SYSTEM BLOCK NODES

To connect element or system block nodes with a wire, position the cursor over 
a node. The cursor displays as a wire coil symbol. Click at this position to mark 
the beginning of the wire and slide the mouse to a location where a bend is 
needed. Click again to mark the bend point. You can make multiple bends. To 
start a wire from another wire, Shift-click to mark the beginning of the wire. 
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Terminate the wire by clicking on another element node or on top of another 
wire. To cancel the wire, press the Esc key.

EDITING PORT PARAMETERS

To edit port parameters, double-click the port in the schematic or system 
diagram windows to display a dialog box in which you can specify new 
parameter values.

ADDING DATA TO NETLISTS

When you create a netlist, an empty netlist window opens into which you type a 
text-based description of a schematic. Netlist data is arranged in blocks in a 
particular order, where each block defines a different attribute of an element 
such as units, equations, or element connections. For more information about 
creating netlists, see the Microwave Office User Guide. 

CREATING EM STRUCTURES

EM structures are arbitrary multi-layered electrical structures such as spiral 
inductors with air bridges.

To create an EM structure, right-click EM Structures in the Project Browser, 
and choose New EM Structure. 

After you specify an EM structure name and select a simulator, an EM structure 
window opens in the workspace and the Project Browser displays the new EM 
structure under EM Structures. Subnodes of the new EM structure which 
contain all of the parameters and options that define and describe the EM 
structure can be displayed as described in �Working With Schematics and 
Netlists in MWO� on page 3-5. In addition, the menu and toolbar display new 
choices particular to drawing and simulating EM structures.
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ADDING EM STRUCTURE DRAWINGS

Before you draw an EM structure, you must define an enclosure. The enclosure 
specifies things such as boundary conditions and dielectric materials for each 
layer of the structure. 

To define an enclosure, double-click Enclosure under your new EM structure in 
the Project Browser to display a dialog box in which you can specify the 
required information.

After you define the enclosure, you can create drawings by accessing options 
from the Draw menu to draw components such as rectangular conductors, vias, 
and edge ports.

You can view EM structures in 2D (structure) and 3D by using the View menu, 
and you can view currents and electrical fields using the Animate menu. 

Create new 
EM structure

EM structure 
window opens in 
the workspace
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Creating a Layout with MWO
A layout is a view of the physical representation of a circuit, in which each 
component of the schematic is assigned a layout cell. In the object-oriented 
AWR environment, layouts are tightly integrated with the schematics and EM 
structures that they represent and are simply another view of the same circuits. 
Any modifications to a schematic or EM structure are automatically and 
instantly reflected in their corresponding layouts. 

To create a layout representation of a schematic, click the schematic window to 
make it active, and choose View > New Layout View. A Layout window displays 
(overlaying the schematic window) with an automatically-generated layout view 
of the schematic. 

You can also click the Layout button on the toolbar to view the layout of a 
schematic.

Shortcuts for 
drawing 
conductors, vias,
and ports

Draw conductors,
vias, and ports

Double-click to 
define an 
enclosure

Display 2D
(structure) and
3D views of the
structure
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The resulting layout contains layout cells representing electrical components 
floating in the layout window. Choose Edit > Snap Together to snap the faces of 
the layout cells together. The following figure shows the layout view from the 
previous figure after a snap together operation.

When you choose View > New Layout View, default layout cells are automatically 
assigned for common electrical components such as microstrip, coplanar 
waveguide, and stripline elements. Components of the schematic that do not 
map to default layout cells display in blue in the schematic window after the 
layout is generated; components that do have default layout cells display in 
magenta. For components without default layout cells defined, you must create 
them or import them using the Layout Manager. For more information see 
Using the Layout Manager on page 3-14.

You can draw in the layout window using the draw tools to build substrate 
outlines, draw DC pads for biasing, or to add other elements. 

MODIFYING LAYOUT ATTRIBUTES AND DRAWING PROPERTIES

To modify layout attributes and drawing properties, as well as create new layout 
cells for elements that do not have default cells, click the Layout tab in the lower 
left window. The Layout Manager replaces the Project Browser window. 
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USING THE LAYOUT MANAGER

The Layer Setup node in the Layout Manager defines layout attributes such as 
drawing properties (for example, line color or layer pattern), 3D properties such 
as thickness, and layer mappings. To modify layer attributes, right-click Layer 
Setup and choose Edit Drawing Layers. You can also import a layer process file 
(LPF) to define these attributes by right-clicking Layer Setup and choosing 
Import Process Definition.

The Cell Libraries node in the Layout Manager allows you to create artwork 
cells for elements that do not have default layout cells. The powerful Cell Editor 
includes such features as coordinate entry, boolean operations for subtracting 
and uniting shapes, array copy, arbitrary rotation, grouping, and alignment tools. 
You can also import artwork cell libraries such as GDSII or DXF into the AWR 
Design Environment. 

After creating or importing cell libraries, you can browse through the libraries 
and select the desired layout cells to include in your layout. Click the + and - 
symbols to expand and contract the cell libraries, and click the desired library. 

Right-click to modify 
layout attributes or 
import an LPF

Right-click to import 
a cell library or create 
your own using a Cell 
Editor

Click the Layout tab to
display Layout Manager

Activate layers for 
viewing and drawing 
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The available layout cells display in the lower window pane. To place a cell into 
the layout window, simply click and drag it, release the mouse button, position it, 
and click to place it.
.

You can import layouts as GDSII or DXF files. To export a layout, click the 
layout window to make it active, and choose Layout > Export.

Creating Output Graphs and Measurements
You can view the results of your circuit and system simulations in various 
graphical forms. Before you perform a simulation, you create a graph and 
specify the data, or measurements, that you want to plot. Measurements can 
include for example, gain, noise or scattering coefficients.

To create a graph, right-click Graphs in the Project Browser, and choose Add 
Graph to display a dialog box in which to specify a graph name and graph type. 

Expand and contract, click 
desired library

Drag layout cell into
Layout window
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An empty graph displays in the workspace and the graph name displays under 
Graphs in the Project Browser. The following graph types are available:

To specify the data that you want to plot, right-click the new graph name in the 
Project Browser, and choose Add Measurement. An Add Measurement dialog 
box allows you to choose from a comprehensive list of measurements.

Performing Simulations
To run a simulation on the active project, choose Simulate > Analyze. The 
simulation runs automatically on the entire project, using the appropriate 
simulator (for example, linear simulator, harmonic balance nonlinear simulator, 
or 3D-planar EM simulator) for the different pieces of the project.

SETTING SIMULATION FREQUENCY

To set the simulation frequency, double-click the Project Options node in the 
Project Browser, or choose Options > Project Options and then specify 
frequency values on the Frequencies tab in the dialog box.

VSS SYSTEM SIMULATIONS 

To set simulation frequency, double-click the System Diagrams node in the 
Project Browser, or choose Options > Default System Options and then specify 
frequency values on the Simulator tab in the dialog box.

Graph Type Description

Rectangular Displays the measurement on an x-y axis, usually over 
frequency.

Constellation Displays the in-phase (real) versus the quadrature (imaginary) 
component of a complex signal. 

Smith Chart Displays passive impedance or admittances in a reflection 
coefficient chart of unit radius.

Polar Displays the magnitude and angle of the measurement.

Histogram Displays the measurement as a histogram.

Antenna Plot Displays the sweep dimension of the measurement as the angle 
and the data dimension of the measurement as the magnitude.

Tabular Displays the measurement in columns of numbers, usually 
against frequency.
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When the simulation is complete, you can view its output on the graphs and 
then easily tune and/or optimize as needed. 

TUNING SIMULATIONS

The real-time tuner lets you see the effect on the simulation as you tune. The 
optimizer lets you see circuit parameter values and variables change in real-time 
as it works to meet the optimization goals that you specified.

You can also click the Tune Tool button on the toolbar. Select the parameters 
you want to tune and then click the Tuner button to tune the values. As you tune 
or optimize, the schematics and associated layouts are automatically updated. 
When you re-run the simulation, only the modified portions of the project are 
recalculated.

Using Scripts and Wizards
AWR Design Environment scripts and wizards allow you to automate and 
extend Microwave Office functions in a non-proprietary manner. These features 
are implemented via the Microwave Office API, a COM automation-compliant 
server that can be programmed in any non-proprietary language such as C, 
Visual Basic�, or Java. 

 
Type the data rate

Type the number
of samples per
symbol
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Scripts are Basic programs that you can write to do things such as automate 
schematic-building tasks within Microwave Office.

Wizards are Dynamic Link Library (DLL) files which you can author to create 
add-on tools for Microwave Office, for example, a filter synthesis tool, and 
Load Pull tool.

Wizards display under Wizards in the Project Browser; to access scripts, choose 
Tools > Scripting Editor. 

USING ONLINE HELP

Online Help provides information on the windows, menu choices, and dialog 
boxes in the AWR Design Environment, as well as for design concepts.

To access Help, choose Help from the menu bar or press F1 anywhere in the 
program. The following context-sensitive Help is also available:

� Help buttons in most dialog boxes.

� Help for each element or system block in the Element Browser by 
selecting a model and pressing Alt+F1, or by right-clicking on a model 
and choosing Element Help. The Element Options dialog box also has 
an Element Help button.

� Help for each measurement in the Add/Modify Measurement dialog 
box by clicking Meas Help.

� Help for using the AWR script development environment, accessed by 
selecting a keyword (i.e., object, object model, or Visual Basic syntax), 
and pressing F1.
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MWO: USING THE LINEAR SIMULATOR 4
Linear simulators use nodal analysis to simulate the characteristics of a circuit. 
Linear simulations are used for circuits such as low noise amplifiers, filters, and 
couplers whose elements can be characterized by an admittance matrix. Linear 
simulators typically generate measurements such as gain, stability, noise figure, 
reflection coefficient, noise circles, and gain circles.

LINEAR SIMULATIONS IN MICROWAVE OFFICE

The Microwave Office linear simulator is architected using object-oriented 
techniques that enable fast and efficient simulations of linear circuits. One of its 
trademarks is a real-time tuner that allows you to see resulting simulations as you 
tune. It also allows you to perform optimization and yield analysis.

The following example illustrates some of the key features of the Microwave 
Office linear simulator.

CREATING A LUMPED ELEMENT FILTER

This example demonstrates how to use Microwave Office to simulate a basic 
lumped element filter using the linear simulator. It includes the following steps:

� Creating a schematic
� Adding graphs and measurements
� Analyzing the circuit
� Tuning the circuit
� Creating variables
� Optimizing the circuit
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Creating a New Project
The example you create in this chapter is available in its complete form as 
�linear_example.emp� in your Program Files\AWR\AWR2003\Examples\
Getting Started\Microwave Office\Linear directory. You can use this example file 
as a reference.

To create a project:

1 Choose File > New Project.

2 Choose File > Save Project As. The Save As dialog box displays.

3 Navigate to the directory in which you want to save the project, type 
�linear_example� as the project name, and then click Save.

Setting Default Project Units
To set default project units:

1 Choose Options > Project Options. The Project Options dialog box 
displays.

2 Click the Global Units tab and verify that your settings match those in the 
following figure. You can choose units by clicking the arrows to the right of 
the display boxes.

3 Click OK.
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Creating a Schematic
To create a schematic:

1 Choose Project > Add Schematic > New Schematic. The Create New 
Schematic dialog box displays.

2 Type �lpf �, and click OK. A schematic window displays in the workspace 
and the schematic displays under Circuit Schematics in the Project 
Browser.

PLACING ELEMENTS IN A SCHEMATIC

Use the scroll arrows along the right and bottom of the schematic window to 
view different portions of the schematic as you work, or to view the entire 
schematic choose View > View All.

To place elements on a schematic:

1 Click the Elem tab in the lower left of the window to display the Element 
Browser. The Element Browser replaces the Project Browser window.

2 If necessary, click the + symbol to the left of the Circuit Elements node to 
expand the elements tree.

3 Expand the Lumped Element category under Circuit Elements, then click 
the Inductor subgroup. Select the IND model from the bottom window 
and drag it to the schematic as shown in the following figure. 

Element models

Element Browser
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4 Repeat step 3 three times, aligning and connecting each inductor as shown 
in the following figure. 

TIP: You can also connect elements by moving them to snap their nodes 
together. When they are properly connected a small green square displays 
and the connection wire extends if you move either element. If you do not 
see the green square, try to drag one of the elements into place again.

5 Click the Capacitor subgroup under Lumped Element, then select the CAP 
model and place it on the schematic as shown in the following figure. Right-
click once before placing the capacitor to rotate it as shown.

6 Repeat Step 5 twice, aligning and linking each capacitor as shown in the 
following figure.

CONNECTING THE WIRES

To connect the bottom nodes of the three capacitor elements together:

1 Place the cursor over the bottom node of CAP C1. The cursor displays as a 
wire coil symbol as shown in the following figure.
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2 Click, then drag the wire past the bottom node of CAP C2, then onto the 
bottom node of CAP C3, and click to place the wire. 

PLACING PORTS ON A NODE

To place a port on a node:

1 Choose Draw > Add Port. 

2 Move the cursor onto the schematic, position the port on the first inductor 
node as shown in the following figure, then click to place it. 

3 Repeat Step 1 to add a port to the right-most inductor, but right-click two 
times to rotate the port 180-degrees before you place it.
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TIP: You can also add a port by clicking the Port button on the toolbar and 
sliding the cursor into the schematic.

PLACING GROUND ON A NODE

To place ground on a node:

1 Choose Draw > Add Ground.

2 Slide the cursor onto the schematic, position the ground on the bottom 
node of CAP C1 as shown in the following figure, and click to place it. 

EDITING ELEMENT PARAMETERS

To edit the element parameters:

1 Double-click the IND L1 element. The Element Options dialog box 
displays.

2 Set the L parameter Value to �15� and click OK. The change is reflected in 
the schematic.

3 Repeat Steps 1 and 2 to edit the inductor and capacitor values to match 
those in the following figure. (To edit capacitor values, set the C parameter 
value as shown.)
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TIP: You can also simply double-click the parameter value displayed on the 
schematic to display a text box in which you can modify a single parameter.

SPECIFYING THE SIMULATION FREQUENCY

To specify the simulation frequency:

1 Click the Proj tab in the lower left of the window. 

2 Double-click Project Options. The Project Options dialog box displays. 

3 Click the Frequencies tab.

4 Type �100� in Start, �1000� in Stop, and �10� in Step, and then click Apply. 
The frequency range and steps you specified display in Current Range.

5 Click OK.

Creating a Graph
To create a graph:

1 Right-click Graphs in the Project Browser and choose Add Graph. You can 
also click the New Graph button on the toolbar. The Create Graph dialog 
box displays.

2 Type �s21 and s11� in Graph Name, select Rectangular as the Graph Type, 
and click OK. The graph displays in a window in the workspace and displays 
as a subgroup of Graphs in the Project Browser.
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ADDING A MEASUREMENT

To add measurements to the graph:

1 Right-click the �s21 and s11� graph in the Project Browser, and choose Add 
Measurement. The Add Measurement dialog box displays. You can also 
click the Add Measurement button on the toolbar.

2 Select Linear > Port Parameters as the Meas. Type and S as the 
Measurement. Click the arrow to the right of Data Source Name and select 
lpf. Click the arrows to the right of To Port Index and From Port Index and 
select �1� for each. Select Mag. as the Complex Modifier, select the DB 
check box under Result Type, and then click Apply.

Individual
graphs display

Graphsunder
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3 Change the value in To Port Index to �2�, and click Apply to add a second 
measurement.

4 Click OK. The measurements lpf:DB(|S(1,1)|) and lpf:DB(|S(2,1)|) display 
under the �s21 and s11� graph in the Project Browser.

Analyzing the Circuit
To analyze the circuit:

1 Choose Simulate > Analyze. The simulation response displays on the 
graph.You can also click the Analyze button on the toolbar to simulate the 
active project.
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TUNING THE CIRCUIT

When you place the tune tool over a schematic element, the cursor displays as a 
cross icon to indicate that the parameter is tuneable.

To tune the circuit:

1 Click the schematic window to make it active.

2 Click the Tune Tool button on the toolbar.

3 Move the cursor over the L parameter of IND L1. The cursor displays as a 
cross as shown in the following figure.
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4 Click to activate the L parameter for tuning. The parameter displays in an 
alternate color.

5 Repeat Steps 2 through 4 for the IND L4 element and the C parameters of 
the CAP C1 and CAP C3 elements.

6 Click the graph window to make it active.

7 Choose Simulate > Tune. The Variable Tuner dialog box displays.

8 Click a tuning button, and holding the mouse button down, slide the tuning 
bar up and down. Observe the simulation change on the graph as the 
variables are tuned.

9 Slide the tuners to the values shown in the following figure, and observe the 
resulting response on the graph of the tuned circuit.
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10 Click the X at the top right of the Variable Tuner dialog box to close it and 
click the Tune Tool button on the toolbar to deactivate the tuner.

Creating Variables
Filters are typically symmetric circuits. To optimize the circuit, you must change 
some of the parameter values to variables. 

To create variables:

1 Click the schematic window to make it active.

2 Choose Draw > Add Equation.

3 Move the cursor into the schematic to display an edit box.

4 Position the edit box near the top of the schematic window and click to 
place it.

5 Type �IND=15� (without the quotes) in the edit box, and then click outside 
of the box.

6 Repeat Steps 2 through 5 to create a second edit box, but type �CAP=8� 
(without the quotes).

7 Double-click the L parameter value of IND L1. An edit box displays. Type 
the value �IND� and then click outside of the edit box.
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8 Repeat Step 7 to change the L parameter value of IND L4 to �IND�, and the 
C parameter values of CAP C1 and CAP C3 to �CAP�, as shown in the 
following figure.

To enable the IND and CAP variables for optimization:

1 Choose Simulate > Optimize. The Optimizer dialog box displays.

2 Click Variables at the bottom left of the dialog box to display the Variables 
tab.

3 Locate the IND and CAP variables in the Parameter column.

4 Click the box in the Optimize column in both the IND and CAP rows.

5 Click the box in the Optimize column in the CAP C2 row, then click the X at 
the top right of the dialog box to close it.
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PORT
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Adding Optimization Goals
When you set an optimization goal, it is specified in the units set when the goal 
is created.

To add optimization goals:

1 In the Project Browser, right-click Optimizer Goals and choose Add Opt 
Goal. The New Optimization Goal dialog box displays. 

2 Select lpf:DB(|S(1,1)) as the Measurement. Select Meas < Goal as the Goal 
Type, deselect Max under Range and type �500� as the Stop value, type 
�-17� db as the insertion loss Goal, and then click OK.

3 Repeat Step 1, then select lpf:DB(|S(2,1)) as the Measurement, select Meas 
> Goal as the Goal Type, deselect Max under Range and type �500� as the 
Stop value, type �-1� db as the attenuation Goal, and then click OK.

4 Repeat Step 1, then select lpf:DB(|S(2,1)) as the Measurement, select Meas 
< Goal as the Goal Type, deselect Min under Range and type �700� as the 
Start value, type �-30� as the Goal, and then click OK.

Optimizing the Circuit
1 Choose Simulate > Optimize. The Optimizer dialog box displays.

2 Click the arrow to the right of Optimization Methods and select Random 
(Local), type �5000� in Maximum Iterations, and then click Start. The 
optimization runs.
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3 When the optimization is complete, click the X box to exit the Optimizer 
dialog box. The optimized response in the following schematic and graph 
should display. Note that your IND and CAP values may vary slightly.

Creating Vector Variables
MWO equation functionality enables optimization on subcircuits. The string 
and vector variable features in the Equation Editor allow you to specify a vector 
of subcircuits that can be optimized. To demonstrate this feature, the lpf 
schematic is copied, edited, and renamed to create the vector of subcircuits.
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To create copies of the lpf schematic:

1 Click the �lpf� schematic in the Project Browser and drag and drop it onto 
Circuit Schematics. A duplicate schematic named �Copy of lpf � is created. 
Repeat this process to create a second copy named �Copy 2 of lpf �.

2 Right-click �Copy of lpf � in the Project Browser, and choose Rename 
Schematic. Type �lpf2� in the Rename Data Source dialog box. Repeat this 
step to rename �Copy 2 of lpf � to �lpf3�. The Project Browser displays as 
follows.

To modify element parameters in the lpf2 and lpf3 schematics (so that each 
schematic is different):

3 Click the �lpf2� schematic window to make it active. Double-click the IND 
and CAP variables and change them to the following values.
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4 Click the �lpf3� schematic window to make it active. Change the C 
parameter value of CAP ID=C2 to the following value.

To create a schematic which contains a subcircuit that references the three 
schematics:

5 In the Project Browser, right-click Circuit Schematics and choose New 
Schematic. Type �Opt_w_subckt� in the Enter Schematic Name dialog 
box, then click OK.

6 In the Element Browser, click Subcircuits. Click the �lpf � subcircuit and 
drag it onto the �Opt_w_subckt� schematic window.

7 Place ports on the subcircuit as follows. (For details, see �Placing Ports on a 
Node� on page 4-5.)
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To create a vector of subcircuits and an index variable to optimize:

8 Create a vector variable Xvector={"lpf3","lpf2","lpf"} in the 
Opt_w_subcircuit schematic as follows. (For details, see �Creating 
Variables� on page 4-12.)

9 Create an index variable X=Xvector[1] in the same schematic, and change 
the NET parameter to �X� as shown in the following figure. (For details, 
see �Editing Element Parameters� on page 4-6.)
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Optimizing with Subcircuits
The variable X=Xvector[1] references the lpf3 subcircuit which can be tuned or 
optimized over the vector of subcircuit elements by varying the index in the 
variable. It is important to note that the index (and not the actual element in the 
vector) is optimized and tuned. 

1 Click the �s21 and s11� graph in the Project Browser and drag and drop it 
onto Graphs. A duplicate graph named �Copy of s21 and s11� is created. 

2 Right-click �Copy of s21 and s11� and choose Rename Graph. Type 
�subckt opt� in the Rename Output Document dialog box and click OK. 
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3 Double-click the lpf:DB(|S(1,1)) measurement under the �subckt opt� 
graph in the Project Browser. The Modify Measurement dialog box 
displays.

4 Select Opt_w_subckt as the Data Source Name and click OK.

5 Repeat steps 3 and 4 for the lpf:DB(|S(2,1)) measurement. The modified 
measurements are shown as follows.

6 Choose Simulate > Analyze. The simulation response in the following 
graph should display.
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7 Click the �Opt_w_subckt� schematic window to make it active. Select the 
X=Xvector[1] equation, right-click, and choose Properties. The Edit 
Equation dialog box displays.

8 Select the Optimize and Constrain check boxes under Tuning/Optimization 
Mode. Type �1� as the Upper bound value and �3� as the Lower bound 
value, then click OK.

9 Add an optimization goal for the Opt_w_subckt:DB(|S(1,1)) measurement 
using the values shown in the following figure. For details, see �Adding 
Optimization Goals� on page 4-14.
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10 Choose Simulate > Optimize. The Optimizer dialog box displays.

11 Click the arrow to the right of Optimization Methods and select Random 
(Local), type �100� in Maximum Iterations, and click Start. The simulation 
runs.

12 When the simulation is complete, click the X box to exit the Optimizer 
dialog box. The final optimized response in the following graph should 
display.
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13 Save your work by choosing File > Save Project.
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Layouts are views of the physical representations of a schematic. Layout is a critical 
part of high-frequency circuit design and simulation, since the response of a circuit 
is dependent on the geometric shapes with which it is composed.

LAYOUTS IN MICROWAVE OFFICE

Microwave Office�s layout capability, architected using advanced object-oriented 
programming techniques, is tightly integrated with its schematic and EM structure 
building capabilities. The Layout view is actually another view of the schematic, and 
any modifications you make to a schematic are simultaneously updated in its 
corresponding layout. This eliminates the need for complicated design 
synchronization and back annotation before you perform your simulations.

The following example demonstrates basic layout features. Microwave Office offers 
many advanced features that allow you to generate complex layouts such as MMIC 
circuits and various types of multi-layer boards. For more advanced layout topics, 
see the Microwave Office User Guide.

Layout Tips and Tricks
The following keyboard shortcuts are helpful as you use Microwave Office�s layout 
capability.

Keystrokes Layout Function

Press the + key Zoom in 

Press the - key Zoom out

Press the Home key Full view

Press the Ctrl key, select a shape, move 
the mouse

Snap to corners, edges, and centers of 
circles

Select a shape, hold down the mouse 
button, press the Tab key

Move shape with coordinate entry
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CREATING A LAYOUT FROM A SCHEMATIC

This example demonstrates how to use Microwave Office to create a layout 
from a schematic. It includes the following main steps:

� Importing a Layer Process File (LPF)
� Editing Database Units and Default Grid Size
� Importing a cell library
� Importing and placing a data file in a schematic
� Changing an element symbol
� Placing microstrip lines for layout
� Assigning an artwork cell to a schematic element
� Viewing a layout
� Anchoring a layout cell
� Creating an artwork cell
� Manipulating the MTRACE2 element in layout
� Snapping functions in layout
� Exporting a layout

Creating a New Project
The example you create in this chapter is available in its complete form as 
�layout_example.emp� in your Program Files\AWR\AWR2003\Examples\
Getting Started\Microwave Office\Layout directory. You can use this example file 
as a reference.

To create a project:

1 Choose File > New Project.

2 Choose File > Save Project As. The Save As dialog box displays.

3 Navigate to the directory in which you want to save the project, type 
�layout_example� as the project name, and then click Save.

Press Ctrl+Shift while clicking on 
layered shapes

Cycle through layered shapes/elements 
and select them individually

Keystrokes Layout Function
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Importing a Layer Process File
A Layer Process File (LPF) defines the default settings for the layout view, 
including drawing layers, layer mappings, 3D views, and EMsight mappings.

To import an LPF:

1 Click the Layout tab at the lower left of the window to display the Layout 
Manager.

2 Right-click Layer Setup in the Layout Manager, and choose Import Process 
Definition. The Open dialog box displays.

3 Locate the program directory (C:\Program Files\AWR\AWR2003 is the 
default installation directory) and double-click it to open it. If you changed 
the default installation directory, then locate that directory instead when the 
program directory is referenced.

4 Click the �MIC_english.lpf � file and click Open. The following figure 
shows the Layout Manager. 

Editing Database Units and Default Grid Size
A database unit is defined as the smallest unit of precision for a layout. It is very 
important that this parameter is not changed once it is set. Changing database 
units can cause rounding errors that may lead to problems in the layout file. The 
grid size is important because many IC designs must reside on a grid. The grid 
must be greater than or equal to the database unit. Because the grid multiplier�s 
smallest unit is .1x, you should set the grid to 10 times the database unit to 
prevent having a smaller grid than database unit. 

Layout Manager
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To edit the database unit and grid size:

1 Choose Options > Layout Options. The Layout Options dialog box 
displays.

2 On the Layout tab, type �.1� in Grid Spacing and �.01� in Database unit 
size, and then click OK.

Importing a GDSII Cell Library
Cell libraries are used in Microwave Office to provide both the physical 
packages and footprints for printed circuit board or hybrid design processes, as 
well as the standard artwork cells used in MMIC and RFIC design processes. 
Microwave Office supports the GDSII file format as the native drawing tool 
format.

To import a GDSII cell library:

1 Right-click Cell Libraries in the Layout Manager and choose Read GDSII 
Library.

2 Locate the program directory and double-click it to open it.

3 Double-click the Examples subdirectory, then double-click the Getting 
Started, Microwave Office, and Layout subdirectories.

4 Select the packages.gds file and click Open. The imported cell library 
displays in the Layout Manager. If a warning message displays, click OK.
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Importing a Data File
To import a data file:

1 In the Project Browser, right-click Data Files and choose Import Data File. 
The Open dialog box displays.

2 Locate the program directory and double-click it to open it.

3 Double-click the Examples subdirectory, then double-click the Getting 
Started, Microwave Office, and Layout subdirectories. 

4 Select the �N76038a.s2p� file and then click Open. 

PLACING A DATA FILE IN A SCHEMATIC

To place a data file in a schematic:

1 Right-click Circuit Schematics in the Project Browser, choose New 
Schematic, and create a schematic named �qs layout�, then click OK. 

2 In the Element Browser, expand the Subcircuits category. 

3 Click the N76038a model and place it in the schematic window.
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CHANGING THE GROUND NODE OF A DATA FILE

You may occasionally need to access the ground node of a data file.

To expose the ground node of a transistor data file:

1 Double-click the subcircuit element in the schematic window. The Element 
Options dialog box displays.

2 Click the Ground tab. 

3 Select Explicit ground node, then click OK. 

Changing the Element Symbol
You can change the subcircuit symbol to represent a FET so that you can see 
which nodes correspond to the gate, drain, and source.

To change the element symbol:

1 Double-click the subcircuit element in the schematic window. The Element 
Options dialog box displays.

2 Click the Symbol tab.

3 Select FET@system.syf in the list box, and then click OK.
5-6 MWO/VSS 2003



M WO :  C R E A T I N G  L A YO U T S  F R O M  S C H E M A T I C S
Creating a Layout From a Schematic
Placing Microstrip Elements for Layout
Microstrip elements have default layout cells associated with each element. The 
layout cells are parameterized and dynamically sized to the values specified for 
each parameter. 

Microwave Office has specialized microstrip elements called Icells� (intelligent 
cells) that do not require any parameter values for the dimensions of the 
element. Icells automatically inherit the necessary parameters from the 
connecting element.

To place microstrip elements:

1 In the Element Browser, expand the Microstrip category, then click the 
Lines subgroup. Select the MLIN model and place it onto node 1 of the 
N7068a subcircuit in the schematic window.

2 In the Microstrip category, click the Junctions subgroup. Select the 
MTEE$ model and place it in the schematic window connected to the 
MLIN element as shown in the following figure.

TIP: Elements with names ending in �$� inherit their attributes from the ports to 
which they connect. Elements with names ending in �X� are created from a 
look-up table of EM-generated models. Thus, the name �MTEEX$� is a 
microstrip tee junction based on an EM model look-up table that inherits 
its widths from the ports to which it connects.
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3 In the Microstrip category, click the Lines subgroup. Select the MTRACE2 
model and place it in the schematic window onto node 1 of the MTEE$ 
element.

4 Select the MLEF model and place it in the schematic window. Right-click 
three times to rotate the element, then position it onto node 3 of the 
MTEE$ element.

5 Double-click the MTRACE2 element in the schematic window to display 
the Element Options dialog box. 

6 Edit the MTRACE2 parameters to match those shown in the following 
figure, then click OK.

7 Repeat step 6 for the MLIN and MLEF elements to match their parameters 
to those shown in the following figure.

8 Click the Substrates category, then select the MSUB model and place it on 
the schematic window as shown in the following figure.
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9 Double-click the MSUB element in the schematic window to display the 
Edit Element dialog box. Edit the MSUB parameters to match those in the 
following figure, then click OK.

10 Click the Port button on the toolbar, move the cursor onto the schematic, 
position the port on the left node of the MTRACE2 element as shown in 
the following figure, and click again to place it.

11 Add another port to node 2 of the SUBCKT element. Right-click three 
times to rotate the port, position it, and click again to place it.

12 To complete the schematic, click the Ground button on the toolbar, move 
the cursor into the schematic, position the ground on node 3 of the 
SUBCKT element, and click again to place it.
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Assigning an Artwork Cell to a Schematic Element
Artwork cells that represent a package layout can be assigned to a schematic 
element. 

To assign an artwork cell:

1 Double-click the �N76038a� subcircuit element in the schematic window to 
display the Element Options dialog box. 

2 Click the Layout tab.

3 Select Alpha_212_3 in the cell list at the right of the dialog box, then click 
OK. 
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Viewing a Layout
The schematic and layout are different views of the same database. Edits made 
to the parameters in the schematic are instantly updated in the layout, and vice 
versa.

To view a layout:

1 Click the schematic window to make it active.

2 Choose View > New Layout View or click the New Schematic Layout View 
button on the toolbar to view a layout representation. The layout displays in 
a layout window.

3 Choose Edit > Select All to select all of the layout cells.

4 Choose Edit > Snap Together to snap all of the faces of the artwork cells 
together.

Anchoring a Layout Cell
Layout cells have various properties that determine the connectivity of each cell 
in the layout view. One of the important properties is anchoring. Anchoring a 
layout cell holds the cell in place so that it cannot be moved by snapping 
functions. An anchored layout cell is typically used to define a reference point 
for the layout.

To anchor a layout cell:

1 Select the �Alpha_212_3� artwork cell. Right-click, and choose Shape 
Properties to display the Cell Options dialog box.
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2 Click the Layout tab, select the Use for anchor check box, and click OK. 
The artwork cell now has an anchor symbol as shown in the following 
figure.

Creating an Artwork Cell
To create an artwork cell:

1 Click the Layout tab to activate the Layout Manager. 

2 Right-click Packages and choose New Layout Cell. The Create New Layout 
Cell dialog box displays.

3 Name the cell �chip cap� and click OK. A drawing window displays in the 
workspace.
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4 Click the Set Grid Snap Multiple button on the toolbar and set it to 10x.

5 Click the Copper box in the left column of the lower pane to enable copper 
as the active layer, as shown in the following figure. (Do not click the light-
bulb, as that specifies hiding or showing drawing layers.)

6 Choose Draw > Rectangle.

7 Move the cursor into the drawing window, then press the Tab key. The 
Enter Coordinates dialog box displays. 

8 Type the values �0� and �10� in x and y, respectively, and click OK. 

9 Press the Tab key again to display the Enter Coordinates dialog box.

10 Type the values �10� and �-10� in dx and dy, respectively, and click OK. The 
following figure shows the resulting drawing. (You may need to adjust your 
view by choosing View > Zoom In or View > Zoom Out.)

Click this box to 
enable copper as 
the active layer.
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11 Click the Footprint box in the left column of the lower pane of the Layout 
Manager to enable footprint as the active layer.

12 Click the �chip cap� window to make it active.

13 Choose Draw > Rectangle.

14 Move the cursor into the �chip cap� window, then press the Tab key. The 
Enter Coordinates dialog box displays. 

15 Type the values �10� and �10� in x and y, respectively, and click OK. 

16 Press the Tab key again to display the Enter Coordinates dialog box.

17 Type the values �20� and �-10� in dx and dy, respectively, and click OK. The 
following figure shows the resulting drawing.
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18 Click the copper square in the �chip cap� window, and press Ctrl+C then 
Ctrl+V to copy and paste it. Slide the mouse to position the copied square 
along the right edge of the rectangle as shown in the following figure, and 
click to place it.
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ADD PORTS TO AN ARTWORK CELL

Ports in the artwork cell editor define the faces to which other layout cells 
connect. The orientation of the port arrow determines the direction of 
connection to the adjacent layout cell.

To add ports to an artwork cell:

1 Choose Draw > Cell Port.

2 Move the cursor into the �chip cap� window. Press and hold the Ctrl key 
while you move the cursor over the bottom left vertex of the square until a 
square symbol displays on the vertex. Do not release the Ctrl key. 

3 With the Ctrl key still pressed, click and hold down the mouse button while 
moving the cursor to the top vertex, until another square displays on that 
vertex. Release the mouse button and the Ctrl key.
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4 Repeat steps 1 through 3 to place a port on the opposite side of the 
drawing, but start at the top vertex and draw down.
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5 Click the X at the top right of the �chip cap� window. A dialog box asks if 
you want to save the cell edits. Click Yes to save.

Editing the Schematic and Assigning a Chip Cap Cell
To edit the schematic and assign a chip cap cell:

1 Click PORT 1 in the schematic window. 

2 Press and hold the Ctrl key while you drag the port away from the 
MTRACE2 element, as shown in the following figure.
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3 In the Element Browser, expand the Lumped Element category, then click 
the Capacitor subgroup. Select the CAP model, and place it in the 
schematic window between PORT 1 and the MTRACE2 element.

4 Double-click the CAP C1 element in the schematic window. The Element 
Options dialog box displays.

5 Click the Layout tab. 

6 Select �chip cap� from the list of cells, then click OK.

7 Choose View > New Layout View. The new layout displays in the workspace. 
The layout and corresponding schematic are shown in the following figures.
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 Routing the MTRACE2 Element in Layout
The MTRACE2 element is a special element that you can edit in the layout view 
to route a microstrip line. 

To route the MTRACE2 element:

1 Double-click the MTRACE2 element in the Layout View to activate the 
blue grab diamonds.

2 Move the cursor over the right-most diamond until a double arrow symbol 
displays. Double-click to activate the routing tool.

3 Move the routing tool to the desired point and click to place. (Right-click to 
delete the last point; press the Esc key to cancel the activity.)
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4 Continue to route points by moving the routing tool and clicking to place, 
then double-click to complete the routing.

TIP: MLIN is a straight element with a width you can change in the layout. You 
can edit the MTRACE2 elements in the layout to create jogs and bends and 
chamfered corners. You can edit the MCTRACE element to create jogs and 
bends with rounded corners.

Snapping Functions for Layout Cells
Snapping functions connect the faces of artwork cells in various configurations. 
You can set snapping options from the Layout Options dialog box.

To specify the snapping options:

1 Choose Options > Layout Options. The Layout Options dialog box 
displays.

2 In the Layout tab, select Manual snap selected objects only under Layout 
Cell Snap Options, then click OK.
G e t t i n g  S t a r t e d  G u i d e   5-21



M WO :  C R E A T I N G  L A YO U T S  F R O M  S C H E M A T I C S

Creating a Layout From a Schematic
5

To separate the layout cells so the change in snapping options is viewable:

3 Click the MLEF layout cell and drag it to a new position as shown in the 
following figure.

4 Repeat step 3 with the MTRACE2 element and the chip cap cell. Position 
the layout cells as shown in the following figure.
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The red lines indicate that the faces of the layout cells are not snapped together. 

To snap a selected set of layout cells together:

5 Hold down the Shift key and select the MLEF, MTRACE2, and MTEE$ 
layout cells in the layout window.

6 Click the Snap Together button on the toolbar. Observe that the chip cap 
layout cell and MLIN layout cell are not snapped together.
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To snap all of the faces together:

7 Type Ctrl+A to select all of the layout cells. 

8 Click the Snap Together button on the toolbar. The layout displays as 
shown in the following figure.

The �snap to fit� function finishes the routing of an MTRACE2 layout cell to a 
specified adjacent layout cell. In this example, the chip cap layout cell is moved 
and MTRACE2 re-routes to snap to the chip cap face.

To �snap to fit� MTRACE2 to the chip cap:

9 Position the chip cap artwork cell as shown in the following figure.
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10 Select the MTRACE2 layout cell, hold down the Shift key and select the 
chip cap artwork cell.

11 Click the Snap to Fit button on the toolbar. The MTRACE2 routes to snap 
to the chip cap artwork cell as shown in the following figure.
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Exporting the Layout
To export a layout:

1 Choose Options > Drawing Layers to specify the file layers to export. The 
Layer Setup dialog box displays.

2 Click the Export Mapping tab.

3 Click the DXF tab at the bottom of the dialog box, and in the Write Layer 
column, deselect all of the drawing layers except the copper layer, then click 
OK.

4 Choose Layout > Export. The Export Layout dialog box displays.
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5 Select DXF(Flat*.dxf) in Save As Type.

6 Type �CopperLayer� as the Filename, and click Save to export the copper 
file layer to a DXF file. 

7 Save your work by choosing File > Save Project.
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MWO: USING THE NONLINEAR SIMULATOR 6
Harmonic balance (HB) is an efficient method for the steady-state analysis of 
nonlinear circuits such as power amplifiers, mixers, multipliers and oscillators. 
This chapter presents an overview of HB simulations in Microwave Office. For 
more detailed information, see the Microwave Office User Guide.

HARMONIC BALANCE IN MICROWAVE OFFICE

Microwave Office simplifies HB simulation setup. The schematic entry, 
measurements, and analysis are accomplished much as they are for a linear 
simulation. Unlike linear analysis, HB requires the presence of voltage, current, 
or power sources. Microwave Office includes a variety of intuitive source 
elements and allows you to specify single- and multi-tone excitations. The HB 
simulator is automatically invoked when appropriate excitations are present in 
the schematic, and corresponding measurements exist.

Single-Tone Analysis
A single-tone HB analysis simulates the circuit at a fundamental frequency, at 
integer multiples of the fundamental frequency, and at DC. Single-tone 
harmonic balance requires the specification of a fundamental frequency (or a 
frequency sweep) and the total number of harmonics.

Multi-Tone Analysis
Multi-tone simulations are used to determine the output of a circuit excited by 
two or more frequencies that cannot be expressed as integer multiples of one 
another. Typical examples include the LO and RF signals in a mixer and closely 
spaced tones used for intermodulation testing of amplifiers.

Nonlinear Measurements
Microwave Office offers a large number of post-processing functions for 
viewing simulation results in both the frequency and the time domain. Examples 
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include large signal S-parameters, voltages and currents at arbitrary nodes, 
intercept points, power spectra and power-added efficiency. Results may be 
swept over any number of arbitrary parameters. 

The following example illustrates some of the key features of the Microwave 
Office nonlinear simulator.

CREATING A POWER AMPLIFIER CIRCUIT

This example demonstrates how to use Microwave Office to simulate a power 
amplifier circuit using the HB nonlinear simulator.

The basic procedures in this example include:

� Using nonlinear models from the element library
� Creating an IV curve measurement
� Biasing the transistor and measuring voltages and currents
� Adding schematic back annotation
� Importing a schematic
� Creating a hierarchical circuit using subcircuits
� Creating a power out versus frequency measurement
� Creating a dynamic load line measurement
� Adding a two-tone excitation port

Creating a New Project
The example you create in this chapter is available in its complete form as 
�nonlinear_example.emp� in your Program Files\AWR\AWR2003\Examples\
Getting Started\Microwave Office\Nonlinear directory. You can use this example 
file as a reference.

To create a project:

1 Choose File > New Project.

2 Choose File > Save Project As. The Save As dialog box displays.

3 Navigate to the directory in which you want to save the project, type 
�nonlinear_example� as the project name, and then click Save. 
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SETTING DEFAULT PROJECT UNITS

To set default project units:

1 Choose Options > Project Options. The Project Options dialog box 
displays.

2 Click the Global Units tab and verify that your settings match those in the 
following figure. You can choose units by clicking the arrows to the right of 
the display boxes.

3 Click OK to save your settings.

Creating a Schematic
To create a schematic:

1 Choose Project > Add Schematic > New Schematic. The Create New 
Schematic dialog box displays.

2 Type �IV Curve�, and click OK. A schematic window displays in the 
workspace.

PLACING A NONLINEAR MODEL FROM THE LIBRARY

To place a nonlinear model:

1 Click the Elem tab at the lower left of the window to display the Element 
Browser.
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2 Expand the Library category, then expand the Nonlinear and Getting 
Started subgroups. Click the GBJT subgroup, then select the BLT11_chip 
model and place it as shown in the following figure.

PLACING AN IV CURVE METER ON THE NONLINEAR ELEMENT 

To place an IV curve meter element with stepped current:

1 Under Circuit Elements, expand the MeasDevice category, then click the IV 
subgroup. Select the IVCURVEI model and place it as shown on the 
following schematic.

2 Place the cursor over the Step node of IVCURVEI. The cursor displays as a 
wire coil symbol. Click, then drag the cursor to node 1 of the GBJT 
transistor, and click to place the wire.

3 Repeat step 2 to connect the Swp node of IVCURVEI to node 2 of the 
GBJT transistor.

4 Click the Ground button on the toolbar. Move the cursor into the schematic 
window and position the ground on node 3 of the GBJT transistor, then 
click to place it.

S

C

B

E

1

2

3

4

GBJT
ID=GP_BLT11_chip_1
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EDITING THE IV CURVE METER ELEMENT

To specify IVCURVEI settings:

1 In the schematic window, double-click the IVCURVEI element. The 
Element Options dialog box displays.

2 Edit the parameters to the values shown in the following figure, then click 
OK.
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ADDING AN IV CURVE MEASUREMENT

To create a graph and add an IV curve measurement:

1 In the Project Browser, right-click Graphs and choose Add Graph. The 
Create Graph dialog box displays.

2 Type �IV BJT� in Graph Name, select Rectangular as the Graph Type, and 
click OK. The graph displays in the workspace.

3 Right-click the �IV BJT� graph in the Project Browser, and choose Add 
Measurement. The Add Measurement dialog box displays.

4 Select Nonlinear > Current in Meas. Type and IVCurve in Measurement. 
Select IVCurve as the Data Source Name, and click OK.

5 Choose Simulate > Analyze. The simulation response in the following 
graph displays.

TIP: You can disable parameter markers by right-clicking on the graph and 
choosing Properties. On the Markers tab of the Graph Properties dialog 
box, clear the Param markers enabled and Param markers in legend check 
boxes.

 Creating a Bias Circuit
To create a DC bias circuit:

1 Choose Project > Add Schematic > New Schematic. The Create New 
Schematic dialog box displays. Type �DC Bias� and click OK.
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2 In the Element Browser, expand the Library category, then expand the 
Nonlinear and GettingStarted subgroups. Click the GBJT subgroup, then 
select the BLT11_chip model and place it on the schematic as shown in the 
following figure.

3 Expand the Lumped Element category, then click the Inductor subgroup. 
Select the IND model, and place it above and to the left of the GBJT 
transistor as shown in the following figure.

4 Place the cursor on node 1 of the GBJT transistor. The cursor displays as a 
wire coil symbol. Click, then drag the cursor to the right node of IND, and 
click to place the wire. 

5 Double-click the IND model and set the L parameter to �1�, then click OK.

6 Click the Resistor subgroup under Lumped Element. Select the RES model 
and place it as shown in the following figure after right-clicking once to 
rotate the element.

7 Double-click the RES model and set the R parameter to �0.5�, then click 
OK. 

8 Click the Ground button on the toolbar and position the ground on the 
bottom of RES R1 as shown in the following figure.

9 Repeat step 8, positioning the ground on node 4 of the GBJT transistor as 
shown in the following figure.

10 Expand the Sources category, then click the DC subgroup. Select the 
DCVS model and place it as shown in the following figure.
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11 Click the Ground button on the toolbar and position the ground on the 
open end of DCVS V1 as shown in the following figure.

12 Double-click the DCVS model and set the V parameter to �1�, then click 
OK. 

13 Click IND L1 in the schematic window. Press Ctrl+C, then Ctrl+V to copy 
and paste it. Connect the new IND element to node 2 of the GBJT model 
as shown in the following figure.

14 Copy the DCVS model and place the copy on the open node of IND L2 as 
shown in the following figure.

15 Double-click the DCVS V2 model and set the V parameter to �6�, then 
click OK.

16 Click the Ground button on the toolbar and position the ground on the 
negative node of DCVS V2 as shown in the following figure.

ADDING SCHEMATIC BACK ANNOTATION

To add schematic back annotation to display DC voltage and current 
measurements:

1 Right-click the �DC Bias� schematic in the Project Browser and choose 
Add Annotation. The Add Annotation to the Schematic dialog box displays.

2 Specify a voltage measurement using the settings in the following figure, 
then click OK.
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then click OK.

4 Choose Simulate > Analyze. The voltage displays at all nodes and the 
current displays at each element as shown in the following figure.
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ADDING A HARMONIC BALANCE PORT

Before adding a harmonic balance port, you must add DC blocking capacitors 
to the transistor input and output.

To add DC blocking capacitors:

1 Click the �DC Bias� schematic window in the workspace to make it active.

2 In the Element Browser, expand the Lumped Element category, then click 
the Capacitor subgroup. Select the CAP model and connect it to node 1 of 
the GBJT transistor as shown in the following figure.

3 Double-click the CAP model and set the C parameter to �100�, then click 
OK. 

4 Copy the CAP model (hereinafter referred to as CAP C1) and connect the 
copy (CAP C2) to node 2 of the GBJT transistor as shown in the following 
figure.

You must also add an RF bypass capacitor across the emitter resistor. 

To add an RF bypass capacitor:

5 Copy the CAP C1 model and place the copy (CAP C3) to the left of RES 
R1 after right-clicking once as shown in the following figure.

6 Connect the top node of CAP C3 to node 3 of the GBJT transistor. 
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7 Connect a wire between the bottom node of CAP C3 and ground. 

To add a harmonic balance port:

1 In the Element Browser, expand the Ports category, then click the 
Harmonic Balance subgroup. Select the PORT1 model and connect it to 
CAP C1 as shown in the following figure.

2 Double-click PORT1 and set the PWR parameter to �23�, then click OK. 

3 Click the Port button on the toolbar and add a port to the open node of 
CAP C2 (output blocking) as shown in the following figure. This port is 
considered a termination port.
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SPECIFYING NONLINEAR SIMULATION FREQUENCIES

You can specify simulation frequencies in several ways:

� As a global sweep in Project Options (Options > Project Options > 
Frequencies tab)

� As a document sweep, (right-click the schematic node and choose 
Options > Frequencies tab)

� By placing a SWPFRQ component (found under Circuit Elements in 
the Simulation Control category) on the schematic. 

You select the frequency sweep used by the simulator in the Add/Modify 
Measurement dialog, as shown in �Adding a Large Signal Reflection Coefficient 
Measurement� on page 6-13. The following step defines the frequency sweep 
using a document sweep, which is the simplest and most convenient means.

To specify a document frequency sweep:

1 In the Project Browser under Circuit Schematics, right-click �DC Bias� 
and choose Options. The Options dialog box displays.

2 Click the Frequencies tab.

3 Clear the Use project defaults check box, select GHz as the Data Entry 
Units, select Replace, specify the Start, Stop and Step values shown in the 
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following figure, click Apply to display the values in Current Range, and 
then click OK.

ADDING A LARGE SIGNAL REFLECTION COEFFICIENT 
MEASUREMENT

Microwave Office makes it easy to compute large-signal network parameters. 
The following exercise demonstrates how to compute the large signal reflection 
coefficient and display it on a Smith Chart.

To create a Smith Chart:

1 In the Project Browser, right-click Graphs and choose Add Graph. The 
Create Graph dialog box displays.

2 Type �Input reflection� in Graph Name, select Smith Chart as the Graph 
Type, and click OK.

To add a large signal reflection measurement:

3 Right-click �Input reflection� under Graphs and choose Add Measurement. 
The Add Measurement dialog box displays.

4 Select Nonlinear > Parameter as the Meas. Type, Gcomp as the 
Measurement, and DC Bias as the Data Source Name. Select PORT_1 as the 
Measurement Component, click the arrows to the right to select 1 in 
Harmonic Index, and then click Apply and OK. 

Note the frequency sweep control which simplifies control of the 
simulation frequencies and allows you to select among the available 
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frequency sweeps. The default setting is the document sweep discussed in 
�Specifying Nonlinear Simulation Frequencies� on page 6-12.

5 Choose Simulate > Analyze. The following simulation response displays on 
the Smith Chart.
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Importing Schematics
The input and output matching for the amplifier are imported from existing 
schematics.

To import the input match schematic:

1 In the Project Browser, right-click Circuit Schematics and choose Import 
Schematic. The Open dialog box displays.

2 Locate the C:\Program Files\AWR\AWR2003\Examples\Getting 
Started\Microwave Office\Nonlinear directory and double-click it to open 
it.

3 Select the �input match.sch� file and click Open to import and open the 
schematic.

To import the output match schematic:

4 Right-click Circuit Schematics and choose Import Schematic.

5 Select the �output match.sch� file from the previously opened directory 
and click Open to import and open the schematic.
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Adding Subcircuits to a Schematic
Whenever an n-port schematic is created or imported it automatically becomes 
an n-port subcircuit. You can use these subcircuits within other schematics to 
create circuit hierarchy. 

To add the input match subcircuit to the DC Bias schematic:

1 In the Project Browser under Circuit Schematics, double-click �DC Bias� 
to display the DC Bias schematic.

2 Click PORT1 in the schematic window, then press and hold the Shift key 
while clicking on CAP C1. Both PORT1 and CAP C1 should be selected 
(and are now considered one unit).

3 Press the Ctrl key and click once on the selected elements, then drag them 
to the left of the circuit to break their connection with the circuit, as shown 
in the following figure.
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4 In the Element Browser, click the Subcircuits category then select the 
�input match� subcircuit and place it on the schematic between CAP C1 
and node 1 of the GBJT transistor as shown in the following figure.

5 If the subcircuit nodes do not properly connect with the capacitor and 
transistor you may need to slightly move the elements until the proper 
connections are made.
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6 Repeat steps 2 and 3 with PORT2 and CAP C2 as shown in the following 
figure.

7 Click the Subcircuits category then select the �output match� subcircuit 
and connect it to the open node of CAP C2 after right-clicking twice to invert it, 
as shown in the following figure.

8 Connect node 2 of the output match subcircuit to node 2 of the GBJT 
transistor. 

9 Double-click the Pwr parameter value of the PORT1 element. An edit box 
displays over the value. Type �18� to change the value from 23 to 18 dBm, 
then click outside the edit box to save the change.
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Creating a Pout vs. Frequency Measurement
To create a graph and add a measurement (Pout versus frequency):

1 In the Project Browser, right-click Graphs and choose Add Graph. The 
Create Graph dialog box displays.

2 Type �Pout� in Graph Name, select Rectangular as the Graph Type, and 
click OK.

3 Right-click �Pout� in the Project Browser and choose Add Measurement. 
The Add Measurement dialog box displays.

4 Create a measurement using the settings in the following figure, then click 
OK. 
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5 Choose Simulate > Analyze. The simulation response in the following 
graph displays.
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Creating a Dynamic Load Line Measurement
A dynamic load line measurement plots the large signal performance of the 
circuit superimposed on the IV curve of the device. 

To create a dynamic load line measurement:

1 In the Project Browser, right-click �IV BJT� under Graphs and choose Add 
Measurement. The Add Measurement dialog box displays.

2 Create a measurement using the settings in the following figure, then click 
OK. 

To select the Voltage Measure Component and Current Measure 
Component, click the �...� button to the right of these options. The 
Component Browser shown in the following figure displays to allow you to 
select the desired components. 
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3 Choose Simulate > Analyze. The simulation response in the following 
graph displays.
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Copying a Schematic in the Project Browser
The next exercise involves a two-tone simulation that is swept over power at one 
frequency point. It requires a new schematic of the same circuit with a different 
port configuration. To create the new schematic, you can duplicate the existing 
schematic and edit the port configurations. 

To duplicate the DC bias schematic:

1 Click �DC bias� under Circuit Schematics, drag it up to the Circuit 
Schematics node and release the mouse button. A duplicate schematic 
named �Copy of DC� bias is created.

2 Right-click the �Copy of DC Bias� schematic and choose Rename 
Schematic. Rename the schematic to �Two Tone Amp� in the Rename Data 
Source dialog box, and then click OK.

ADDING A TWO-TONE HARMONIC BALANCE PORT

A common measurement used to characterize power amplifiers is a third-order 
intermodulation product versus swept power. To make this measurement, two 
closely-spaced tones must be injected into the input port.

To add a two-tone harmonic balance port:

1 Click the �Two Tone Amp� schematic window in the workspace to make it 
active. You can press the Home key to view the entire schematic.

2 Double-click PORT1 in the schematic window. The Element Options 
dialog box displays.

3 Click the Port tab. 

4 Specify the port settings shown in the following figure.
G e t t i n g  S t a r t e d  G u i d e   6-23



M WO :  U S I N G  T H E  N O N L I N E A R  S I M U L A T O R

Creating a Power Amplifier Circuit
6

5 Click the Parameters tab and edit the parameters to the values shown in the 
following figure, then click OK. 
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ADDING A THIRD-ORDER INTERMODULATION MEASUREMENT

To add a third-order intermodulation product measurement:

1 Create a rectangular graph named �IM3�. 

2 Right-click �IM3� under Graphs and create a measurement using the 
settings in the following figure, then click OK.

3 Repeat step 2 to plot a fundamental component output power, this time 
selecting �0� and �1� under Harmonic Index.

4 Choose Simulate > Analyze. The simulation response in the following 
graph should display.
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USING VARIABLE SWEEPS TO MEASURE IP3 VS VOLTAGE

The output-referred IP3 measurement extrapolates the low-power results, so in 
this exercise you create another schematic to avoid multidimensional (voltage 
and power) sweeps.

To create a schematic for the IP3 measurement:

1 Copy the �Two Tone Amp� schematic under Circuit Schematics.

2 Right-click the �Copy of Two Tone Amp� schematic and rename it �IP3�.

To change the port excitation to a fixed power:

3 Double-click Port_PS2 P=1. In the Element Options dialog box, click the 
Port tab and clear the Swept power check box, then click OK. The port 
name changes to Port2 P=1.

4 Double-click the Pwr1 and Pwr2 parameter values of PORT2 P=1 and 
change both to �-10�.
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To define a swept variable:

1 Choose Draw > Add Equation. You can also click the Equation button on 
the toolbar.

2 Move the cursor into the schematic to display an edit box. Position the box 
near the top of the schematic window and click to place it.

3 Type �Vcc=1� in the edit box, and then click outside of the box. A variable 
named �Vcc� is created.

4 In the Element Browser, click the Simulation Control category, then select 
the SWPVAR element and place it as shown in the following figure.

5 Specify the SWPVAR parameter settings shown in the following figure to 
define Vcc as a variable swept between 4 and 8 in steps of 0.5, then click 
OK.
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6 Double-click the V parameter value of DCVS V2 and change it to �Vcc�.

To add a graph and measurement:

1 Add a rectangular graph named �IP3�.

2 Create a measurement using the settings in the following figure, then click 
OK.
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3 Choose Simulate > Analyze to obtain the output-referred IP3 intercept, 
swept over the bias voltage, as shown in the following graph.

4 Save your work by choosing File > Save Project.
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Electromagnetic (EM) simulators use Maxwell�s equations to compute the 
response of a structure from its physical geometry. EM simulations are ideal 
because they can simulate highly arbitrary structures and still provide very 
accurate results. In addition, EM simulators are not subject to many of the 
constraints of circuit models because they use fundamental equations to 
compute the response. One limitation of EM simulators is that simulation time 
grows exponentially with the size of the problem, thus it is important to 
minimize problem complexity to achieve timely results.

EM SIMULATION IN MICROWAVE OFFICE

EM simulation and circuit simulation are complementary techniques for circuit 
design, and the two approaches can be used in combination to solve many 
design problems. Microwave Office (MWO) supports the seamless integration 
of many EM simulators via an �EM Socket� software interface. To integrate a 
third-party simulator with the AWR Design Environment, the simulator must 
support an interface complementary to the �EM Socket� interface. One such 
simulator is the latest version of Sonnet® em® (www.SonnetSoftware.com). Since it 
is not possible to document the unique features of all third-party simulators that 
integrate with MWO, the example presented here is centered around Applied 
Wave Research�s native EM simulator, EMSight. The manipulation of the 
geometry and simulations settings in the AWR Design Environment are very 
similar for all simulators. Detailed documentation of the unique functionality 
supplied by other compatible solvers is available from the individual vendors.

EMSight can simulate planar 3D structures containing multiple metallization 
and dielectric layers. The structures can have interconnecting vias between layers 
or to ground. EMSight uses the Galerkin Method of Moments (MoM) in the 
spectral domain, an extremely accurate method for analyzing microstrip, 
stripline, and coplanar structures as well as other more arbitrary media. Properly 
used, this technique can provide accurate simulation results up to 100 GHz and 
beyond.
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The following example illustrates some of the key features of the Microwave 
Office EM simulator.

CREATING A DISTRIBUTED INTERDIGITAL FILTER

This example demonstrates how to use Microwave Office to simulate a 
distributed microstrip interdigital filter using the EM simulator.

The basic procedures in this example include:

� Creating an EM structure
� Defining an enclosure
� Adding a substrate definition
� Creating a layout
� Modelling via holes
� Viewing a structure in 3D
� Defining ports and de-embedding lines
� Viewing current density and electric fields

Creating a New Project
The example you create in this chapter is available in its complete form as 
�EM_example.emp� in your Program Files\AWR\AWR2003\Examples\
Getting Started\Microwave Office\EM directory. You can use this example file as a 
reference.

To create a project:

1 Choose File > New Project.

2 Choose File > Save Project As. The Save As dialog box displays.

3 Navigate to the directory in which you want to save the project, type 
�EM_example� as the project name, and then click Save.

Creating an EM Structure
To create an EM structure:

1 Choose Project > Add EM Structure > New EM Structure. The New EM 
Structure dialog box displays.
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2 Type �Interdigital Filter� and select the AWR EMSight Simulator from the 
list of EM Simulators available on your computer, then click Create. An EM 
structure window displays in the workspace.

TIP: EMSight uses a rectilinear grid for defining structures. When you set up 
designs, use the coarsest grid possible when defining structures, as this 
provides faster simulation time (usually without any compromise in 
simulation accuracy.) Other third-party EM simulators may only use the 
grid for drawing purposes and the density may not matter-- see the third-
party simulator documentation for further details.

SETTING UP THE ENCLOSURE

The enclosure defines all the dielectric materials for each of the layers in an EM 
structure, sets the boundary conditions, and defines the overall physical size of 
the structure and minimum grid units used to specify conductor materials in the 
structure. 

To set up the enclosure:

1 Choose Options > Project Options. The Project Options dialog box 
displays.

2 Click the Global Units tab and select the Metric units check box, then set 
the Length type to �mm� and click OK.

3 In the Project Browser, under EM Structures and �Interdigital Filter�, 
double-click Enclosure. The Substrate Information dialog box displays. 
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4 Under Box Dimensions, type �10� as the X-Dimension, type �50� in X-
Divisions, type �10� as the Y-Dimension, and type �50� in Y-Divisions.

To define the dielectric layers of the enclosure:

5 Click the Dielectric Layers tab in the Substrate Information dialog box.

6 Select Layer 1 under Dielectric Layer Parameters. Type �3� in the edit box 
(near the bottom of the dialog box) in the Thickness column and type �1� 
in the edit box below the er column. Leave the default values in the 
remaining columns.

TIP: In EMSight, simulations run twice as fast if they are loss-less. Therefore, set 
the Loss Tangent to zero and use perfect conductors to define all the 
metallization and vias in an EM structure.

7 Select Layer 2 under Dielectric Layer Parameters. Type �0.635� in the edit 
box in the Thickness column and type �9.8� in the edit box below the er 
column. Type �0.001� in the edit box below the Loss Tangent column and 
type �4� in the edit box below the View Scale column (this expands the 3D 
view for this layer to four times its normal thickness).

8 Select Layer 3 (if present) and click the Delete button.
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VIEWING BOUNDARY CONDITIONS

In EMSight, the boundary conditions for the sidewalls of the enclosure are 
always perfect conductors and cannot be modified. Third-party simulators may 
make other assumptions for the sidewall boundary conditions-- for details, see 
the vendor documentation for the solver used. The boundary conditions for the 
top and bottom of the enclosure have default perfect conductors, but they can 
be modified. You do not modify the default boundary conditions in this 
example. 

To view the boundary conditions:

1 Click the Boundaries tab in the Substrate Information dialog box. 

2 Click OK to complete the enclosure set up procedure.
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Adding Conductors to the Layout
You can use the Microwave Office EM Simulation Editor to draw physical 
structures for simulation. You can also import structures directly from the 
Applied Wave Research layout tool, or import structures from AutoCAD DXF 
or GDSII. In this example you draw the physical layout of a microstrip 
interdigital filter using the EM simulation editor.

To draw the physical layout:

1 Ensure that the Layer 2 tab is active in the EM structure window.

2 Choose Draw > Add Rect Conductor to add a rectangular conductor.

3 Move the cursor into the Interdigital Filter window, and press the Tab key. 
The Enter Coordinates dialog box displays.
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4 Type �0� as the value of x and �2.2� as the value of y, and then click OK. 

5 Press the Tab key again to display the Enter Coordinates dialog box. Ensure 
that the Re (relative) check box is selected, type �2.2� as the value of dx, 
and �0.6� as the value of dy, and then click OK. A rectangular conductor 
displays in the EM structure window. 

To draw a second rectangular conductor:

6 Choose Draw > Add Rect Conductor.

7 Move the cursor into the Interdigital Filter window, and press the Tab key. 
The Enter Coordinates dialog box displays. Type �4� as the value of x and 
�2� as the value of y, and then click OK. 
G e t t i n g  S t a r t e d  G u i d e   7-7



M WO :  U S I N G  T H E  E L E C T R O M A G N E T I C  S I M U L A T O R

Creating a Distributed Interdigital Filter7
8 Press the Tab key again to display the Enter Coordinates dialog box. Type 
�1.2� as the value of dx and �7.2� as the value of dy, and then click OK. A 
second rectangular conductor displays in the EM structure window. 

To move the second rectangular conductor next to the first conductor:

9 Click the second rectangular conductor. Squares display at the rectangle�s 
corners.

10 Slide the cursor over the selected conductor until the cursor displays as a 
cross. 

11 Click and hold down the mouse button. A dx, dy readout displays in the 
window, as shown in the following figure. 
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TIP: Click the Ruler button on the toolbar to measure the dimension of 
conductors, offsets, or spaces in an EM structure layout.

12 Drag the cursor until the dx, dy readout displays dx:-2 and dy:-1, then 
release the button to place the rectangle.

Adding Vias
Vias are interconnects between substrate layers. You must add a via to ground 
one side of the larger conductor to the bottom of the enclosure. 

To add a via:

1 Choose Draw > Add Via.

2 Move the cursor into the Interdigital Filter window and press the Tab key. 
The Enter Coordinates dialog box displays. Type �2.4� as the value of x and 
�1.2� as the value of y, and then click OK. 

3 Press the Tab key again to display the Enter Coordinates dialog box. Type 
�0.4� as the value of dx and �0.8� as the value of dy, and then click OK. A 
via displays in the Interdigital Filter window, with blue squares in its corners 
to show that it is selected.
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4 Choose Edit > Copy, then choose Edit > Paste. 

5 Move the mouse into the EM structure window. An outline of the copied 
via displays. 

6 Right-click once to rotate the via.

7 Press the Tab key to display the Enter Coordinates dialog box. Deselect Re 
to activate absolute coordinates. Type �2.2� as the x value and �1.8� as the y 
value, and then click OK. The new EM structure displays as follows.
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Viewing the Structure in 3D
The EM simulator supports multiple 2D (structure) and 3D views.

 To create a 3D view:

1 Choose View > New 3D View. A window containing the 3D view displays in 
the workspace. 

2 Choose Window > Tile Vertical. The views display side-by-side. 

TIPS: To change the view of a 3D structure, right-click in the 3D window and 
choose Zoom In, Zoom Out, View Area, or View All. 

To rotate a 3D structure, click anywhere in the 3D window and continue to 
hold down the mouse button while you move the mouse. 

Adding Ports and De-embedding Lines
The EM simulator can have electrical ports defined at the edge of the defining 
box (edge ports) or as a via probe coming in from the top or bottom surfaces 
(via ports). 

To define an edge port:

1 Click the smaller conductor in the EM structure window. Note that this 
conductor must be positioned exactly on the left edge of the substrate (X:0; 
Y:2.2) before you can add an edge port to it.

TIP: Choose View > Zoom In once or twice to magnify the view for the following 
steps. 
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2 Choose Draw > Add Edge Port. 

3 Position the cursor to the left edge of the small conductor until the outline 
of a square displays, and click to place the port. A small box with the 
number 1 (indicating port 1) displays at the left edge of the conductor. 

To subtract (de-embed) an amount of electrical length from the simulation 
results, the reference plane for the port must be moved away from the edge of 
the box. 

To de-embed 1mm of electrical length on port 1:

4 Right-click in the EM structure window and choose View Area.

5 With the cursor displayed as a magnifying glass, click and drag the cursor 
around port 1 and the small conductor. The window zooms in on the 
selected area.

6 Click port 1. Four squares display at its corners.

7 Slide the mouse over the edge of the port until the cursor displays as a 
double arrow.
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8 Click and hold down the mouse button to display a dx or dy readout.

9 Drag the cursor to the right until the dx, dy readout displays dx:1. Release 
the mouse button to place the de-embedding line. 

Specifying the Simulation Frequencies
To specify the simulation frequencies:

1 In the Project Browser, right-click �Interdigital Filter� under EM Structures 
and choose Options. The Options dialog box displays.

2 Click the Frequencies tab.
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3 Clear the Use project defaults check box to give local frequency settings 
precedence over global project frequency settings.

4 Ensure that GHz displays in Data Entry Units.

TIP: You can define the simulation frequency globally (by choosing Options >  
Project Options and clicking the Frequencies tab) or locally using these 
steps. It is best to use the local frequency settings for EM structures as you 
typically want to sweep EM structures with fewer frequency points than 
with linear circuits. Data is obtained at the project frequencies using 
interpolation and/or extrapolation. 

5 Specify the Start, Stop and Step values shown in the following figure, click 
Apply to display the values in Current Range, and then click OK.

Running the EM Simulator
The EM simulator is very fast for electrically small structures. To find the 
resonant frequency of the first resonator of the filter, you can run an EM 
simulation on the initial layout of the Interdigital Filter EM structure. 

To simulate the structure:

1 Under EM Structures and �Interdigital Filter�, double-click Information. 
The Solver Information dialog box displays if EMSight is the selected 
simulator. The estimated solve time for the EM structure and other 
information displays, depending on the selected solver. For more 
information about the data displayed for third-party simulators, see the 
vendor documentation. 
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2 Click OK to close the dialog box.

3 Choose Simulate > Analyze. A dialog displays to indicate the simulation 
progress. The progress bar(s) and text are controlled by the electromagnetic 
simulator, so the details of the steps in the analysis may vary. 

TIP: (EMSight) If the amount of memory required to solve a problem is greater 
than the available memory, try redefining the problem so that it runs within 
the available memory of the computer. You may need to add RAM to solve 
large problems efficiently.
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Displaying Results on a Graph
To determine the resonant frequency, you must plot the return loss of the EM 
structure.

To measure the resonant frequency on a graph:

1 In the Project Browser, right-click Graphs and choose Add Graph. The 
Create Graph dialog box displays.

2 Type �EM Graph 1� in Graph Name, select Rectangular as the Graph Type, 
and click OK. The graph displays in the workspace.

3 Right-click the �EM Graph 1� graph in the Project Browser, and choose 
Add Measurement. The Add Measurement dialog box displays.

4 Create a measurement using the settings in the following figure, then click 
OK.

5 Choose Simulate > Analyze. The simulation response in the following 
graph displays. The measurement indicates that the resonant frequency is 
near 4 GHz.
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To determine a more precise measurement of the resonant frequency, you must 
change the frequency range and step size of the simulation. 

Changing Frequency Range and Step Size
To change the simulation frequency range and step size:

1 In the Project Browser, right-click �Interdigital Filter� under EM Structures 
and choose Options. The Options dialog box displays.

2 Click the Frequencies tab.

3 Type �3� in Start, type �5� in Stop, and type �0.1� in Step. Click Apply, 
then click OK.

4 Choose Simulate > Analyze to re-analyze the circuit. The simulation 
response in the following graph displays. 
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Animating Currents and Viewing E-Fields
Viewing the currents and electric fields of an EM structure can be useful when 
studying its physical characteristics. Currently, EMSight is the only simulator 
which can display currents and E-fields within the AWR Design Environment. 
For details on imaging when using an alternate simulator, see the associated 
vendor documentation. 
To animate the currents on the conductors:

1 Click the 3D window of the Interdigital Filter EM structure to make it 
active.

2 Choose Animate > E-Field Settings, select Layer 2, and click OK.

3 Choose Simulate > Analyze.

4 Choose Animate > Animate Play. The animated currents in the 3D view 
display in the workspace.
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5 Choose Animate > Animate Stop to turn off the animation.

To display the electric field of Layer 2:

6 Choose Animate > E-Field Settings. The E-Field Computation dialog box 
displays.

7 Select the Layer 2 check box and click OK.

8 Choose Simulate > Analyze to compute the electric fields.

9 Choose Animate > Animate Play to view the currents and electric field. 

10 Choose Animate > Animate Stop to turn off the animation.

TIP: This animation illustration may vary depending upon your computer 
configuration.
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G e t t i n g  S t a r t e d  G u i d e   7-19



M WO :  U S I N G  T H E  E L E C T R O M A G N E T I C  S I M U L A T O R

Creating a Distributed Interdigital Filter7
To turn off the electric field computations:

11 Choose Animate > E-Field Settings. The E-Field Computation dialog box 
displays.

12 Clear the Layer 2 check box and click OK.

Completing the Filter Layout
To complete the following filter you use some advanced editing features in the 
drawing window.
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To add the small conductor on the end of the input resonator:

1 Click the Interdigital Filter window to make it active.

2 With your cursor in the window, right-click and choose View All.

3 Choose Draw > Add Rect Conductor. Press the Tab key to display the Enter 
Coordinates dialog box.

4 Type �2� as the x value and �8.2� as the y value, then click OK. 

5 Press the Tab key again to display the Enter Coordinates dialog box. Select 
the Re check box to change the relative coordinates. Type �-0.4� as the dx 
value and �-0.2� as the dy value, then click OK. A rectangular conductor 
displays in the EM structure window. 

To draw the output resonator:

6 Choose Edit > Select All. 

7 Choose Edit > Copy, and then choose Edit > Paste. An outline of the input 
resonator displays.

8 Move the cursor to place the outline of the copied instance directly on top 
of the original input resonator, and click. The newly created instance is still 
selected, as shown in the following figure.
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9 Choose Edit > Flip.

10 Move the cursor into the middle of the EM structure window. Click, and 
drag the cursor down, then release the mouse button. The selected instance 
flips as follows. Leave the flipped instance selected.

You must move the flipped instance to align the output line with the edge of the 
structure. To move the flipped instance:

11 Move the cursor over the selected instance until the cursor displays as a 
cross.

12 Click, and drag the outline of the instance until the output line aligns with 
the edge of the structure as follows, then release the mouse button.
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To create the middle resonator:

13 Click near the top left corner of the left-most resonator, and holding the 
mouse button down, drag the cursor down and to the right so the dashed 
box encompasses the resonator, and then release the mouse button. The 
large conductor and the two vias are selected.

14 Choose Edit > Copy, then choose Edit > Paste. An outline of the copied 
instance displays.

15 Move the cursor to the middle of the EM structure window to move the 
copied instance to the middle of the window, then right-click twice to rotate 
the instance 180-degrees.

edge of structure

output line
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16 Press the Tab key to display the Enter Coordinates dialog box.

17 Deselect Re to change the relative coordinates. Type �5.6� as the x value 
and �9.2� as the y value, and then click OK. The EM Structure displays as 
follows. 
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Adding a Port
To complete the EM structure, you must add a port to the output line.

 To add a port to the output line and de-embed 1mm of electrical length:

1 Click the rightmost conductor in the EM structure window.

TIP: Choose View > Zoom In once or twice to magnify the view for the following 
steps. 

2 Choose Draw > Add Edge Port. 

3 Position the cursor on the right edge of the conductor until the outline of a 
square displays, and click to place the port. A small box with the number 2 
(indicating port 2) displays at the right edge of the conductor. 

4 Right-click in the EM structure window and choose View Area.

5 With the cursor displayed as a magnifying glass, click and drag the cursor 
around port 2 and the small conductor. The window zooms in on the 
selected area.

6 Click port 2. Four squares display at its corners.

7 Move the cursor over the edge of the port until it displays as a double arrow.

8 Click and hold down the mouse button to display a dx or dy readout.

9 Drag the cursor to the left until the dx, dy readout displays dx:-1. Release 
the mouse button to place the de-embedding line. The final layout is shown 
in the following figure.
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10 Choose Simulate > Analyze to re-analyze the circuit.

Adding a Measurement to the Graph
To add an s21 measurement to the graph: 

1 Right-click the �EM Graph 1� graph in the Project Browser, and choose 
Add Measurement. The Add Measurement dialog box displays.

2 Create a measurement using the settings in the following figure, then click 
OK. 
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3 Choose Simulate > Analyze. The final simulation response on the following 
graph displays.

4 Save your work by choosing File > Save Project.
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VSS: SYSTEM SIMULATION IN VSS 8
This chapter provides a brief outline of the theory behind the Visual System 
Simulator (VSS), and includes a procedure for a simple amplitude modulation to 
demonstrate how a simulation is performed in VSS. The first section describes 
the basic philosophy of the simulator, and the example describes use of several 
key VSS features.

OVERVIEW OF VSS THEORY

VSS is a sampled time-domain simulator that uses a fixed time step which is set 
either by the default system settings for every system diagram, or by individual 
blocks inside a system diagram (usually sources) and inherited by subsequent 
blocks. This section outlines several important aspects of a VSS simulation, 
including data types, the concept of Complex Envelope signal representation, 
center frequency and sampling frequency and their importance, and finally the 
concept of parameter propagation.

Data Types
All VSS blocks have input and output nodes which handle (and operate on) data 
belonging to one of four basic data types: Digital, Real, Complex, or Unset. 
Each VSS block node color corresponds to its data type: green for Digital, 
yellow for Real, red for Complex, and white for an Unset data type. Unset nodes 
indicate the block supports two or more data types. You can double-click an 
unset node to redefine it as a specific node type. For example, ADD2, a two-
input adder (located in the Element Browser under System Blocks in the Math 
Tools > Adders category) has Unset nodes by default, signifying that it adds the 
data coming into its two nodes and provides the sum at its output node 
regardless of the data type. Another example is the behavioral amplifier AMP_B 
(located in the Element Browser under System Blocks in the RF Blocks > 
Behavioral category), which also has its ports unset. The amplifier block 
supports both real and complex signals, but does not support digital signals.

Digital data types comprise streams of digital data with abrupt transitions (such 
as a pseudo-random sequence of bits generated by a source to perform a 
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Monte-Carlo simulation of a digital communication system). Real data refers to 
any real waveform observed in communication systems, for example, sinusoids, 
real passband noise, or possibly a sawtooth waveform. You can use these two 
data types to represent any waveform encountered in natural system design. 
Complex data deserves more attention because it is a compact way to represent 
complex baseband data (with frequency content concentrated around DC, as 
required by modern communication systems), as well as real passband 
waveforms via the Complex Envelope (CE) signal representation.

Complex Envelope Signal Representation
As a sampled time-domain system simulator, a basic underlying concept of VSS 
is that of sampling frequency-- something not encountered in nature (where all 
signals and waveforms are analog, i.e., they exist in continuous time), but more 
and more prevalent in modern measurement equipment, a growing portion of 
which samples the measured data at a uniform specified rate before 
manipulating or processing it.

In general, sampling an analog signal into a discrete time representation is an 
information-lossless operation only if the sampling frequency exceeds two times 
the highest frequency content of the analog signal. In such cases, recovery of the 
original analog waveform from its sampled stream is typically perfect via an ideal 
lowpass filter. Otherwise, a phenomenon known as aliasing occurs, and it is not 
possible to reconstruct the original analog waveform based on the sampled 
stream.

This concept places a significant burden on any time-domain systems simulator, 
because in a simulated transmitter/receiver chain it forces the overall sampling 
frequency to be at least twice the highest frequency component anywhere in the 
system. This is somewhat wasteful, since up- or down-conversion chains usually 
include carrier-modulated passband signals of relatively low frequency content 
(bandwidth) concentrated around a very high frequency carrier. In principle, the 
signal of interest is the modulating signal and not the carrier, and assuming an 
interest in a narrow band of frequencies around a center frequency, this 
modulating signal can be more efficiently represented by its Complex Envelope 
(CE), assuming the frequencies very far away from the carrier are filtered out 
anyway. For example, consider a GSM signal, which has a bandwidth of a few 
hundred kHz, but is modulated on a 1.9 GHz carrier. In principle, a sampling 
frequency of 5 MHz (more correctly, 5 Msamples/sec) can adequately describe 
the signal in its CE form, but to also comfortably sample the carrier, the 
sampling frequency must be at least 3.8 GHz, and more comfortably 5 GHz, or 
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5 Gsamples/sec. It is obvious how the two different approaches can result in a 
simulation speed difference of three orders of magnitude!

VSS utilizes the CE representation of signals whenever possible to gain the 
tremendous advantage in simulation speed discussed here, without 
compromising simulation accuracy. Specifically, a real passband signal , 
representing a narrowband modulation centered about a high frequency 
sinusoidal carrier with frequency  is mathematically represented as:

,

where  and  are real lowpass signals, with bandwidth much smaller 
than the carrier frequency , and are called the in-phase and quadrature 
components of the real passband signal . The signal can be represented by 
its Complex Envelope (CE) form , where:

,

and, therefore, it holds that the CE lowpass signal is:

.

VSS utilizes the CE lowpass equivalent signal  wherever possible to allow 
for orders-of-magnitude-faster narrowband simulation. To this end, each signal 
at any point in the simulation has a sampling frequency, and a center frequency tag 
associated with it. For example, a plain tone at frequency 2 GHz for which the 
real passband signal is ), can be easily generated using the 
SIN_C block, located under System Blocks in the Sources > Waveforms 
category and represented in CE form in any of the following ways:

� as having a center frequency of 2 GHz and an offset frequency of 0, in 
which case  bears a center frequency tag of 2 GHz, 
or

� as having a center frequency of, for example, 1 GHz and offset 
frequency of 1 GHz, in which case  bears a 
center frequency tag of 1 GHz, or

� as having a center frequency of 0 and an offset frequency of 2 GHz, in 
which case  bears a center frequency tag of 0.

When working with RF tones, the TONE block, located under System Blocks 
in the Sources > RF Sources category, is preferred, as all frequencies are 
specified in absolute frequency and power is specified in dB/dBm.

All of these CE forms show the same spectrum plot (the 2 GHz tone 
corresponding to the real passband signal ), although the time 
domain waveform generated by VSS is internally different. The center 
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frequency tag is a parameter propagated implicitly, but internally the signal is 
modeled as a CE lowpass equivalent.

As another example, the GSM signal previously discussed would also be in CE 
lowpass equivalent form in VSS; a sequence of complex numbers sampled at 5 
MHz and bearing only a center frequency tag of 1.9 GHz, and not a series of 
real samples taken at a rate of 5 Gsamples/sec. Of course, if the latter more 
cumbersome approach is desired, VSS provides the capability to switch any 
signal to real passband representation via the CE-to-Real block (CE2R) located 
under System Blocks in the Converters > Complex Envelope category.

Note that VSS treats complex signals depending on their context, their center 
frequency, and the block performing the operation. For example, blocks found 
under the System Blocks Math Tools > Math Functions category simply 
perform standard complex arithmetic on their input complex signals, treating 
them as ordinary complex numbers. Modulation mapper and detection blocks in 
the Modulation category treat the series of complex samples as baseband I/Q 
symbols. Blocks designed to operate on RF signals, such as those in the Filters 
or RF Blocks categories treat complex signals with non-zero center frequency as 
CE representations of a real signal centered around a carrier at the center 
frequency. When the center frequency is 0, by default the RF amplifier, RF 
mixer and circuit filter blocks treat the complex signal as a pair of real signals 
representing separate I and Q channels.

Center Frequency and Sampling Frequency
It is important to note that the CE representation of signals can greatly reduce 
simulation time, but requires careful choice of the sampling frequency, such that 
the frequencies of interest are included in a simulation. Any simulated CE signal 
only exists for frequencies that lie in the interval:

,

where  is the center frequency of the signal, and  is the sampling frequency.

Therefore, to examine the frequency content (for example, the Adjacent 
Channel Power Ratio, or ACPR) of the previous GSM signal at a frequency 
offset of 30 MHz from the 1.9 GHz carrier (the signal�s center frequency tag), 
you must make sure the sampling frequency is at least  MHz, so that the 
signal exists between 1.87 GHz and 1.93 GHz, or .

Because VSS is geared towards digital communication applications, many of its 
blocks (and the entire system diagram) have Data Rate and Oversampling 
associated with them.

fc
fs
2
---� fc
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2
---+,

fc fs

fs 60≥
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The Data Rate is the number of digital communication symbols per second. 
Inside a VSS system diagram the default data rate is denoted _DRATE. A 
symbol can differ in meaning, depending on the modulation specifics. For 
example, for the previous GSM, the symbol rate or data rate is set by the 
standard as 270.833 ksymbols/sec, and since in this case every symbol is one bit, 
it translates to 270.833 kbits/sec. To simulate a satellite link using Quadrature 
Phase Shift Keying (QPSK) modulation to transmit 100 Mbits/sec, you set the 
symbol rate (or data rate) of the QPSK source block to 50 Msymbols/sec 
(because each QPSK symbol corresponds to 2 bits). The QPSK_SRC block is 
found under the System Blocks Modulation > QPSK category.

Each of these symbols can be represented with any number of samples 
(oversampling). Inside a VSS system diagram the default number of samples per 
symbol is denoted _SMPSYM. For the QPSK example, you can have 10 
samples per symbol, which is a total sampling frequency of:

MHz.

As previously explained, if the center frequency tag of this QPSK signal is 5 
GHz, the signal will exist for 250 MHz on either side of the 5 GHz carrier (from 
4.75 GHz to 5.25 GHz).

For digital communications, the data rate and oversampling values, and the 
center frequency tag of each signal are important. You can set these values on 
the Simulator tab of the System Simulator Options dialog box (as shown in the 
following example) or in the source blocks in the simulation (usually at the 
beginning of a simulated chain) and they are subsequently propagated along any 
constructed simulation chain. At any point in the system diagram you can use 
the System Tools FRQ_PROP measurement to check the propagated 
parameters.

Parameter Propagation
An important VSS feature for increasing ease of use is Parameter propagation, 
previously briefly introduced when discussing propagation of the sampling 
frequency and the center frequency by all VSS blocks to other blocks further 
downstream in the simulation chain. This procedure of parameter propagation 
is bidirectional, and also occurs from the end to the beginning of a simulation 
chain. In VSS, the forward and backward parameter propagation occurs for a 
variety of parameters, a small set of which are center frequency, sampling 
frequency, and oversampling (there are others too, such as signal and noise 
levels, and delay and phase distortion).

fs DataRate( ) Oversampling( )⋅ 500= =
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For example, you can place a QPSK transmitter inside a system diagram, 
configure it for the properties of the specific transmission scenario (data rate, 
pulse shaping, power, etc.), but then not repeat the corresponding settings in a 
receiver block. This is done automatically via parameter propagation by the 
simulator at the start-up phase of each simulation. Even more impressively, you 
can place an amplifier block and/or a filter somewhere in the simulation chain 
between the transmitter and receiver, and then not need to adjust the signal 
arriving at the receiver for delay and phase rotation introduced by the filter, or 
for gain introduced by the amplifier. All of these parameters are automatically 
propagated forward by the simulator, thus allowing the receiver block to adjust 
the received signal for them. As a result, even the first time, you can set up and 
run a relatively involved BER simulation of a transmitter/receiver chain in just a 
few minutes.

The details of parameter propagation for each individual block are explained in 
the block Help. For instance, an amplifier doesn�t alter the propagated value of 
the center frequency tag at its input, but does alter the propagated signal and 
noise levels, according to its gain (and possibly noise figure). A mixer block with 
a center frequency  arriving at its input node, and a center frequency  
arriving at its LO node propagates as a center frequency either the sum 

 (if it is in up-conversion mode) or the difference  (if it is 
in down-conversion mode). A filter block increases the propagated value of 
delay at its output by adding to the propagated delay at its input the amount of 
delay it introduces itself to the signal.

AM-MODULATION EXAMPLE

In this example a sinusoidal data signal with a frequency of 2 GHz is modulated 
onto a sinusoid carrier of 41 GHz.

AM modulation is described as:

where m(t) is the message data signal; a sinusoidal signal of frequency 2 GHz 
given by:

A represents the DC level of the message signal and B and C represent the 
amplitudes of the carrier and the message signal respectively.

fm c, fLO c,

fm c, fLO c,+ fm c, fLO c,�

XAM t( ) C A m t( )+[ ] ωccos⋅= t⋅

m t( ) B ω t⋅cos=
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The procedures in this example include:

� Creating a project
� Setting default system settings
� Creating a system diagram
� Placing blocks in the system diagram
� Specifying System Simulator options
� Adding graphs and measurements
� Running the simulation and analyzing the results

Creating a Project
The first step in building and simulating your designs is to create a project. You 
use a project to organize and manage related designs, and everything associated 
with them, in a tree-like directory structure.

The example you create in this chapter is available in its complete form as 
�AM.emp� in your Program Files\AWR\AWR2003\Examples\Getting 
Started\VSS\AM directory. You can use this example file as a reference.

To create a project:

1 Start VSS if not already started. To start VSS, click Start on your desktop, 
choose Programs > AWR Suite 2003 > AWR Design Environment, or 
double-click the corresponding shortcut on your desktop. For information 
on installing, setting up shortcuts and starting VSS, see �Installing MWO/
VSS� on page 2-1.
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2 Choose File > New Project.

3 Choose File > Save Project As. The Save As dialog box displays.

4 Navigate to the directory in which you want to save the project, type �AM� 
as the project name, and then click Save. The project name displays in the 
title bar.

Setting Default System Settings
Before creating a simulation you should set the default system settings.

To set default project units:

1 Choose Options > Project Options. The Project Options dialog box 
displays.

2 Click the Global Units tab and verify that your settings match those in the 
following figure. You can choose units by clicking the arrows to the right of 
the display boxes.
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3 Click OK to save your settings.

Creating a System Diagram
The system diagram is the canvas upon which you build end-to-end 
communications systems and graphically develop algorithms using VSS 
behavioral blocks. A VSS project can include multiple system diagrams, linear 
and nonlinear schematics, and netlists.

To create a system diagram:

1 Choose Project > Add System Diagram > New System Diagram. The 
Create New System Diagram dialog box displays.

2 Type �AM�, and click OK. A system diagram window displays in the 
workspace and the �AM� system diagram displays under System Diagrams 
in the Project Browser.
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Placing Blocks in a System Diagram
The Element Catalog is a database of behavioral system blocks that you can 
include in your system diagrams. 

To place a system block in a system diagram:

1 Click the Elem tab in the lower left of the window to display the Element 
Browser. The Element Browser replaces the Project Browser window.

2 If necessary, click the + symbol to the left of the System Blocks node to 
expand the system blocks tree.

3 Click the Sources category. A Real Source block (SRC_R) displays in the 
lower pane.

4 Select the SRC_R block and drag it onto the system diagram, release the 
button, and then click to position the element as shown in the following 
figure. This serves as the DC level of the message signal.

TIP: You can view the full name of a system block before dragging it to the system 
diagram by simply moving the mouse over the block or right-clicking on it and 
then selecting Show Details. 

5 Expand the Sources category, then click the Waveforms subgroup. Select 
the SIN_R block and place it as shown in the following figure.
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TIP: Before clicking to position a block, you can rotate the block by right-
clicking on it.

6 Expand the Math Tools category, then click the Adders subgroup. Select 
the ADD2 block and place it as shown in the following figure.

7 Expand the Modulation category, then click the Analog subgroup. Select 
the AM_MOD block and place it as shown in the following figure.

8 Select the SIN_R block in the system diagram. Choose Edit > Copy then 
Edit > Paste. Place the duplicated block as shown in the following figure.

TIP: Choose View > Zoom In to magnify the system diagram.

9 To save the file choose File > Save Project.

CONNECTING THE BLOCKS AND ADDING TEST POINTS

To connect the system blocks and add Test Points:

1 Place the cursor over the node of the SRC_R block. The cursor displays as 
a wire coil symbol.

2 Click and drag the displayed wire to input node 2 of the ADD_2 block, 
then click to place the wire.

3 Repeat steps 1 and 2 to complete the connections shown in the following 
figure.
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4 From the system block list click the Meters category. Individually select 
three Test Points (TP) and place them as shown in the following figure. You 
can also click the Add Test Point button on the toolbar. While placing the 
test points, right-click to rotate them as needed. The simulation results can 
be displayed at these test points.

TIP: You can also connect blocks by moving them to snap their nodes together. 
When they are properly connected a small green square displays and the 
connection wire extends if you move either block. If you do not see the green 
square, try to drag one of the block into place again.
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EDITING BLOCK PARAMETERS

To edit block parameters:

1 In the system diagram, double-click the SIN_R block connected to the 
ADD_2 block. The Element Option dialog box displays.

2 Click Show Secondary to display the secondary parameters. Edit the 
parameters to the values shown in the following figure, then click OK.

3 Double-click the SIN_R block connected to the AM_MOD block. If the 
secondary parameters are not visible, click Show Secondary. Change the 
AMPL parameter to �3�, the OFFFRQ parameter to �41� and the 
SMPSYM parameter to �10�, then click OK.

4 Double-click the SRC_R block and change the SMPSYM parameter to 
�10�, then click OK.

5 Double-click the AM_MOD block and change the MODIDX parameter to 
�2�, then click OK.

TIP: You can also simply double-click the parameter value displayed on the 
system diagram to modify a single parameter.

Specifying System Simulator Options
To specify system simulation sampling:

1 Choose Options > Default System Options. The System Simulator Options 
dialog box displays.
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2 Click the Simulator tab, and under Sampling Frequencies/Data Rates 
select Data rate in the first drop-down text box, and Oversampling in the 
second drop-down text box.

3 Type �1� GHz as the Data rate and �80� as the Oversampling value, then 
click OK. Note the options under Sampling Frequencies/Data Rates that 
define the system sampling rate. Data rate, symbol period, time step, 
sampling frequency and oversampling rate are all interrelated. You can use 
various pairs of these settings to specify the overall settings.

Creating a Graph to View Results
VSS allows you to see the results of your simulations in various graphical 
formats. Before you perform a simulation, you must create a graph and specify 
the data or measurements that you want to plot.

To create a graph:

1 Click the Proj tab in the lower left the window to display the Project 
Browser.

2 Right-click Graphs and choose Add Graph. You can also click the New 
Graph button on the toolbar. The Create Graph dialog box displays.
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3 Type �Amplitude Mod� in Graph Name, select Rectangular as the Graph 
Type, and click OK. The graph displays in a window in the workspace and 
displays as a subgroup of Graphs in the Project Browser.

Adding a Measurement
To add a measurement to the graph:

1 Right-click the �Amplitude Mod� graph in the Project Browser, and choose 
Add Measurement. The Add Measurement dialog box displays. You can 
also click the Add Measurement button on the toolbar.

2 For measurement type, select System under Meas. Type and select WVFM 
under Measurement. 
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3 Ensure that Test Point is TP.TP1, then click Apply. The 
AM:Re(WVFM(TP.TP1,10,1,1)) measurement displays under the 
�Amplitude Mod� graph in the Project Browser.

4 Select TP.TP2 in Test Point, then click Apply. 

5 Select TP.TP3 in Test Point, then click OK. 

TIP:   You can custom name a test point by double-clicking its ID number. 

Running the Simulation and Analyzing Results
To run the simulation:

1 Choose Simulate > Run/Stop System Simulators. Let the simulation run 
for 5 seconds, then choose Simulate > Run/Stop System Simulators again 
to stop the simulation. You can also click the Run/Stop System Simulators 
button on the toolbar. The simulation response in the following graph 
should display. 
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2 Choose File > Save Project to save the project. 

3 Choose File > Close Project to close the project. 
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VSS: END-TO-END SYSTEM 9
This chapter illustrates the signal and noise power relationship in an end-to-end 
communication link system. The goal of an end-to-end link analysis is to measure 
how often a transmitted bit is received in error (BER). Sometimes it is preferable to 
deal with symbols (a bit or group of bits encoded in a signal). In this example you 
evaluate the link error rate for a basic QAM transmission. You also analyze how 
often bits (BER) or symbols are received in error (SER), and the effect of signal-to-
noise (SNR) on BER and SER. 

The procedures in this example include:

� Creating a QAM project and system diagram
� Creating graphs and analyzing BER and SER
� Tuning the system parameters.

CREATING A QAM PROJECT

The example you create in this chapter is available in its complete form as 
�QAM.emp� in your Program Files\AWR\AWR2003\Examples\Getting 
Started\VSS\QAM directory. You can use this example file as a reference.

To create a project:

1 Choose File > New Project.

2 Choose File > Save Project As. The Save As dialog box displays.

3 Navigate to the directory in which you want to save the project, type 
�QAM� as the project name, and then click Save. 

4 Choose Options > Project Options. 

5 Click the Global Units tab and verify that your settings match those in the 
following figure.
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9

6 Click OK to save your settings.

Creating a QAM End-to-End System Diagram
To create a QAM end-to-end system diagram:

1 Choose Project > Add System Diagram > New System Diagram. The 
Create New System Diagram dialog box displays. 

2 Type �QAM� as the diagram name and click OK. 

3 Click the Elem tab in the lower left of the window to display the Element 
Browser. 

4 Expand the Sources category, then click the Random subgroup. Select the 
RND_D block and place it on the system diagram as shown in the 
following figure. 

5 Expand the Modulation category, then click the QAM subgroup. Select the 
QAM_TX block and place it on the system diagram as shown in the 
following figure. 

6 Click the Channels category, then select the AWGN block and place it on 
the system diagram as shown in the following figure. 

7 In the Modulation category, click the General Receivers subgroup. Select 
the RCVR block and place it on the system diagram as shown in the 
following figure.
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8 Click the Add Test Point button on the toolbar and add a Test Point (TP) 
between the QAM_TX and AWGN blocks. Add another Test Point (TP) at 
the output of the RCVR block as shown in the following figure. 

9 Connect the blocks and test points as shown in the following figure.
 

10 Double-click the RND_D block in the system diagram and verify that the 
M parameter is 2.

Because M = 2, RND_D is set by default to generate a digital signal that 
varies between �0� and �1�. Leave all other secondary parameters at their 
default settings.

11 Double-click the QAM_TX block and change the parameters as shown in 
the following figure.
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In this dialog box you can control several parameters as well as the pulse 
shaping filter used on the in-phase and quadrature-phase signals.

12 RCVR automatically adjusts its parameters to agree with the transmitter 
parameters, so maintain the default settings. 

13 Choose Options > Default System Options. The System Simulator Options 
dialog box displays. Verify that your settings match those in the following 
figure, then click OK.
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Adding Graphs and Measurements
To add graphs and specify the measurements you want to plot:

1 In the Project Browser, right-click Graphs and choose Add Graph, or click 
the New Graph button on the toolbar. Type �Complexbaseband� in Graph 
Name. For Graph Type, select Rectangular and click OK. 

2 Repeat step 1 to create a second graph named �Receiver Constellation�. 
For Graph Type select Constellation and click OK. 

3 To view all of the windows, choose Window > Tile Vertical. 

4 In the Project Browser, right-click �Complexbaseband� and choose Add 
Measurement. The Add Measurement dialog box displays.

5 Select System as the Meas. Type and select WVFM as the Measurement.

6 Select TP. TP1 as the Test Point, then click OK.

7 In the Project Browser, right-click �Receiver Constellation� and choose 
Add Measurement.

8 Create an IQ measurement using the settings in the following figure, then 
click OK. 
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Running the Simulation and Analyzing the Results
To run the simulation and configure the results display:

1 Choose Simulate > Run/Stop System Simulators. Let the simulation run 
for 3 seconds, then choose Simulate > Run/Stop System Simulators again 
to stop the simulation. The simulation responses in the following graphs 
should display.

The received constellation does not appear as expected because the power 
spectral density of the noise source is set to 0 dB. Note that the time 
waveform of the complex baseband signal does not show eight samples per 
symbol as specified in the System Simulator Options dialog box.

2 Select the Complexbaseband graph window and click the Properties button 
on the toolbar. The Rectangular Plot Properties dialog box displays.

3 Click the Traces tab. 

4 Using the drop-down symbol and line selectors, specify a triangle as the 
symbol and a solid line as the line style, as shown in the following figure. 
(The lines will display on the Complexbaseband waveform).
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5 Under Symbol, clear the Auto interval check box, change the Interval value 
to 1 and click OK.

6 On the system diagram, double-click the AWGN block and change the 
PWR parameter to �-30� dB, then click OK.

7 Start the simulation, let it run for about 10 seconds, and then stop the 
simulation. 

Notice how the scatter plot changes. The simulation responses in the 
following graphs should display. On the Complexbaseband graph the 
triangular symbols display on the waveform. There are now eight samples 
per symbol. You can choose Options > Default System Options to return 
to the System Simulator Options dialog box and change the values under 
Sampling Frequencies/Data Rates to observe the different results.

Auto Interval

Interval

Line selector

Symbol selector 
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Note that your graphs may not look identical to these examples due to printed 
size limitations.

TIP: Click the Properties button on the toolbar to edit the appearance of any graph, 
or right-click in the graph to zoom in and zoom out.

8 Choose File > Save Project to save your project.

TUNING SYSTEM PARAMETERS

Visual System Simulator (VSS) architecture uses object-oriented techniques to 
enable fast and efficient simulations. A real-time tuner allows you to see the 
results of simulations as you tune parameters. 

To tune a system parameter:

1 Click the system diagram window to make it active.

2 Click the Tune Tool button on the toolbar. 

3 Position the cursor over the PWR parameter value of the AWGN block. 
The cursor displays as a small cross on a black background. 

4 Click to activate the PWR parameter for tuning. The parameter value 
displays in blue. To disengage the Tune Tool, click anywhere in the design 
area.
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5 To start the simulation, click the Run/Stop System Simulators button on 
the toolbar, then click the Tune button on the toolbar. 

The Variable Tuner dialog box displays.

6 To observe the impact of the noise level, set the Max and Min values to �0� 
and �-50� respectively. Click the tuning bar and slide it to adjust the values 
while observing the results on the constellation graph.

7 Click the �x� at the upper right of the Variable Tuner dialog box to close it.

8 Stop the simulation by clicking the Run/Stop System Simulators button on 
the toolbar.

9 To de-tune the PWR parameter of the AWGN block, click the Tune Tool 
button on the toolbar and then click the PWR parameter value again. The 
parameter value displays in black. To disengage the Tune Tool, click 
anywhere in the design area.

10 Double-click the PWR parameter and change the value to 0.

CREATING A BER AND SER SIMULATION

System engineers often want to perform Bit Error Rate (BER) simulation. For 
some modulation schemes, it is easier to analytically calculate Symbol Error Rate 
(SER) than BER. This example shows how to generate both BER and SER. To 
generate a BER curve, a method of varying the signal-to-noise-ratio (SNR) must 
be available. For this purpose, a stepped variable �Eb_No� is established to 
sweep out a range of values from -6 to 6, in increments of 1. The stepped 
variable is used as the value for the transmitter output power parameter, thus

Max value

Min value 
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raising the signal level as the variable is stepped. In this case, the AWGN power 
parameter is set to 0 db and the simulation is set up to increase the transmitter 
power.

To create a BER simulation:

1 Click the system diagram window to make it active.

2 Choose Draw > Add Equation and move the cursor into the system diagram 
window. An edit box displays.

3 Position the edit box at the top of the system diagram and click to place it.

4 Type �Eb_NO = sweep (stepped(-6, 6, 1))� (without the quotes) in the edit 
box, and then click outside of the box. 

5 Double-click the QAM_TX block and verify that the OUTLVL parameter 
is Eb_NO, and the OLVLTYP parameter is Bit Energy (dB), then click OK.

6 In the Element Browser under System Blocks, expand the Meters category 
and click the BER subgroup. Select the BER block (internal reference 
source) and place it to the right of the RCVR block in the system diagram.

7 Connect the BER block to the �D� node of the RCVR block.

8 Double-click the BER block. Click Show Secondary to view the secondary 
parameters. Edit the parameters to the values shown in the following figure, 
then click OK.
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The BER block is now set to test 1e7 (MXTRL * TBLKSZ) bits. It registers 25 
errors before a BER computation is generated for each value of Eb_NO. The 
BER block internally generates the original data source and compares the 
received bits to the transmitted bits. The last point on the BER curve (the 8th 
value of Eb_NO) takes the longest to plot.

9 To add a BER plot to the project, add a rectangular graph named �BER�.

10 In the Project Browser, right-click �BER� and choose Add Measurement.

11 Create a BER measurement using the settings in the following figure, then 
click Apply to save the measurement.

12 To verify the obtained results with the theoretical results, add another 
measurement to the BER graph using the settings in the following figure, 
then click OK.
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13 Verify that the PWR parameter value of the AWGN block is 0dB.

14 Select the BER graph window, then click the Properties button on the 
toolbar.

15 Click the Axes tab and set Left1 to Log scale by selecting Left1 under 
Choose Axis and selecting the Log Scale check box, then click OK.

16 Click the Run/Stop System Simulators button on the toolbar to start the 
simulation. As the simulation runs, the BER curve is generated. Note that 
the size of the received constellation becomes clearer as the power is 
increased or, as Eb_NO is swept from -6 dB to 6 dB.
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The simulation stops when 25 errors are counted at Eb_NO = 6dB. The 
simulation response in the following graph should display.

In this example the signal power was swept to plot the BER. You can sweep 
the noise power, keeping the signal power constant. Change the PWR 
parameter of the AWGN block to -Eb_NO and the OUTLVL parameter of 
the QAM_TX block to 0 to get the same BER curve achieved here.

17 Choose File > Save Project.

18 Similar to the BER version, you can create a SER vs Eb/N0 graph. In the 
Project Browser, click �QAM� under System Diagrams. Drag and drop the 
QAM icon onto the System Diagrams node. A �Copy of QAM� system 
diagram is created under System Diagrams. 

19 Click the �Copy of QAM� window to make it active, then delete the BER 
block. 

20 In the Element Browser, expand the Meters category, then click the BER 
subgroup. Select the SER block, drag it to the �Copy of QAM� system 
diagram, and connect it to the �D� node of the RCVR block.

21 Add a rectangular graph named �SER� to the project.

22 Add a measurement to the �SER� graph using the settings in the following 
figure. 
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23 Add another measurement to the �SER� graph using the settings in the 
following figure.

24 Select the �SER� graph window, then click the Properties button on the 
toolbar.

25 Click the Axes tab and set Left1 to Log scale by selecting Left1 under 
Choose Axis and selecting the Log Scale check box, then click OK.
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26 Click the Run/Stop System Simulators button on the toolbar to start the 
simulation. As the simulation runs, the SER curve is generated. The 
simulation response in the following graph should display.

You can also plot BER and SER against Es/N0 by specifying Es/N0 as the 
SWPTYP parameter in BER and SER blocks.

Converting BER Curve Results to a Table
 To convert the results of the BER curve to a table:

1 In the Project Browser select the �BER� graph, right-click and choose 
Duplicate as > Table. A new table (graph) named �Copy of BER� displays 
under Graphs.
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2 To change the numerical precision of the table, select the �Copy of BER�, 
graph window and click the Properties button on the toolbar. Make any 
desired changes in the Tabular Graph Format dialog box, then click OK. 

3 Choose File > Save Project.
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The circuit simulation capabilities of Microwave Office (MWO) and Visual 
System Simulator (VSS) provide a unique environment in which to measure the 
impact of RF components on system performance. Measurements you can 
make include, for example, the impact of phase noise on BER, spectral 
regrowth due to the non-linearities of an amplifier, and the impact of filter 
characteristics on BER.

This exercise presents features of the VSS environment and demonstrates its 
integration with the MWO circuit simulation environment. You add an actual 
MWO filter circuit to the QAM system that you built in the previous example, 
and then you measure the impact of the filter on BER performance as you 
change filter parameters. 

The procedures in this example include:

� Importing an MWO ideal filter circuit to the system project

� Approximating the filter response before including it in the simulation

� Changing filter parameters and monitoring the impact on BER 
performance

� Creating a power spectral density plot.

ADDING AN MWO FILTER CIRCUIT TO THE SYSTEM

In this example you import an MWO ideal filter schematic into your existing 
QAM project. Although there are also ideal filter blocks available in VSS, the 
purpose of this exercise is to demonstrate how you can implement an MWO 
structure in VSS. The complete example is available as �QAM+Filter.emp� in 
your Program Files\AWR\AWR2003\Examples\Getting Started\VSS\QAM 
directory. You can use this example file as a reference.

1 Open your QAM project if it is not already open. (Choose File > Open 
Project and select the directory in which you saved �QAM.emp�). If you 
did not build this project, you can get the project file from the Program 
Files\AWR\AWR2003\Examples\GettingStarted\VSS\QAM directory.
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2 In the Project Browser, right-click Circuit Schematics and choose Import 
Schematic. Select the �Ideal filter.sch� schematic from the Program 
Files\AWR\AWR2003\Examples\Getting Started\VSS\QAM directory. 
The following filter schematic displays.

Testing the Filter
You should verify the filter response before including the filter in the system 
simulation. You will use a separate system diagram to connect the MWO filter 
to a VNA_SS block and plot the frequency magnitude and phase response on a 
graph to check the frequency response of the filter before including it in a 
simulation chain.

To verify the filter response:

1 Choose Options > Project Options and click the Frequencies tab to set the 
project frequency.

2 Specify the Start, Stop and Step values shown in the following figure, click 
Apply to display the values in Current Range, and then click OK.
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3 Right-click System Diagrams and choose New System Diagram to add a 
diagram named �Filter Test�.

4 Click the �Filter Test� window in the workspace to make it active.

5 In the Element Browser, expand the Filters category, then click the 
Bandpass subgroup. Select the BPFB block and place it on the system 
diagram as shown in the following figure.

6 Expand the RF Blocks category, then click the Simulation Based subgroup. 
Select the LIN_S block and place it on the system diagram as shown in the 
following figure.

7 Expand the Meters category, then click the Network Analyzers subgroup. 
Select the VNA_SS block, place it on the system diagram, and connect it 
across the BPFB block as shown in the following figure.

8 Repeat step 7 to connect a VNA_SS block across the LIN_S block as 
shown in the following figure.
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9 In the BPFB block, set the N parameter to �10�, the FP1 parameter to �4� 
GHz, and the FP2 parameter to �6� GHz.

10 In both of the VNA_SS blocks set the FSTART parameter to �1� and the 
FSTOP parameter to �10� GHz.

11 In the LIN_S block set the parameters as shown in the following figure.

12 Create a rectangular graph named �Ideal Filter Response� and add a 
measurement to the graph using the settings in the following figure, then 
click Apply.

BPFB
ID=F1
N=10
FP1=4 GHz
FP2=6 GHz
AP=3.0103 dB

LIN_S
ID=S1
NET="Ideal filter"

SRC MEAS

VNA_SS
ID=M1
FSTART=1 GHz
FSTOP=10 GHz

SRC MEAS

VNA_SS
ID=M2
FSTART=1 GHz
FSTOP=10 GHz
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13 Add another measurement to the same graph using the settings in the 
following figure, then click OK.

14 Run both the Harmonic Balance simulator and System simulator. The 
simulation response in the following graph should display.
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15 Zoom into the area shown in the previous figure.

16 In the �Filter Test� diagram, change the LIN_S block NTAP parameter to 
�1024� and run the simulation. Notice the change in the graph. The 
response from LIN_S follows the actual graph of the given filter.

17 Create another rectangular graph named �Filter Response 1� and add a 
measurement to the graph using the settings in the following figure, then 
click Apply.
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18 Add another measurement to the same graph except select Angle as the 
Complex Modifier and deselect DB as Result type, then click OK. 

19 Run the System Simulator. The simulation response in the following graph 
should display after making some axes changes: Double-click the legend in 
the graph. In the Rectangular Plot Properties dialog box, click the 
Measurements tab. Under Select measurement to edit select Filter 
Test:(Ang(S21_SS(VNA_SS.M1))) and under Choose axis select Right 1. 
Click Apply, then OK.

Simulating the QAM System
To simulate the QAM system:

1 On the �QAM� system diagram, double-click the QAM_TX block 
CTRFRQ parameter and set the value to �5� GHz.

2 In the Element Browser, expand the RF Blocks category, then click the 
Simulation Based subgroup. Select the LIN_S block and place it on the 
system diagram between the AWGN and RCVR blocks. Connect the 
blocks, moving them as necessary. 

3 Change the LIN_S block NET parameter to �Ideal Filter� (including 
quotes) as shown in the following figure, then click OK.
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4 Add a test point at the output of the LIN_S block as shown in the following 
figure.

Adding a Graph and Analyzing the Results
You now add a graph and two measurements to create an overlay to view the 
power spectral density for the QAM system before and after the addition of the 
bandpass filter. 

To add a graph and measurements:

1 Add a rectangular graph named �Power Spectrum�.

2 Add a PWR_SPEC measurement using the settings in the following figure, 
then click Apply. 
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Specifying �TP.TP3� for Test Point places the measurement after the 
LIN_S block.

3 Add another PWR_SPEC measurement with the same settings, but choose 
TP.TP1 (the test point prior to the AWGN block) for Test Point, then click 
OK.

4 Run the simulation. Note that the BER performance has degraded. The 
simulation response in the following graph should display.
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5 Save the project as �QAM+Filter�.

Experimenting with Filters
Try varying the filter parameters using the Variable Tuner to observe the impact 
on the system BER performance. Remember to restore the filter parameters to 
their current values for the next exercise, however.

Note that as you change the filter parameters, you can improve or severely 
degrade the system�s BER performance. You may also want to experiment with 
other filters. In the next example you will discover that the primary reason for 
the degradation in BER performance is the impact of the filter�s phase response.

You can verify this by creating a graph that is an overlay of the PWR_SPEC of 
the filter output with that of a MWO linear measurement named �Accumulation 
of Linear Deviation�.
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This chapter demonstrates how to use the Microwave Office (MWO) Harmonic 
Balance nonlinear simulator with a Visual System Simulator (VSS) simulation. In 
this example you simulate an amplifier model and then measure the impact of 
the amplifier on the overall system. You observe the resulting power spectrum, 
the constellation graph, eye diagram, and the group delay. You also overlay a 
gain plot of the filter response with power spectral density of the transmitted 
signal, and analyze the simulation results.

 The procedures in this example include:

� Importing an MWO amplifier model into a system project

� Compensating for phase shift

� Working with the VSS Vector Signal Analyzer block

� Creating plots for eye diagrams, filter response, and group delay

IMPORTING AN AMPLIFIER MODEL INTO VSS

In this example you add an amplifier model to the QAM system built in the 
previous chapter. The complete example is available as 
�QAM+Filter+Amp.emp� in your Program Files\AWR\AWR2003\
Examples\Getting Started\VSS\QAM directory. You can use this example file 
as a reference.

To import an amplifier:

1 Open the �QAM+ Filter.emp� project you saved in the previous chapter if 
not already open. If you did not build this project, you can get the project 
file from the Program Files\AWR\AWR2003\Examples\GettingStarted\
VSS\QAM directory.

2 In the Project Browser, right-click Circuit Schematics and choose Import 
Schematic. Select the �amplifier.sch� schematic from the Program 
Files\AWR\AWR2003\Examples\Getting Started\VSS\QAM directory.
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The following amplifier schematic displays in the project.

3 Verify that the NL_AMP parameters are set to the following values, then 
click OK. 

4 In the QAM system diagram, separate the QAM_TX block and the TP1 
test point and disconnect the wire between them.

NL_AMP
ID=AM1
GAIN=3 dB
NF=0 dB
IP2H=55 dBm
IP3=55 dBm
P1DB=40 dBm

PORT_PS1
P=1
Z=50 Ohm
PStart=0 dBm
PStop=50 dBm
PStep=1 dB

PORT
P=2
Z=50 Ohm
11-2 MWO/VSS 2003



V S S :  U S I N G  A N  M WO  N O N L I N E A R  E L E M E N T  I N  V S S
Importing an Amplifier Model into VSS
5 In the Element Browser under System Blocks, expand the RF Blocks 
category, then click the Simulation Based subgroup. Select the NL_S block 
and place it between the QAM_TX and AWGN blocks as shown in the 
following figure. 

6 Connect the NL_S block to the QAM_TX and AWGN blocks.

7 Double-click the NL_S block and set its NET parameter to �amplifier� to 
reference the amplifier schematic (include the quotes), then click OK.
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Compensating for Phase Shift
The amplifier introduces a 180-degree phase shift on the data. To compensate 
for this shift, you place the PHASE block just after the NL_S block. 

To compensate for phase shift:

1 Click the Signal Processing category, then select the PHASE block and 
place it as shown in the following figure.

2 Set the PHASE block SHFT parameter to �180� Deg.

3 Save the project as �QAM+Filter+Amp�.

4 Start and then stop the system simulation. Note on the BER graph that the 
BER has improved relative to the simulation you performed with only the 
bandpass filter in the previous exercise.

5 To verify the improvement, you can disable and bypass the amplifier and 
phase shift. To disable the NL_S and PHASE blocks, select each block, 
right-click and choose Toggle Enable. The disabled blocks turn gray. 

6 Connect the QAM_TX and AWGN blocks as shown in the following 
figure.
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7 Run the simulation and note the BER values.

8 Disconnect the wire between the QAM_TX and AWGN blocks by 
selecting the wire and pressing Delete. 

9 Enable the NL_S and PHASE blocks by selecting each block and then 
right-clicking and choosing Toggle Enable. 

10 Start the simulation.

Using the Vector Signal Analyzer Block
Next you use the Vector Signal Analyzer block to plot the instantaneous output 
power of the QAM transmitter relative to the AM/AM characteristics of the 
amplifier.

To use the VSA block to plot output power:

1 Expand the Meters category, then click the Network Analyzers subgroup. 
Select the VSA block and place it above the NL_S block in the QAM 
system diagram.

2 Connect the two ports of the VSA block to either side of the NL_S block as 
shown in the following figure.

3 Save the project.

4 Add a rectangular graph named �AMtoAM.�

5 Add a measurement to the graph using the following settings, then click 
Apply.
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6 Add another measurement to the graph using the following settings, then 
click OK.
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7 In the Project Browser, right-click the �amplifier� schematic and choose 
Options to display the Options dialog box.

8 Click the Frequencies tab and set the options as shown in the following 
figure, then click OK.

9 Start the harmonic balance simulation by clicking the Analyze button on 
the toolbar. This updates the AMtoAM graph with harmonic balance 
results.

10 For best graph appearance, select the AMtoAM graph window, click the 
Properties button on the toolbar, click the Traces tab, and change the 
symbol from a triangle to none.

11 Start the system simulation by clicking the Run/Stop System Simulators 
button on the toolbar. As the simulation runs, a marker moves along the 
plot that resulted from the harmonic balance simulation. The marker moves 
because you are sweeping the Eb_NO variable. The marker indicates the 
operating point of the system relative to the 1dB compression point of the 
amplifier. As you decrease the value of the 1dB compression point, the 
operating point of this system moves into the nonlinear region of the 
amplifier. 

The simulation response in the following graph should display.

 Deselect this

   Set to 5GHz Select Single point
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Importing an Amplifier Model into VSS
1 1
For information on the LIN_S, NL_S and VSA blocks, see the Visual System 
Simulator System Block Catalog. 

Note that these examples use ideal behavioral models for the filter and 
amplifier. You can also use actual circuit models for the filter and amplifier.

Analyzing Filter Response and Group Delay
You need at least two sweep points to make a group delay measurement. The 
�Ideal Filter� schematic is using the sweep frequency specified in the project 
options, but if you want the group delay to simulate in a frequency range other 
than the project frequency you can do so by right-clicking the �Ideal filter� 
schematic under Circuit Schematics and then choosing Options > Frequencies. 
In the Options dialog box, clear the Use project defaults check box and specify 
the frequency range. Click Apply, and then OK.

To analyze the filter response and group delay:

1 Add a group delay measurement to the �Ideal Filter Response� graph using 
the following settings, then click OK.
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Importing an Amplifier Model into VSS
2 Select the �Ideal Filter Response� graph window and click the Properties 
button on the toolbar.

3 Click the Measurements tab and under Select Measurement to edit, select 
Ideal Filter: GD(2,1), then under Choose axis, select Right 1 and then click 
OK.

4 Click the Analyze and Run/Stop System Simulators buttons on the toolbar. 
The simulation response in the following graph should display.
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Creating Eye Diagrams
The benefits of eye diagrams is increasingly recognized in most communications 
system standards. In digital communications, the eye diagram is used to visualize 
how the waveforms used for sending multiple bits of data can potentially lead to 
errors in the interpretation of those bits. This problem ia known as intersymbol 
interference (ISI), and certain pulse shapes are used specifically to alleviate the 
problem. One simple example of this is the "raised cosine" pulse shape. Here 
you display the eye diagram for the root raised cosine pulse shape at the 
transmitter output and at the amplifier output, and compare them.

To compare the eye diagram for the root raised cosine pulse shape at the 
transmitter and amplifier outputs:

1 In the QAM system diagram, add a fourth test point between the 
QAM_TX and NL_S blocks.

2 Change the QAM_TX block PLSTYP parameter to �Raised Cosine�.

3 Add a rectangular graph named �Eye Diagram at Transmitter�.

4 Add a measurement to the graph using the following settings, then click 
OK.
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Importing an Amplifier Model into VSS
5 Add another rectangular graph named �Eye Diagram at Amp Output�.

6 Add a measurement to the graph using the following settings, then click 
OK.

7 Run the simulation for 5 seconds and stop. 

8 Set the graph properties to display the X-axis from 0 to 8 ns. 
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The simulation response in the following graphs should display.

9 Choose File > Save Project.

10 Choose File > Close Project.

0 2 4 6 8
Time (ns)

Eye Diagram at Amp Output

-30

-20

-10

0

10

20

30
Re(EYE(TP.TP4,10,1,80,0))
QAM

0 2 4 6 8
Time (ns)

Eye Diagram at Transmitter

-40

-20

0

20

40
Re(EYE(TP.TP1,10,1,80,0))
QAM
11-12 MWO/VSS 2003



. . . . .

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
VSS: VSS EXAMPLES 12
This chapter includes additional useful examples such as FSK, Phase Noise and 
I/Q Imbalance, End-to-End QAM system, and mixer modeling. It also includes 
steps for displaying measurements such as IRR, ACPR, EVM, and others.

FSK EXAMPLE

In this example you build and simulate a complete transmitter-channel-receiver 
chain for a Binary Frequency Shift Keying (BFSK) transmission. The example 
shows how to generate a frequency shift keying (FSK) source using elementary 
blocks or a �black box� FSK modulator (called FSK_SRC) in VSS. It is not 
always necessary to construct a receiver and transmitter using elementary 
blocks. For many common modulation methods, corresponding black boxes 
already exist in VSS. This exercise, however, is intended to show that using the 
black box or creating one using the elementary blocks produces identical results. 
You will also construct an FSK demodulator using basic blocks, and verify the 
performance of the system by setting different parameters. For more 
information and application notes on FSK modulation please visit our website 
at http://www.mwoffice.com/.

The procedures in this example include:

� Verifying the BFSK waveform generated using different methods
� Channel and noise scaling and system performance
� Monitoring the BER and sweep statistics in a text window. 

Using a �Black Box� FSK Modulator
In this section you create a project and BFSK system diagram, then use the FSK 
modulator (FSK_SRC) and plot the power spectrum of the modulated signal. 
The complete example is available as �bfsk.emp� in your Program 
Files\AWR\AWR2003\Examples\Getting Started\VSS\BFSK directory.

To generate an FSK source using a �black box� FSK modulator:

1 Create a project named �bfsk�.
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2 Add a system diagram named �BFSK� to the project.

3 In the Project Options dialog box, set the frequency Start to �1� GHz, the 
Stop to �2� GHz, and specify Step as �1� GHz.

4 In the Element Browser System Blocks list, expand the Modulation 
category, then click the FSK subgroup. Select the FSK_SRC block and 
place it on the system diagram. Verify that its parameters are set to the 
following values, then click OK.

5 Add and connect a test point as shown in the following figure.
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6 Add a rectangular graph named �Spectrum�.

7 Add a measurement to the graph using the settings in the following figure, 
then click OK.

8 Run the simulation. The power spectrum of the FSK signal generated by 
the block displays as shown in the following graph.
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Creating An FSK Modulator Using Elementary Blocks
In this section you create a BFSK modulator using elementary blocks, then 
compare the results with those of the previous method. These two distinct 
transmitters are behaviorally identical. 

1 In the Element Browser, expand the Sources category, then click the 
Random subgroup. Select the RND_D block and place it on the system 
diagram as shown in the following figure. 

2 Double-click the RND_D block and set the RATE parameter to �1000� 
and the RSEED parameter to �{0}� (with the brackets).

3 Expand the Converters category, then click the Analog-Digital subgroup. 
Select the DAC block and place it on the system diagram as shown in the 
following figure.

4 Expand the Modulation category, then click the Analog subgroup. Select 
the FM_MOD block and place it on the system diagram as shown in the 
following figure. 

5 Set the FM_MOD block KF parameter to �0.707/2*1000�.

6 Expand the Sources category, then click the Waveforms subgroup. Select 
the SIN_C block and place it on the system as shown in the following 
figure.

7 Set the SIN_C block AMPL parameter to �5�. 

8 Add a second test point to the system as shown in the following figure.
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9 Add a power spectrum (PWR_SPEC) measurement at test point TP2 to the 
�Spectrum� graph.

10 Run the simulation. Note that there is no change in the graph since the 
waveform from the cascade of these blocks is identical to the waveform of 
the FSK_SRC block, hence the overlap. 

TIP: To view the spectrum of each setup separately, you can display them in 
separate graphs or toggle the measurements one at a time under Graphs in 
the Project Browser (right-click and choose Toggle Enable). You can also 
simply toggle the test points one at a time by double-clicking the test point 
and clearing the Enable element check box in the Element Options dialog 
box. These steps confirm that the two methods for setting up the 
transmitter create identical BFSK waveforms.

11 Add a third test point between the RND_D block and the DAC block. 

To observe the behavior of the transmitted phase: 

12 Add a rectangular graph named �TX Waveforms�.

D A

D A C
ID = A 2

1

2

3

F M_ M O D
I D = A 3
K F = 0. 70 7 /2* 10 00

S IN _ C
I D = A 4
A M PL = 5
P H SO F F = 0 D eg
O F F F R Q = 0  G H z
C T R F R Q = 1 G H z

RN D _ D
ID = A1
M= 2
RA T E =1 0 00

T P
I D =T P 2

F S K _ S R C
I D =A 8
M O D= 2 - F S K
O U T LV L= 0  d B
O LV LT Y P= B it E ne r gy  (d B )
R A T E = 1 00 0
C T R F R Q = 1 G H z
M O DI D X = 0 .7 07
P LS T Y P = R ec t an g ula r
A LP H A= 0 .3 5
L =  
P LS LN =  

T P
ID = T P 1
G e t t i n g  S t a r t e d  G u i d e  12-5



V S S :  V S S  E X A M P L E S1 2
13 Add a random data waveform measurement to the graph using the settings 
in the following figure, then click Apply.

14 Add a measurement to the graph for the phase produced by the FSK 
modulator using the settings in step 13, but select TP.TP2 as the Test Point 
and Angle as the Complex Modifier, then click OK.

15 Select the �TX Waveforms� graph and click the Properties button on the 
toolbar.

16 Click the Axes tab and select Left 1. Clear the Auto limits check box and 
enter �-1� as the Min and �2� as the Max. Under Divisions, clear the Auto 
divs. check box and enter �1� as the Step.

17 Select Right 1. Clear the Auto limits check box and enter �-200� as the Min 
and �200� as the Max, then click Apply.

18 Click the Measurements tab and under Select Measurement to edit, select 
BFSK:Ang(WVFM(TP.TP2,20,4,1)], then under Choose axis, select Right 1 
and click Apply.

19 Click the Traces tab and under Style, select measurement 1, then under 
Weight select a heavier line from the corresponding drop-down box at the 
bottom of the dialog box. Select measurement 2, then select a square as the 
Symbol style from the corresponding drop-down box at the bottom of the 
dialog box.
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20 Run the simulation. Observe that the transmitted phase behaves exactly as 
expected in a binary FSK transmission scheme with rectangular frequency 
shaping pulse. 

Your simulation response should look similar to the following graph, which 
shows that the phase of the modulated waveform increases in a ramp when 
the input bit is �1�, and decreases in a ramp with the same slope when the 
input bit is �0�. The phase remains continuous between different bit 
intervals, and the phase jumps in the plot are only the effect of the wrap-
around when the phase exceeds . The data waveform (binary 1�s and 0�s) 
is plotted on the left axis while the phase waveform is shown on the right 
axis.

Receiver and Demodulation
In this section you complete the channel-receiver chain for BFSK. The receiver 
is built from elementary VSS blocks for demonstration purposes and is shown 
to outperform even the coherent BFSK demodulator. The modulated signal out 
of the transmitter is passed through an AWGN channel and then demodulated 
by a discriminator receiver, consisting of a filter (PLSSHP), an FM discriminator 
(FM_DSCRM), an integrate-and-dump block (INTG_DMP), and an ADC 
block. In this exercise you also scale the channel and noise parameters and 
analyze the system performance. 
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To complete the channel-receiver chain for BFSK (using the following figure as 
a reference):

1 In the Element Browser, click the Channels category. Select the AWGN 
block and place it on the system diagram.

2 Click the Filters category, then select the PLSSHP block and place it on the 
system diagram.

3 Expand the Modulation category, then click the Analog subgroup. Select 
the FM_DSCRM block and place it on the system diagram.

4 Click the Signal Processing category, then select the INTG_DMP block 
and place it on the system diagram.

5 Expand the Converters category, then click the Analog-Digital subgroup. 
Select the ADC block and place it on the system diagram.

6 Add a 4th, 5th and 6th test point at the outputs of the FM_DSCRM, 
INTG_DMP and ADC blocks respectively.

7 Click the Signal Processing category, then select the DLY_SMP block and 
place it on the system diagram.

8 Expand the Meters category, then click the BER subgroup. Select the 
BER_EXT block and place it on the system diagram.
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9 Add the following equation to the system diagram.
Eb_No = sweep (stepped(1, 9, 1))

10 Set the AWGN block PWR parameter to �-Eb_No� and its PWRTYP 
parameter to �Normalized N0/2�.

11 Set the PLSSHP block PLSTYP parameter to �Gaussian (BT)� and its 
ALPHA parameter to �0.5�.

12 Set the FM_DSCRM block GAIN parameter to �2/0.707�.

13 Set the INTG_DMP block N parameter to �8�.

14 Set the ADC block M parameter to �2�.

15 Set the DLY_SMP block DLY parameter to �15�. 

16 Verify that the BER_EXT block parameters match those in the following 
figure.

D A

DAC
ID=A2

1

2

3

FM_MOD
ID=A3
KF=0.707/2*1000

SIN_C
ID=A4
AMPL=5
PHSOFF=0 Deg
OFFFRQ=0 GHz
CTRFRQ=1 GHz

AWGN
ID=A5
PWR=0 dB
PWRTYP=Auto
LOSS=0 dB

PLSSHP
ID=F1
PLSTYP=Root Raised Cosine
ALPHA=0.35
PLSLN= 
NRMTYP=Unit Pulse Power

FM_DSCRM
ID=A6
GAIN=1

dt

INTG_DMP
ID=A7
N=8
INTGTYP=Sum*Time Step

RND_D
ID=A1
M=2
RATE=1000

A D

ADC
ID=A9
M=2

BER

BER_EXT
ID=BER1
SWPVAR= 
SWPTYP=Auto
OUTFL=""

TP
ID=TP2

FSK_SRC
ID=A8
MOD=2-FSK
OUTLVL=0 dB
OLVLTYP=Bit Energy (dB)
RATE=1000
CTRFRQ=1 GHz
MODIDX=0.707
PLSTYP=Rectangular
ALPHA=0.35
L= 
PLSLN= 

TP
ID=TP1

TP
ID=TP3

DLY_SMP
ID=A10
DLY=1
IVAL=0

TP
ID=TP4

TP
ID=TP5

TP
ID=TP6
G e t t i n g  S t a r t e d  G u i d e  12-9



V S S :  V S S  E X A M P L E S1 2
Adding Graphs and Analyzing Results
To add and analyze an RX waveform graph:

1 Add a rectangular graph named �RX Waveforms�.

2 Add a measurement to this graph using the following settings, then click 
Apply.
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3 Repeat step 2 but select TP.TP5 as Test Point.

4 Repeat step 2 but select TP.TP6 as Test Point, then click OK.

Run the System Simulator for a few seconds and then stop. A snapshot of 
the simulator response is shown in the following graph. Your graph should 
look very similar after making the appropriate trace and axis property 
changes in the Graph Properties dialog box.

5 Analyze the graph. The bold waveform is the output of the FM 
discriminator in low noise. The sample output of the integrate-and-dump 
block at every 1 msec or 1e6 nsec (sample at the symbol rate of 1000 
samples/sec) is displayed with a triangular mark. As expected, this curve is 
positive when the FM discriminator output is increasing, and negative 
otherwise. Also observe the output of the ADC block, which slices the 
output of the integrate-and-dump block for digital output data. The scale 
for integrate-and-dump output and ADC output is on the left y-axis, and 
that of the FM discriminator is on the right y-axis. 

6 Add another rectangular graph named �BER�.

7 Add a measurement to this graph using the settings in the following figure, 
then click Apply.
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8 Add another measurement to this graph to represent the performance of a 
non-coherent receiver, using the settings in the following figure, then click 
Apply.

9 Repeat step 9 but select �Coherent� as Demodulation Type. This represents 
the performance of a coherent linear (correlation) receiver.
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10 Repeat step 9 but select �Discriminator� as Demodulation Type, then click 
OK. This represents the performance of the nonlinear discrimination 
receiver, under an ideal assumption.

11 Set the BER_EXT block TXTOUT parameter to �Trial statistics�.

12 Run the simulation. A text window displays with the statistics of BER 
simulation. 

13 Select the BER graph window, then click the Properties button on the 
toolbar. Click the Traces and Axes tabs and make the appropriate changes 
to your graph so it looks similar to the following graph.

14 Set the SIN_C block AMPL parameter to �5*10^(Eb_No/20)�.

15 Set the AWGN block PWR parameter to �0� db.

16 Run the simulation again. Note that these changes have no effect on the 
BER simulation; the results are identical. If you use the FSK_SRC block in 
the system (instead of elementary blocks), you can achieve the identical 
BER simulation by setting its OUTLVL parameter to �0� db and the 
AWGN block PWR parameter to �-Eb_No�, or by setting OUTLVL to 
�Eb_No� and PWR to �0� db.

17 Save and close the project.
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PHASE NOISE AND I/Q IMBALANCE EXAMPLE

In this section you observe the effects of oscillator phase noise on different 
modulation schemes. Phase noise causes erroneous separation of the I (in-
phase) and Q (quadrature-phase) RF signal, resulting in I/Q plot errors 
proportional to the amplitude of the signal and dependent on the phasing of the 
RF signal. In this exercise you model the phase noise by adding colored noise to 
the phase of a complex sinusoidal signal. You also observe the effect of 
amplitude and/or phase mismatch (I/Q imbalance) of a complex signal. For 
more information, see the PhaseNoise/IQ Imbalance application notes 
available in the KnowledgeBase on AWR�s website at www.mwoffice.com.

The procedures in this example include:

� Modeling the phase noise
� Analyzing the effect of phase noise in a QAM signal
� Analyzing the effect of I/Q imbalance in a QAM signal.

Modeling the Phase Noise
In this section you first use elementary blocks to model the phase noise. The 
complete example is available as �Phase_noise.emp� in your Program Files\
AWR\AWR2003\Examples\Getting Started\VSS\PHNoise directory.

To create the schematic:

1 Create a project named �Phase_noise�.

2 Add a system diagram named �Phase Noise Generator� to the project. 

3 To set the project options choose Options > Project Options and click the 
Global Units tab. Set the Frequency as MHz, Time as us and Power/Log as 
dBW.

4 Click the Frequencies tab. Set the frequency Start to �0� MHz, the Stop to 
�200� MHz, and specify the Step as �2� MHz, then click Apply and OK.

5 In the Element Browser System Blocks list, expand the Converters 
category, then click the Mag/Phase subgroup. Select the C2MP block 
(separates complex to magnitude and phase) and place it on the system 
diagram. 

6 Select the MP2C block (combines magnitude and phase to form complex) 
and place/connect it on the system diagram as shown in the following 
figure.
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7 Expand the Math Tools category, then click the Adders subgroup. Select 
the ADD2 block and place/connect it on the system diagram as shown in 
the following figure.

8 Expand the Sources category, then click the Noise subgroup. Select the 
COLORNS block and place/connect it on the system diagram as shown in 
the following figure.

9 Click the Ports category, then place/connect the PORTDIN input data 
port and the PORTOUT output data port on the system diagram as shown 
in the following figure.

10 Right-click Data Files in the Project Browser and choose Import Data File. 
Select Text Data Files as Files of type, then browse to and select the 
�Phmask.txt� file located in the Program Files\ AWR\AWR2003\Examples\
Getting Started\VSS\PHNoise directory. This data file contains noise power 
information for various frequencies.

11 Set the COLORNS block FC parameter to �Phmask� (including quotes), 
the PWR parameter to �-5�, the NFLT parameter to �1024�, and the 
RSEED parameter to �{0}�.

12 In the Project Browser, right-click the �Phase Noise Generator� system 
diagram and choose Export System Diagram. Name the exported file 
�Phase Noise Generator� and save it to the Program Files\AWR\
AWR2003\Examples\Getting Started\VSS\PHNoise directory. This process 
saves the system diagram for future import with a �.sys� extension. 
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Adding Phase Noise to a QAM Signal
To add phase noise to a QAM signal:

1 Add a system diagram to the project named �QAM System�. 

2 Expand the Modulation category, then click the QAM subgroup. Select the 
QAM_SRC block and place it on the system diagram as shown in the 
following figure. Set the MOD parameter to �16-QAM (Gray)� and the 
PLSTYP parameter to Raised Cosine.

3 Expand the RF Blocks category, then click the Behavioral subgroup. Add a 
MIXER_B block to the system diagram as shown in the following figure.

4 Expand the Sources category, then click the Waveforms subgroup. Select 
the SIN_C block and place it on the system diagram as shown in the 
following figure.

5 Set the SIN_C block CTRFRQ parameter to �5200� MHz.

6 Click the Subcircuits category and add the �Phase Noise Generator� 
subcircuit to the system as shown in the following figure.

7 Click the Signal Processing category, select the DECIM block and place 
two of them on the system diagram as shown in the following figure. 

8 Set the DECIM block RATIO parameter to �8� and the DLY parameter to 
�4� for both blocks.

9 Add four test points to complete the system as shown in the following 
figure.
12-16 MWO/VSS 2003



V S S :  V S S  E X A M P L E S
10 Set the MIXER_B block parameters to the values shown in the following 
figure, then click OK.
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Adding Graphs and Analyzing Results
In this section you view the signal constellation with and without adding noise 
to the system.

To add and analyze a constellation graph:

1 Add a constellation graph named �QAM Constellation�.

2 Add two System/IQ measurements to the graph to display the 
constellations at test points TP1 and TP2. Set the Block Diagram to QAM 
System and the Time Span to �1000� for each measurement in the Add 
Measurement dialog box.

3 Add a rectangular graph named �Power Spectrum�.
12-18 MWO/VSS 2003



V S S :  V S S  E X A M P L E S
4 Add a measurement to the �Power Spectrum� graph using the settings in 
the following figure, then click Apply.

5 Repeat the previous step and select TP.TP3 as the Test Point (to display the 
power spectrum at the output of the mixer), then click OK.

6 Run the simulation. The simulation response in the following graph should 
display.

The result is as expected--phase noise results in a rotational pattern more 
predominant at a higher amplitude, as seen in the outer corners of the 
constellation. This is typically due to the up- or downconverter. Gain 
compression is demonstrated by the outer corners of the constellation 
being compressed toward the middle of the display. Gain compression is 
caused by an active device, which in this case is the upconverter.
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7 The simulation response in the following graph should display.
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I/Q Imbalance and Image Rejection Ratio
Any digital transmitter-receiver communication system which comprises analog 
and digital sections is plagued by �in-phase to quadrature-phase� (I-Q) 
imbalance, causing the signal to distort. I-Q imbalance occurs when the 
quadrature-phase signal components of the modulated signal are not perfectly in 
quadrature (separated in-phase by 90-degrees), or are otherwise processed 
unequally, such as the application of differing gain to in-phase and quadrature 
signals when equal gain is desired. I-Q imbalances typically occur at least in the 
analog sections of the communication system, particularly in connection with 
upconversion and downconversion. In this section you study the I-Q imbalance 
in a QAM signal by the effect of either a dirty input signal or a dirty local 
oscillator (LO). You also measure the image rejection ratio (IRR). 

To view the I-Q imbalance in a QAM signal:

1 In the Element Browser, expand the XML Libraries category, then expand 
the RF Blocks subgroup. Click the Imbalance group, then select the 
INP_IMBAL block and place/connect it on the �QAM System� system 
diagram as shown in the following figure. 

2 Disable and bypass the �Phase Noise Generator� subcircuit as shown in the 
following figure
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MIXER_B
ID=A2
MODE=Up converter
FCOUT= 
GCONV=-6 dB
P1DB=130 dBW
IP3=140 dBW
LO2OUT= 
IN2OUT= 
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NF=6 dB
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AMPL=1
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OFFFRQ=0 MHz
CTRFRQ=5200 MHz

DECIM
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RATIO=8
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DLY=4
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RATIO=8
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TP
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OUTLVL=0 dB
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3 Run the simulation. The simulation response in the following graph should 
display. 

The constellation at the output is slightly skewed. You can alter the 
AMPIMBAL and PHAIMBAL parameters and analyze the effect on the 
constellation even further. The system thus simulated has a dirty input 
signal (causing imbalance) and a clean LO. You can also build the system 
with a clean input signal and a dirty LO (causing imbalance). To do so you 
need to remove the INP_IMBAL block and add the LO_IMBAL block 
between the SIN_C block and the �LO� terminal of the MIXER_B block. 
This also causes the output constellation to skew in a similar pattern.

The INP_IMBAL block has an amplitude imbalance of 0.6, a phase 
imbalance of 6 degrees and a DC offset value of 20e-3 (or 0.02). If the DC 
offset value is zero, ideally it should produce an image rejection ratio (IRR) 
of 24 dBW. Here, you display the IRR for tones. 

4 Set the DCoffset parameter of the Input Imbalance subcircuit to �0�.

5 Replace the QAM_SRC block with a copy of the SIN_C block as shown in 
the following figure. Set the new SIN_C block CTRFRQ parameter to 
�5200� MHz and the OFFFRQ parameter to �100� MHz.
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6 Add a rectangular graph named �IRR�.

7 Add a measurement to the graph using the settings in the following figure, 
then click OK. 

IN OUT

LO

MIXER_B
ID=A2
MODE=Up converter
FCOUT= 
GCONV=-6 dB
P1DB=130 dBW
IP3=140 dBW
LO2OUT= 
IN2OUT= 
PLO=-20 dBW
PLOUSE=Spur reference only
PIN=30 dBW
NF=6 dB
NOISE=Off

SIN_C
ID=A3
AMPL=1
PHSOFF=0 Deg
OFFFRQ=0 MHz
CTRFRQ=5200 MHz

DECIM
ID=A4
RATIO=8
PHS=0
DLY=4

DECIM
ID=A5
RATIO=8
PHS=0
DLY=4

TP
ID=TP1

TP
ID=TP2

TP
ID=TP3

TP
ID=TP4

SIN_C
ID=A6
AMPL=1
PHSOFF=0 Deg
OFFFRQ=100 MHz
CTRFRQ=5200 MHz

1 2

SUBCKT
ID=S1
NET="Phaise Noise Generator"

1 2

SUBCKT
ID=S2
NET="Input Imbalance1"
DCoffset=0.02
AMPIMBAL=0.6
PHAIMBAL=6
G e t t i n g  S t a r t e d  G u i d e  12-23



V S S :  V S S  E X A M P L E S1 2
8 Run the simulation. The simulation response in the following graph should 
display. Measure the difference between the power spectrums of two IF 
frequencies, it is almost 24 dBW.
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9 Save and close the project.

END-TO-END 64QAM EXAMPLE

This example presents an advanced end-to-end 64 QAM system. You build the 
system comprising an RF chain and phase noise, and observe the error vector 
magnitude (EVM), adjacent channel power ratio (ACPR), AM-to-AM 
characteristics, and intersymbol interference (ISI) introduced by the filter. 

The procedures in this section include:

� Building the QAM system
� Analyzing the impact of oscillator phase noise
� Analyzing the non-linearities of an amplifier 
� Analyzing ISI and the jitter in the system.
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Building a QAM System
The example you create in this section is available as �64QAM.emp� in your 
Program Files\AWR\AWR2003\Examples\Getting Started\VSS\64QAM 
directory.

To build a QAM system:

1 Create a project named �64QAM�.

2 Add a system diagram named �64QAM System�. 

3 To set the project options choose Options > Project Options and click the 
Global Units tab. Set the Frequency as GHz, Time as ns and Power/Log as 
dBm.

4 Click the Frequencies tab. Set the frequency Start to �27.96� GHz, the 
Stop to �28.04� GHz, and specify the Step as �0.0016� GHz, then click 
Apply and OK.

5 Choose Options > Default System Options and click the Simulator tab. 
Select Data rate (_DRATE) and set its value to �4.6698E-3� GHz, then select 
Oversampling (_SMPSYM) and set its value to �20� samples/symbol. Select 
Stop after and set it to �2e5� ns.

6 Right-click Data Files in the Project Browser and choose Import Data File. 
Browse to and select the �Phmask.txt� file located in the Program 
Files\AWR\AWR2003\Examples\Getting Started\VSS\64QAM directory.

7 Import the �Phase Noise Generator.sys� system diagram file located in the 
Program Files\AWR\AWR2003\Examples\Getting Started\VSS\64QAM 
directory.

8 Right-click Circuit Schematics and import the �RX Filter.sch� file located 
in the Program Files\AWR\AWR2003\Examples\Getting Started\VSS\
64QAM directory.

9 Expand the Modulation category, then click the QAM subgroup. Select the 
QAM_SRC block and place it on the system diagram as shown in the 
following figure. Set the MOD parameter to �64-QAM (Gray)� and the 
OUTLVL parameter to �-30�.

10 Expand the RF Blocks category, then click the Behavioral subgroup. Select 
the MIXER_B block and place/connect it on the system diagram as shown 
in the following figure.

11 To create oscillator phase noise, expand the Sources category, then click 
the Waveforms subgroup. Select the SIN_C (complex sinusoidal) block and 
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place it on the system diagram as shown in the following figure. Set the 
CTRFRQ parameter to �28� GHz.

12 Click the Subcircuits category, then select the �Phase Noise Generator� 
subcircuit and connect it to the LO node of the mixer as shown in the 
following figure.

13 Expand the RF Blocks category, then click the Behavioral subgroup. Select 
the NL_AMP2 block and place/connect it on the system diagram as shown 
in the following figure. Set the GAIN parameter to �29�, the P1DB 
parameter to �28�, the IP3 parameter to �35�, and the IP2H parameter to 
�35�. Click Show Secondary and set the S21MAG parameter to �3.162�.

14 Click the Signal Processing category, then select the PHASE block and 
place/connect it on the system diagram as shown in the following figure.

15 Click the Channels category, then select the AWGN block and place/
connect it on the system diagram as shown in the following figure. Set the 
PWR parameter to �-100� and the RSEED parameter to �{0}�.

16 Click the Signal Processing category, then select the ATTEN block and 
place/connect it on the system diagram as shown in the following figure. 
Set the LOSS parameter to �-22�.

17 Expand the RF Blocks category, then click the Simulation Based subgroup. 
Select the LIN_S block and place/connect it on the system diagram as 
shown in the following figure. Set the NET parameter to �RX Filter�.

18 Add another NL_AMP2 block, PHASE block, and MIXER_B block and 
connect the LO nodes of the two mixers together as shown in the following 
figure.

19 Set the copy of the NL_AMP2 block GAIN parameter to �10�, the P1DB 
parameter to �20�, the IP3 parameter to �40�, and the IP2H parameter to 
�40�. Click Show Secondary and set the S21MAG parameter to �3.162�.

20 Expand the Modulation category, then click the General Receivers 
subgroup. Select and place/connect two RCVR blocks on the system 
diagram as shown in the following figure. 

21 Expand the Meters category, then click the Network Analyzer subgroup. 
Select and place/connect two VSA blocks on the system diagram as shown 
in the following figure. Set the NFFT parameters of both blocks to �1024�.

22 Add six test points in the same order as shown on the system diagram in 
the following figure.
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23 Set both PHASE block SHFT parameters to �180�.

24 Set both MIXER_B block parameters (except the IDs) to the values shown 
in the following figure, then click OK.
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Adding Graphs and Analyzing Results
To add and analyze a constellation and rectangular graph:

1 Add a constellation graph named �RX Constellation�.

2 Add a System/IQ measurement to the graph to display the constellations at 
test point TP6 (the output of the RCVR block). Set the Block Diagram to 
64QAM System and the Time Span to �400�; ensure that the DB check box 
is not selected.

3 Run the simulation. The simulation response in the following graph should 
display. You can clearly see the effect of inter-symbol interference (ISI) 
introduced by the filter on the received signal.

4 Disable and bypass the LIN_S block, then run the simulation again. Notice 
the difference in the signal constellation-- the ISI is minimized. Disabling 
the AWGN block would further reduce the jitter in the system. 

5 Add a rectangular graph named �RX Filter Response�. 

6 Add two Linear/Port Parameters S-parameter measurements for the filter. 
Set the To Port Index to �1� for the first measurement and to �2� for the 
second measurement. For both measurements, set the From Port Index to 
�1�, the Data Source Name to �RX Filter�, and select the DB check box.

7 Add a power spectrum measurement of the signal at test point TP5 using 
the settings in the following figure, then click OK.
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8 Re-enable the LIN_S block and run both the harmonic balance simulator 
and system simulator. The simulation response in the following graph 
should display after adjusting the left and right axes.

27.9533 28.0033 28.0467
Frequency (GHz)

RX Filter Response

-80

-60

-40

-20

0

-100

-70

-40

-10

20

DB(|S(1,1)|) (L)
RX Filter

DB(|S(2,1)|) (L)
RX Filter

DB(PWR_SPEC(TP.TP5,256,1,10,1,-1,0,-1,0,1,0)) (R, dBm)
64QAM System
12-30 MWO/VSS 2003



V S S :  V S S  E X A M P L E S
9 Add a rectangular graph named �EVM� and add a measurement using the 
following settings, then click OK.

Note that the VSA block selected in VSA/Large Signal VNA should be the 
block with the receivers connected to it. Your block ID may differ from the 
VSA.M2 shown in this dialog box.

10 Run the harmonic balance simulator and system simulator. The simulation 
response in the following graph should display.
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11 Add a rectangular graph named �AM to AM�, and using the settings in the 
following figure, add a measurement to analyze the instantaneous AM-to-
AM characteristic of the signal, then click OK.

Note that the VSA block selected in VSA should be the block connected 
across the NL_AMP2 block. Your block ID may differ from the VSA.M1 
shown in this dialog box.

12 Run the harmonic balance simulator and system simulator. The simulation 
response in the following graph should display.
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13 Tune the OUTLVL parameter of the QAM_SRC block and view the impact 
on the constellation graph.

Adjacent-Channel Power Ratio (ACPR)
In this section you observe the adjacent-channel power ratio imposed by the 
nonlinear effect of the power amplifier. You can calculate ACPR in two different 
ways. The first is by finding 10*log of the ratio of the total output power to the 
power in the adjacent channel. The second and most popular method, shown 
here, is finding the ratio of the output power in a smaller bandwidth around the 
center of a carrier, to the power in the adjacent channel. The smaller bandwidth 
is equal to the bandwidth of the adjacent channel signal. In VSS you can 
measure the ACPR at a given signal power or over a range of signal power.

In the following simple example, the channel of interest is centered at 28 GHz 
and has a bandwidth of 15 MHz. The adjacent channel is centered at 28.010 
GHz and also has a bandwidth of 15 MHz. The input carrier signal is centered 
at 28 GHz and has a bandwidth of 15 MHz. 

To measure the ACPR at the signal power of  -30 dBW:

1 Add a tabular graph named �ACPR� and add a measurement using the 
following settings, then click OK.
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Note that the VSA block selected in Vector Signal Analyzer should be the 
block connected across the NL_AMP2 block. Your block ID may differ 
from the VSA.M1 shown in this dialog box.

2 In the VSA block specified above, set the SWPDUR parameter to �10� ns.

3 Start the simulation. The tabulated form displays the ACPR value shown in 
the following table.

To measure the ACPR over a range of signal power:

1 In the QAM_SRC block, set the OUTLVL parameter to 
�sweep(stepped(-30,-10,5))� without the quotes.
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2 Start the simulation again and let it run for a couple of minutes. Notice how 
the ACPR tabular graph updates. You can display the results in a rectangular 
graph by right-clicking ACPR under Graphs in the Project Browser and 
choosing Change Type to > Rectangular. The simulation response in the 
following graph should display.

3 Save and close the project.

MIXER MODELING EXAMPLE

In this example you model a mixer from a given set of intermodulation and 
harmonic suppression (spurs) data. The spur suppressions for the mixer are 
specified through a text data file. You can use different text data file formats to 
specify the spurs.

Here you use the MIXER_F block which implements a behavioral model of the 
nonlinear mixer. This block is normally used to model a specific mixer only 
when the spur table is available, otherwise you should use the MIXER_B block 
instead. 

This procedures in this section include: 

� Modeling a mixer 
� Using various data file formats and verifying the results 
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Setting up the System
The example you create in this section is available in its complete form as 
MIXER.emp. This file is included in your ProgramFiles\AWR\AWR2003\
Examples\Getting Started\VSS\MIXER directory. In this example you model the 
mixers using a given data file and its transpose file and then verify that the two 
instances are identical.

To build a mixer system:

1 Create a project named �Mixer�.

2 To set the project options choose Options > Project Options and click the 
Frequencies tab. Set the frequency Start to �1000� MHz, the Stop to 
�2000� MHz, and specify the Step as �1000� MHz, then click Apply and 
OK. On the Global Units tab, ensure that Frequency is set to �MHz�.

3 Choose Options > Default System Options and click the Simulator tab. 
Select Data rate (_DRATE) and set its value to �1.0e3� MHz, then select 
Oversampling (_SMPSYM) and set its value to �10� samples/symbol. Select 
Stop after and set it to �100� ns.

4 Import the �Mixer1.sys� and �Mixer2.sys� system diagrams located in the 
ProgramFiles\AWR\AWR2003\Examples\Getting Started\VSS\MIXER 
directory. �Mixer1� is shown in the following diagram. Note that these 
diagrams contain several variables which are declared in various element 
parameters.
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5 Import the �mixer1.txt� and �mixer1_T.txt� data files located in the 
ProgramFiles\AWR\AWR2003\Examples\Getting Started\VSS\MIXER 
directory. In the �mixer1� data file, each row represents the input harmonic 
and each column represents the LO harmonic, with the top row and left 
column representing the first harmonic. The �mixer1_T� data file is the 
transpose of the �mixer1� data file with rows representing LO harmonics 
and columns representing the input harmonic.

On the �Mixer1� system diagram:

6 Depending on the type of data file used, you must set the SPURFMT 
parameter accordingly. Verify that the MIXER_1A block has the following 
parameter values. 
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7 In the MIXER_1B block, set SPURS to �mixer1_T�, SPURFMT to           
�LO rows x Inp columns�, and set the remaining parameters to the 
MIXER_1A values as shown in the previous figure. 
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Adding Graphs and Analyzing Results
With FLO=2000MHz, FIn=1950MHz, PLO=+10dBm, PIn=-10dBm, 
GCONV=-7.5dB, the expected tones are shown in the following figure.

To verify these results using the proper graphs:

1 Add a rectangular graph named �Mixer1 Spectrum�. 

2 Add a power spectrum measurement using the settings in the following 
figure, then click Apply.
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3 Set the Test Point to TP.TP3 and click Apply.

4 Set the Test Point to TP.TP2 and RBW/#Bins to �400�, then click OK.

5 Run the simulation. The simulation response in the following graph should 
display after changing your graph�s trace styles and axes to match those 
shown.
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6 Right-click on the graph and choose Marker to measure the values in the 
graph and compare them with those given in the previous table of expected 
values. Move the �+� cursor to the point you want to measure and click to 
display the graph value at that point. The result is as expected, otherwise 
TST2IN would generate an error message. Alter any elements in either of 
the two text data files and run the simulation; an error message is generated. 

Exploring with a Different Data Format
In this example you use a different data format to model the mixer.

To model the mixer using a different data file:

1 Import the �mixer2.txt� data file. This file combines the spur table for three 
different mixers into one data file with all of the tables required to have the 
same number of columns. The first column is the LO power associated 
with a row. The remaining columns specify LO harmonics, with the first 
harmonic corresponding to the second column. The rows represent the 
input harmonic associated with the LO power value in the first column, and 
the first row of a given LO power value representing the first harmonic.

2 Similarly, import the �mixer2_T.txt� data file, the transpose of �mixer2.txt�. 

The expected results for LO=10 dBm are the same as for the �Mixer1� 
system diagram. The expected results for LO=13 dBm are shown in the 
following figure.
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On the �Mixer2� system diagram:

3 In the MIXER_2A mixer block, set the SPURS parameter to �mixer2�, 
SPURFMT to �LO Power(dBm); Inp rows x LO columns�, and leave PLO 
empty.

4 Repeat step 3 for the MIXER_2C mixer block.

5 In the MIXER_2B mixer block, set the SPURS parameter to �mixer2_T�, 
SPURFMT to �LO Power(dBm); LO rows x Inp columns�, and leave PLO 
empty.

6 With this setup, the two mixer instances (MIXER_2A and MIXER_2C) 
check the proper selection of the Spur table based on LO power. 
MIXER_2C uses the portion of the Spur table with LO=10 dBm, while 
MIXER_2A uses the portion with LO=13 dBm. MIXER_2B uses the 
transpose of the data file with the �LO Power(dBm); LO rows x Inp 
columns� setting, which should produce the same result.

7 Create a rectangular graph named �Mixer2 Spectrum� and add a 
measurement using the settings in the following figure, then click Apply.
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8 Repeat the previous step, but set the Test Point to TP.TP2.

9 Run the simulation. The simulation response in the following graph should 
display after changing your graph�s trace styles and axes to match those 
shown.
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10 The results are as expected. Measure the values in the graph and compare 
them with the values in the previous table.

11 Save and close the project.
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